Main Content

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

テキスト ファイル

区切り文字付きテキスト ファイルおよび書式設定付きテキスト ファイル

.csv ファイルや .txt ファイルなど、区切り付きおよび書式設定済みのテキスト ファイルで、数値および非数値データを読み取りおよび書き込みできます。インポート ツールを使用してテキスト ファイル データを対話的にインポートします。このページの関数を使用してテキスト データをプログラムでインポートまたはエクスポートします。

関数

すべて展開する

インポート ツールファイルからデータをインポート

基本的なインポートとエクスポート

readtableファイルからのテーブルの作成
writetableファイルへの table の書き込み
readtimetableファイルからの timetable の作成
writetimetableファイルへの timetable の書き込み

インポートのルールの定義

detectImportOptionsファイルの内容に基づくインポート オプションの作成
delimitedTextImportOptions区切りテキストのインポート オプション オブジェクト
fixedWidthImportOptions固定幅テキスト ファイルのインポート オプション オブジェクト
getvaropts変数インポート オプションの取得
setvaropts変数のインポート オプションの設定
setvartype変数のデータ型の設定
previewインポート オプションを使用してファイルから 8 行をプレビュー
readmatrixファイルからの行列の読み取り
writematrixファイルへの行列の書き込み
readcellファイルからの cell 配列の読み取り
writecellファイルへの cell 配列の書き込み
readvarsファイルからの変数の読み取り
textscanテキスト ファイルまたは文字列から書式付きデータを読み取る
typeファイルの内容の表示
filereadファイルの内容をテキストとして読み取る

オブジェクト

tabularTextDatastore表形式テキスト ファイルのデータ ストア

トピック

テキスト ファイルからの表形式データの読み取り

テキスト ファイルのインポート

テキスト ファイルには、多くの場合数値データおよびテキスト データとともに変数名および行名が混在しており、MATLAB® では table として表現すると最適です。

インポート ツールを使用したテキスト ファイル データの読み取り

テキスト ファイルまたはクリップボードの表形式データをプレビューし、インポート ツールを使用してインポート対象のデータを選択する。

テキスト ファイルから table への混在するデータのインポート

テキスト ファイルの表形式データを MATLAB で表現する最善の方法は table です。table は異種混合 (数値とテキストの混合) データも、変数名や行名も格納できるからです。

テキスト ファイルから table または cell 配列に混在データのブロックをインポート

ブロック書式の表形式データをテキスト ファイルから table または cell 配列にインポートする。

テキスト ファイルから行列への数値データのインポート

readtable を使用してテキスト ファイルから数値表形式データを table としてインポートする他に、このデータを行列として MATLAB ワークスペースにインポートすることもできます。

テキスト ファイルからの数値データ ブロックのインポート

ブロック書式の任意の数値データをテキスト ファイルから cell 配列に読み取る。

大規模な表形式テキスト ファイルの読み取りと解析

次の例では、表形式データを含む大規模なテキスト ファイル用のデータストアを作成し、次にデータを 1 ブロックずつまたは 1 ファイルずつ読み取って処理する方法を説明します。

テキスト ファイルからの日付と時刻のインポート

書式設定済みの日付と時刻 ('01/01/01''12:30:45' など) を列方向の表形式データからインポートする。

テキスト ファイルのコレクションまたはシーケンスの読み取り

テキスト ファイルのコレクションからデータを読み取り、管理する。

テーブルのインポート オプションの定義

欠損データやエラーの処理方法の定義など、関数 readtable により提供されるオプションにないインポート処理を制御する場合は、データをインポートする前にインポート オプション オブジェクトを作成します。

テキスト ファイルへの表形式データの書き込み

テキスト ファイルへのデータの書き込み

table、cell 配列、または数値配列に含まれる表形式データを、MATLAB ワークスペースからテキスト ファイルにエクスポートします。