ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

イメージ ビューアー アプリを使用したイメージの操作

イメージ ビューアー アプリは、イメージの表示と一般的な画像処理タスクの実行のために統合された環境を提供する、イメージの表示と調査のツールです。イメージ ビューアーを使用すると、その他の複数のツールにアクセスできます。

  • ピクセル情報ツール — ポインターを置いたピクセルに関する情報を取得します。

  • ピクセル領域ツール — ピクセルのグループに関する情報を取得します。

  • 距離ツール — 2 つのピクセル間の距離を測定します。

  • イメージ情報ツール — イメージとイメージ ファイル メタデータに関する情報を取得します。

  • コントラスト調整ツールおよび関連するウィンドウ/レベル ツール — イメージ ビューアーに表示されたイメージのコントラストを調整し、実際のイメージ データを変更します。調整したデータはワークスペースまたはファイルに保存できます。

  • イメージ トリミング ツール — イメージのトリミング領域を定義し、イメージをトリミングします。切り取り後のイメージはワークスペースまたはファイルに保存できます。

  • 表示範囲ツール — イメージ データの表示範囲を決定します。

さらに、イメージ ビューアーには大きいイメージの調査に役立つ複数のナビゲーション支援ツールがあります。

  • 概要ツール — 現在イメージ ビューアーに表示されているイメージの部分を特定し、このビューを変更します。

  • 移動ツール - イメージの他の部分を表示するためにそのイメージを移動します。

  • ズーム ツール - イメージの任意部分のクローズアップ ビューを表示します。

  • スクロール バー — イメージでのナビゲーションに使用します。

次の図は、イメージ ビューアーに表示されたイメージを示しています。関連ツールの多くが開かれ、アクティブな状態になっています。

イメージ ビューアー アプリを開く

イメージ ビューアーを起動するには、[アプリ] タブで [イメージ ビューアー] をクリックするか、関数 imtool を使用します。また、[ファイル] メニューの [新規作成] オプションを使用することで、既存のイメージ ビューアー内から別のイメージ ビューアーを起動することもできます。

イメージ データをイメージ ビューアーに表示するには、[ファイル] メニューの [開く] または [ワークスペースからインポート] オプション (ワークスペースからイメージ ビューアー アプリへのイメージ データのインポートを参照) のいずれかを使用します。

さらに、imtool を呼び出す際、イメージ データを格納している MATLAB® ワークスペース変数の名前も指定できます。

moon = imread('moon.tif');
imtool(moon)

代わりに、イメージを格納するグラフィックス ファイルの名前を指定することもできます。次の構文は、複数のグラフィックス ファイルをスキャンするために役立ちます。

imtool('moon.tif');

メモ:

ファイル名を指定する場合、イメージ データは MATLAB ワークスペース変数には保存されません。イメージ ビューアーに表示されたイメージをワークスペースに表示するには、関数 getimage を使用するか、イメージ ビューアーの [ファイル] メニューの [ワークスペースにエクスポート] オプションを使用します (イメージ ビューアー アプリからワークスペースへのイメージ データのエクスポートを参照)。

イメージ ビューアー アプリ内のイメージの初期倍率

イメージ ビューアーは、100% の倍率 (イメージ ピクセルごとに 1 つのスクリーン ピクセル) でイメージ全体を表示しようとしますが、指定した倍率値に常に従います。イメージが大きすぎて画面上の Figure に収まらない場合、イメージ ビューアーではイメージの一部のみが表示されますが、スクロール バーが追加されるので、現在表示されていない部分にも移動できます。指定された倍率ではイメージが大きくなりすぎて画面に収まらない場合は、イメージ ビューアーによってイメージが画面に収まるようにスケールされ、警告は発行されません。これが、'InitialMagnification' のパラメーター値 'adaptive' で指定される既定の動作です。

imtool の特定の呼び出しで、この既定の初期倍率の動作をオーバーライドするには、InitialMagnification パラメーターを指定します。たとえば、150% の倍率でイメージを表示するには、次のコードを使用します。

pout = imread('pout.tif');
imtool(pout, 'InitialMagnification', 150)

また、初期倍率の値として 'fit' を指定することもできます。その場合、imtool は Figure ウィンドウの既定のサイズに合わせてイメージをスケールします。

イメージ ビューアーの既定の初期倍率の動作を変更するもう 1 つの方法は、ツールボックスに ImtoolInitialMagnification を設定する方法です。指定した倍率値は、変更するまで有効です。設定を行うには、iptsetpref を使用するか、Image Processing Toolbox™ の [設定] パネルを開きます。[設定] パネルを開くには、iptprefs を呼び出すか、[イメージ ビューアー] メニューの [ファイル][設定] を選択します。ツールボックスの設定の詳細は、iptprefs を参照してください。

イメージ ビューアーがイメージをスケールする際には、内挿を使用してイメージ行列内の要素と直接対応しないスクリーン ピクセルの値が決定されます。内挿法の指定の詳細については、関数 imresize を使用したイメージのサイズ変更を参照してください。

イメージ ビューアー アプリで使用するカラーマップの選択

カラーマップは、任意数の行を含めることのできる行列ですが、列は 3 つなければなりません。カラーマップ内の各行は、1 番目の要素が赤の強度を指定し、2 番目の要素が緑を指定し、3 番目の要素が青を指定する色として解釈されます。

イメージ ビューアーでインデックス付きのイメージまたはグレースケール イメージの表示に使用するカラーマップを指定するには、[ツール] メニューで [カラーマップの選択] オプションを選択します。これにより、カラーマップの選択ツールがアクティブになります。このツールを使用して、MATLAB カラーマップの 1 つを選択するか、MATLAB ワークスペースからカラーマップ変数を選択できます。

カラーマップを選択すると、イメージ ビューアーで指定したカラーマップ関数が実行され、表示されているイメージが更新されます。カラーマップは、[カラーマップの評価] テキスト ボックスで編集できます。たとえば、カラーマップ内のエントリ数 (既定の設定は 256) を変更できます。このフィールドには独自のカラーマップ関数を入力できます。Enter キーを押して、コマンドを実行します。

カラーマップを選択すると、新しいマップを使用するようにイメージが更新されます。[OK] をクリックすると、イメージ ビューアーでカラーマップが適用され、[カラーマップの選択] ツールは閉じられます。[キャンセル] をクリックすると、イメージは前のカラーマップに戻ります。

ワークスペースからイメージ ビューアー アプリへのイメージ データのインポート

MATLAB ワークスペースからイメージ ビューアーにイメージ データをインポートするには、イメージ ビューアーの [ファイル] メニューの [ワークスペースからインポート] オプションを使用します。下に示したダイアログ ボックスで、ワークスペースにインポートするワークスペース変数を選択します。

次の図は、[ワークスペースからインポート] ダイアログ ボックスを示しています。[フィルター] メニューを使用すると、リストに含まれるイメージをバイナリ、インデックス付き、強度 (グレースケール)、トゥルーカラーなどの特定のイメージ タイプに制限することができます。

イメージ ビューアー アプリからワークスペースへのイメージ データのエクスポート

イメージ ビューアーに表示されたイメージを MATLAB ワークスペースにエクスポートするには、イメージ ビューアーの [ファイル] メニューの [ワークスペースにエクスポート] オプション、または関数 getimage を使用します (データをエクスポートする場合、表示範囲の変更は保存されません)。下に示したダイアログ ボックスで、ワークスペース内の変数に割り当てる名前を指定します。既定の設定では変数名フィールドは自動的に入力されます。バイナリ イメージの場合は BW、トゥルーカラー イメージの場合は RGB、グレースケールまたはインデックス付きイメージの場合は I になります。

イメージ ビューアーにインデックス付きイメージが含まれる場合、このダイアログ ボックスには関連するカラーマップの名前を指定するためのフィールドも含まれます。

関数 getimage を使用して、イメージ ビューアーからイメージ データを MATLAB ワークスペースに取り込むこともできます。

関数 getimage は、現在の image オブジェクトからイメージ データ (CData) を取得します。イメージ ビューアーに表示されている image オブジェクトを取得するには、ツールボックス関数 imgca を使用します。次の例では、対象の Figure ウィンドウが現在アクティブな場合に、moon.tif のイメージ データを変数 moon に割り当てます。

moon = getimage(imgca);

イメージ ビューアーに表示されたイメージ データの保存

イメージ ビューアーに表示されたイメージ データを保存するには、イメージ ビューアーの [ファイル] メニューで [名前を付けて保存] オプションを選択します。次の図に示す [イメージの保存] ダイアログ ボックスが開きます。このダイアログ ボックスを使用して、ファイル システムをナビゲートし、イメージ ファイルの保存場所を決定し、ファイル名を指定します。[ファイルの種類] メニューに表示されたイメージ ファイル形式から必要なグラフィックス ファイル形式を選択します。ファイル名拡張子を指定しない場合は、JPEG 形式の .jpg など、選択したファイル形式に関連付けられているファイル拡張子がイメージ ビューアーによって追加されます。

メモ

表示範囲に加えた変更は保存されません。変更を保存するには imcontrast を使用してください。

イメージ ビューアー アプリを閉じる

イメージ ビューアーを閉じるには、ウィンドウのタイトル バーの [閉じる] ボタンを使用するか、イメージ ビューアーの [ファイル] メニューから [閉じる] オプションを選択します。関数 imtool を使用してイメージ ビューアーを起動した場合は、アプリが含まれている figure オブジェクトを取得できます。このオブジェクトを使用してアプリを閉じることができます。イメージ ビューアーを閉じると、現在開いている関連ツールもすべて閉じられます。

イメージ ビューアーではコンポーネントのグラフィックス オブジェクトが表示されないので、MATLAB の close all コマンドを呼び出してもイメージ ビューアーは終了しません。複数のイメージ ビューアーを閉じるには、次の構文を使用します。

imtool close all

または、イメージ ビューアーの [ファイル] メニューから [すべて閉じる] を選択します。

イメージ ビューアー アプリに表示されたイメージの印刷

イメージ ビューアーに表示されたイメージ データを出力するには、[ファイル] メニューで [Figure に出力] を選択します。イメージ ビューアーにより別の Figure ウィンドウが開かれ、イメージが表示されます。この Figure ウィンドウの [ファイル] メニューの [印刷] オプションを使用して、イメージを印刷します。詳細は、イメージの印刷 を参照してください。