ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

イメージ ビューアー アプリでのイメージ コントラストの調整

コントラスト調整ツールを開く

この節では、イメージ ビューアーでコントラスト調整ツールを使用する方法について説明します。

  1. イメージ ビューアーでイメージを表示します。

    imtool('moon.tif')

    また、関数 imcontrast を呼び出して、イメージ ビューアーからではなく、単独でコントラスト調整ツールを使用することもできます。

  2. イメージ ビューアーのツール バーの [コントラスト調整] をクリックするか、イメージ ビューアーの [ツール] メニューから [コントラスト調整] オプションを選択します。コントラスト調整ツールが新しいウィンドウで開きます。このウィンドウには、イメージ ビューアーに表示されているイメージのヒストグラムが含まれています。ヒストグラムは、イメージの "データ範囲" とイメージの表示範囲を示します。データ範囲は、実際にイメージで使用される強度値の範囲です。表示範囲はイメージの表示に使用される黒から白のマッピングです。これはイメージ クラスによって決まります。コントラスト調整ツールは表示範囲を操作することによって機能します。イメージのデータ範囲は一定です。

    たとえば、次の図ではイメージのヒストグラムは、イメージのデータ範囲が 74 ~ 224 であり、表示範囲が uint8 クラスの既定の表示範囲 0 ~ 255 であることを示しています。イメージのピクセル値が表示範囲の中央に集まっています。コントラストを調整すると、表示範囲全体にピクセル値が分散され、イメージがより詳細に表示されます。

    イメージのコントラストを調整するには、"ウィンドウ" と呼ばれる赤みがかった四角形のボックスを操作します。このボックスはコントラスト調整ツールによってヒストグラムの上に表示されます。このウィンドウのサイズと位置をマウスで変更することで、イメージの表示範囲を変更し、そのコントラストと輝度を改善できます。ヒストグラム ウィンドウを使用したイメージ コントラストの調整を参照してください。

メモ:

また、ウィンドウ/レベル ツールを使用して、コントラストと輝度をマウスで調整することもできます (名前は医学アプリケーションに由来します)。イメージ ビューアーのツール バーで [ウィンドウ/レベル] をクリックするか、またはイメージ ビューアーの [ツール] メニューから [ウィンドウ/レベル] オプションを選択します。ウィンドウ/レベル ツールの使用方法の詳細は、ウィンドウ/レベル ツールを使用したイメージ コントラストの調整を参照してください。

コントラスト調整ツールを閉じても、ウィンドウ/レベル ツールはアクティブなままです。ウィンドウ/レベル ツールをオフにするには、[ウィンドウ/レベル] ボタン をクリックするか、またはイメージ ビューアーのツール バーでいずれかのナビゲーション ボタンをクリックします。

ヒストグラム ウィンドウを使用したイメージ コントラストの調整

コントラスト調整ツールを使用してイメージ コントラストを調整するには、以下のいずれかの方法で、ヒストグラムの上に表示される赤みがかったウィンドウのサイズを操作します。

  • ウィンドウの左右の端にあるいずれかの赤いハンドルをつかんでドラッグする。中央の線をつかみ、ウィンドウを右または左にドラッグすることで、ウィンドウの位置を変更することもできます。

  • [最小値] および [最大値] フィールドでウィンドウのサイズと位置を指定する。これらのフィールドに関連付けられたスポイト ボタンをクリックすることで、これらの値を定義することもできます。これを行うと、ポインターはスポイトの形状になります。最小 (または最大) 値にするイメージ内のピクセルの上にスポイト ポインターを置き、マウスのボタンをクリックします。

  • [幅] および [中心] フィールドでウィンドウのサイズと位置を指定する。

  • ツールの [表示範囲のスケーリング] 部分の [データ範囲の一致] ボタンを選択する。このオプションを選択すると、ウィンドウのサイズが既定の表示範囲からイメージのデータ範囲に変わります。

  • イメージのデータ範囲の上下にある外れ値をトリミングする。[外れ値の排除] オプションを選択すると、コントラスト調整ツールにより上の 1% と下の 1% が削除されますが、他の割合を指定することもできます。割合を指定すると、その半分の割合が上に、残りの半分が下に割り当てられます (関数 stretchlim を使用して同じ操作を行うことができます)。

次の図は、これらのコントラスト調整方法を示しています。ウィンドウのサイズを変更すると、イメージ ビューアーの右下隅に表示される表示範囲の値が更新されます。

ウィンドウ/レベル ツールを使用したイメージ コントラストの調整

ウィンドウ/レベル ツールを起動するには、イメージ ビューアーのツール バーの [ウィンドウ/レベル] をクリックします。

ウィンドウ/レベル ツールを使用すると、マウスをイメージの上にドラッグするだけで、イメージのコントラストと輝度を変更できます。マウスを水平方向に動かすとコントラストの変更、垂直方向に動かすと輝度の変更になります。ウィンドウ/レベル ツールを使用して行うコントラスト調整は、コントラスト調整ツールに即座に反映されることに注意してください。たとえば、輝度を上げると、コントラスト調整ツールのウィンドウがヒストグラムの上に移動します。

次の表は、これらのマウスの動きがコントラスト調整ツールのウィンドウのサイズおよび位置にどのように影響するかをまとめています。

マウスの動き

 

効果

水平方向に左へ

両側からウィンドウが縮小します。

水平方向に右へ

両側からウィンドウが拡大します。

垂直方向に上へ

ウィンドウがヒストグラム上の右側に移動し、輝度が高くなります。

垂直方向に下へ

ウィンドウがイメージのヒストグラム上の左側に移動し、輝度が低くなります。

ウィンドウ/レベル ツールを停止するには、イメージ ビューアーのツール バーの [ウィンドウ/レベル] ボタンをクリックするか、ツール バーの任意のナビゲーション ボタンをクリックします。

ウィンドウ/レベル ツールによるコントラストの調整

  1. ツールボックスに含まれるサンプル DICOM ファイルからイメージを読み取ります。

    I = dicomread('CT-MONO2-16-ankle.dcm');
  2. イメージ ビューアーを使用してイメージ データを表示します。イメージ データは符号付き 16 ビット データなので、この例では自動スケーリング構文を使用します。

    imtool(I,'DisplayRange',[])
  3. [ウィンドウ/レベル] ボタン をクリックしてツールを起動するか、イメージ ビューアーの [ツール] メニューから [ウィンドウ/レベル] を選択します。

  4. ポインターを画像上に移動します。ポインターがウィンドウ/レベル カーソル に変わります。

  5. 左 (または右) マウス ボタンをクリック アンド ドラッグして、ポインターを水平方向に左または右に移動してコントラストを調整するか、垂直方向に上または下に移動して輝度を変更します。

コントラスト調整の反映

既定の設定では、コントラスト調整ツールはイメージ ビューアーでイメージを表示するために使用されるピクセルの値を調整しますが、実際のイメージ データは変更されません。イメージ内のピクセル値を変更し、実行したコントラストの調整を反映させるには、[データの調整] ボタンをクリックしなければなりません。

次の例はこのプロセスを説明します。

  1. イメージ ビューアーでイメージを表示します。この例では、ファイルからイメージを開きます。

    imtool('moon.tif');
  2. [コントラスト調整] ボタン をクリックするか、イメージ ビューアーの [ツール] メニューから [コントラスト調整] を選択してコントラスト調整ツールを起動します。

  3. イメージのコントラストを調整します。ヒストグラム上のウィンドウのサイズ変更など、コントラスト調整ツールによって提供されるいずれかの方法を使用してください。ヒストグラム ウィンドウを使用したイメージ コントラストの調整を参照してください。また、ウィンドウ/レベル ツールを使用し、ポインターをイメージの上に移動して、コントラストを調整することもできます。

  4. イメージ データを調整し、今行ったコントラストの調整を反映します。コントラスト調整ツールの [データの調整] ボタン をクリックします。[データの調整] ボタンをクリックすると、ヒストグラムが更新されます。次に、必要に応じてコントラストを再調整します。他の対話型モジュラー ツールのウィンドウを開いている場合は、それらのウィンドウも自動的に更新され、コントラストの調整が反映されます。

    メモ

    [データの調整] ボタンは、イメージのコントラストを変更するまで使用できません。

変更したイメージ データの保存

既定の設定では、イメージ ビューアーを閉じると、変更したイメージ データは保存されません。これらの変更した値を保存するには、イメージ ビューアーの [ファイル] メニューの [名前を付けて保存] オプションを使用して変更したデータをファイルに保存するか、[ワークスペースにエクスポート] オプションを使用して変更したデータをワークスペース変数に保存します。