ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

イメージ ビューアー アプリでのピクセル情報の取得

イメージ ビューアーでの個々のピクセル値の特定

イメージ ビューアーではイメージ内の個々のピクセルの場所と値に関する情報がツールの左下隅に表示されます (imshow を使用して Figure を開き、コマンド ラインから impixelinfo を呼び出してもこの情報を取得できます)。ピクセルの値と位置の情報は、ポインターの現在位置の下のピクセルを表します。イメージ上でポインターを動かすと、イメージ ビューアーでこの情報が更新されます。

たとえば、イメージ ビューアーでイメージを表示するには以下のように入力します。

imtool('moon.tif')

次の図は、ピクセル情報ツールにピクセルの位置と値が表示されたイメージ ビューアーを示しています。詳細は、ピクセル値と位置の情報の保存を参照してください。

ピクセル値と位置の情報の保存

表示されたピクセルの位置と値の情報を保存するには、イメージ内のピクセルを右クリックし、[ピクセル情報のコピー] オプションを選択します。イメージ ビューアーは x 座標および y 座標とピクセル値をクリップボードにコピーします。

このピクセル情報を MATLAB® ワークスペースまたは別のアプリケーションに貼り付けるには、右クリックして表示されたコンテキスト メニューから [貼り付け] を選択します。

イメージの領域内でのピクセル値の特定

イメージ ビューアーに表示されているイメージの特定の領域内のピクセル値を表示するには、ピクセル領域ツールを使用します。ピクセル領域ツールは、イメージ ビューアーに表示されたイメージの上に "ピクセル領域四角形" と呼ばれる四角形を重ねて表示します。この四角形は、ピクセル領域ツール ウィンドウに極端なクローズアップ ビューで表示されるピクセルのグループを定義します。次の図は、ピクセル領域ツールを使用した場合のイメージ ビューアーを示しています。ピクセル領域ツールでは、表示された各ピクセルの値がどのように含まれるかを確認してください。

以下の節では、ピクセル領域ツールの使用に関する詳細を説明します。

領域の選択

  1. ピクセル領域ツールを起動するには、イメージ ビューアーのツール バーで [ピクセル領域] ボタン をクリックするか、[ツール] メニューから [ピクセル領域] オプションを選択します。(別のオプションとして、imshow を使用して Figure を開き、コマンド ラインから impixelregion を呼び出すこともできます)。イメージ ビューアーはターゲット イメージの中央にピクセル領域四角形 を表示し、ピクセル領域ツールを開きます。

    メモ:

    イメージをスクロールすることは、現在表示されているイメージの部分からピクセル領域四角形を移動することになります。ピクセル領域四角形を現在表示されているイメージ部分の中央に戻すには、ピクセル領域ボタンを再度クリックしてください。大きいイメージ内でピクセル領域ツールを見つける方法は、ピクセル領域四角形の位置の決定を参照してください。

  2. マウスを使用して、ピクセル領域四角形上にポインターを配置します。ポインターは、花形 に変化します。

  3. 左マウスボタンをクリックして、ピクセル領域四角形をイメージの任意の部分にドラッグします。ピクセル領域四角形をイメージ上で移動すると、ピクセル領域ツールによって表示されるピクセル値が更新されます。さらに、ピクセル領域ツール ウィンドウのスクロール バーを動かすことによってもピクセル領域四角形を移動することができます。

表示のカスタマイズ

イメージ ピクセルのクローズアップを取得するには、ピクセル領域ツールのツール バーのズーム ボタンを使用します。ズーム インするとピクセル領域ツールで表示されるピクセルのサイズが大きくなり、表示されるピクセル数が少なくなります。ズーム アウトするとピクセル領域ツールで表示されるピクセルのサイズが小さくなり、表示されるピクセル数が多くなります。倍率を変更せずに、ツールで表示されるピクセル数を変更するには、マウスを使用してピクセル領域ツールのサイズを変更します。

ズーム インまたはズーム アウトに伴い、ピクセル領域四角形のサイズが倍率に従ってどのくらい変化するかを確認してください。ピクセル領域四角形のサイズは、マウスを使用して変更できます。ピクセル領域四角形のサイズを変更すると、ピクセル領域ツール内に表示されるピクセルの倍率も変更されます。

倍率によっては、ピクセル領域ツールで各ピクセルの上に数値が表示されます。RGB イメージの場合、この情報にはイメージの帯域ごとに 1 つ、合計 3 つの数値が含まれます。インデックス付きイメージの場合、この情報にはインデックス値、および関連する RGB 値が含まれます。表示に数値を含めない場合は、ピクセル領域ツールの [編集] メニューで [ピクセル値の重ね書き] オプションをオフにします。

ピクセル領域四角形の位置の決定

ターゲット イメージ内のピクセル領域の位置を特定するには、ツールの下部に表示されたピクセル情報を使用します。この情報には、ターゲット イメージの座標系のピクセルの x 座標および y 座標が含まれます。ピクセル領域四角形をターゲット イメージ上に移動すると、カーソルをピクセル領域ツールに戻すまで、下部に表示されたピクセル情報は更新されません。

さらに、ピクセル領域ツールの [編集] メニューから [位置のコピー] オプションを選択することにより、ピクセル領域四角形の現在位置を取得できます。このオプションは、位置情報をクリップボードにコピーします。位置情報は、[xmin ymin width height] の形式のベクトルです。

この位置ベクトルを MATLAB ワークスペースまたは別のアプリケーションに貼り付けるには、右クリックして表示されたコンテキスト メニューから [貼り付け] を選択します。

次の図は、ピクセル領域ツールのこれらの要素を示しています。

ピクセル領域ツールでのイメージ表示の印刷

ピクセル領域ツールに表示されたイメージを印刷できます。ピクセル領域ツールの [ファイル] メニューから [Figure に出力] オプションを選択します。詳細は、イメージの印刷 を参照してください。

イメージ ビューアーでのイメージ表示範囲の特定

イメージ ビューアーではグレースケール イメージのピクセルの表示範囲に関する情報が提供されます。表示範囲は軸 CLim プロパティの値です。この値はイメージ CData の Figure のカラーマップへのマッピングを制御します。CLim は 2 要素のベクトル [cmin cmax] で、カラーマップ (cmin) 内の最初の色にマップする CData 値、およびカラーマップ (cmax) 内の最後の色にマップする CData 値を指定します。間のデータ値は、線形にスケーリングされます。

イメージ ビューアーではウィンドウの右下隅の表示範囲ツールにこの情報が表示されます。イメージ ビューアーは、インデックス付きイメージ、トゥルーカラー イメージまたはバイナリ イメージの表示範囲は表示しません (imshow を使用して Figure ウィンドウを開き、コマンド ラインから imdisplayrange を呼び出してもこの情報を取得できます)。

たとえば、イメージ ビューアーでイメージを表示するには以下のように入力します。

imtool('moon.tif')

次の図は、表示範囲情報がイメージと共に表示されているイメージ ビューアーを示しています。