ドキュメンテーション

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

イメージ ビューアー アプリを使用したイメージのトリミング

イメージの切り取りは、元のイメージの一部から新しいイメージを作成することを意味します。イメージ ビューアーを使用してイメージをトリミングするには、イメージ トリミング ツールを使用します。イメージ トリミング ツールを使用するには、以下の手順に従います。

既定の設定では、イメージ ビューアーを閉じると、変更したイメージ データは保存されません。トリミングしたイメージを保存するには、イメージ ビューアーの [ファイル] メニューの [名前を付けて保存] オプションを使用して変更したデータをファイルに保存するか、[ワークスペースにエクスポート] オプションを使用して変更したデータをワークスペース変数に保存します。

  1. イメージ ビューアーでイメージを表示します。

    I = imread('moon.tif');
    imtool(I)
  2. イメージ ビューアーのツール バーの [イメージのトリミング] をクリックするか、イメージ ビューアーの [ツール] メニューから [イメージのトリミング] を選択してイメージ トリミング ツールを起動します。(別のオプションとして、関数 imshow を使用して Figure ウィンドウを開き、コマンド ラインから関数 imcrop を呼び出すこともできます)。ポインターをイメージ上に移動すると、ポインターが十字 に変わります。

  3. イメージ上でマウスをクリック アンド ドラッグすることにより、四角形のトリミング領域を定義します。トリミング対象の四角形を微調整するには、マウスでトリミング対象の四角形を移動してサイズを変更します。または、別の領域をトリミングする場合は、別の位置に移動して再度クリック アンド ドラッグします。イメージ トリミング ツールがアクティブの場合にイメージ上で拡大または縮小するには、Ctrl+Plus キーまたは Ctrl+Minus キーを使用します。これらは、キーボードの数値キーパッドの Plus(+) キーと Minus(-) キーです。次の図は、イメージ トリミング ツールを使用して定義されているトリミング四角形を示しています。

  4. トリミング領域の定義を完了したら、トリミング操作を行います。マウスの左ボタンでダブルクリックするか、領域内で右クリックして、コンテキスト メニューから [イメージのトリミング] を選択します。イメージ ビューアーにトリミングされたイメージが表示されます。他の対話型モジュラー ツールを開いている場合は、それらのツールも更新され、新たに切り取られたイメージが表示されます。

  5. トリミングしたイメージを保存するには、イメージ ビューアーの [ファイル] メニューにある [名前を付けて保存] オプションまたは [ワークスペースにエクスポート] オプションを使用します。