Main Content

ビデオ ビューアー アプリでのイメージ シーケンスの表示

この節では、ビデオ ビューアー アプリを使用してイメージ シーケンスを表示する方法を説明し、アプリの構成に関する情報を提供します。

ビデオ ビューアー アプリでデータを開く

この例では、ビデオ ビューアーでマルチスライス ボリューム データを表示する方法を説明します。

イメージ シーケンスを MATLAB® ワークスペースに読み込みます。この例では、ファイル mristack.mat から MRI データを読み込みます。このファイルは imdata フォルダーにあります。これにより、mristack という名前の変数がワークスペース内に作成されます。変数は、脳の MRI イメージを含んでいる 21 のグレースケール フレームの配列です。各フレームは uint8 データの 256 行 256 列の配列です。

load mristack
mristack       256x256x21       1276256     uint8

アプリ ギャラリーでビデオ ビューアーをクリックし、[ファイル] メニューで [ワークスペースからインポート] オプションを選択します。または、イメージ シーケンス変数の名前を引数として指定して関数 implay を呼び出します。

implay(mristack)

ビデオ ビューアーが開き、イメージ シーケンスの最初のフレームが表示されます。各フレームのサイズやフレームの総数といったイメージ シーケンスに関する情報が、ビデオ ビューアーのウィンドウの下部にどのように表示されるかを確認してください。

Video Viewer app displaying one frame of a grayscale image sequence, information about the video, and playback controls.

再生制御を使用したイメージ シーケンスの調査

イメージ シーケンスまたはビデオをアニメーションとして表示するには、再生ツール バーの [再生] ボタン をクリックするか、[再生] メニューから [再生] を選択するか、P またはスペース バーを押します。既定の設定では、ビデオ ビューアーはイメージ シーケンス全体を一度だけ正方向に再生しますが、下の表で説明するように、さまざまな方法でイメージ シーケンス内のフレームを表示できます。イメージ シーケンスを表示すると、ビデオ ビューアーのウィンドウの下部にあるステータス バーが更新されます。

表示オプション再生制御キーボード ショートカット
イメージ シーケンスを再生する方向を指定します。再生ツール バーの再生モード ボタン をクリックするか、[再生] メニューから [再生モード] を選択します。[正方向に再生]、[逆方向に再生] または [オートリバース再生] を選択できます。ビデオ ビューアーで再生モード ボタンをクリックするたびに、これらのオプションが順番に切り替わり、現在選択されているオプションが表示されます。ビデオ ビューアーでは、現在のフレーム表示にプラス (+) とマイナス (-) の記号で再生方向が示されます。ビデオを逆再生する場合、負のフレーム番号が表示されます。オートリバース モードの場合、ビデオ ビューアーはプラス記号で正方向を示します。A
シーケンスを繰り返し表示します。再生ツール バーの [繰り返し] ボタン をクリックするか、[再生] メニューから [再生モード] > [繰り返し] を選択します。このオプションのオン/オフを切り替えます。R
シーケンス内の特定のフレームにジャンプします。再生ツール バーの [ジャンプ先] ボタン をクリックするか、[再生] メニューから [ジャンプ先] を選択します。このオプションによって、フレーム数を指定できるダイアログ ボックスが開きます。 J
シーケンスを停止します。再生ツール バーの [停止] ボタン をクリックするか、[再生] メニューから [停止] を選択します。このボタンは、イメージ シーケンスの再生時のみ有効になります。S
一度に 1 フレームのシーケンスのステップ実行、またはシーケンスの最初と最後へのジャンプ (巻き戻し) を行います。再生ツール バーにあるいずれかのナビゲーション ボタン (目的の方向) をクリックするか、[再生] メニューから [早送り][巻き戻し] などのオプションを選択します。

矢印キー、PageUp/PageDown

L (最後のフレーム)、F (最初のフレーム)

フレームの詳細な調査

ビデオ ビューアーは [ツール] メニューおよびツール バーにリストされているいくつかのツールをサポートしています。これらのツールを使用してイメージ シーケンス内のフレームをより詳細に調べることができます。

表示オプション再生制御
イメージを拡大または縮小し、移動して表示を変更します。 ツール バーのいずれかのズーム ボタン をクリックするか、[ツール] メニューから [ズームイン] または [ズームアウト] を選択します。ツール バーの [移動] ボタン をクリックするか、[ツール] メニューから [移動] を選択します。ツール バーの [ウィンドウに合わせて表示] ボタン をクリックするか、[ツール] メニューから [ウィンドウに合わせて表示] を選択すると、ズームおよび移動のボタンが無効になります。
現在のフレームの領域を詳細に検査します。 再生ツール バーにある [ピクセル領域] ボタン をクリックするか、または [ツール] メニューから [ピクセル領域] を選択します。
フレームをイメージ ビューアーにエクスポートします。再生ツール バーの [イメージ ツールにエクスポート] ボタン をクリックするか、[ファイル] メニューから [イメージ ツールにエクスポート] を選択します。ビデオ ビューアーによってイメージ ビューアー アプリが開かれ、現在のフレームが表示されます。

フレーム レートの指定

再生レートを上げ下げするには、[再生] メニューから [フレーム レート] を選択するか、キーボード ショートカット T を使用します。[フレーム レート] ダイアログ ボックスにはソースのフレーム レートが表示されます。ここでは、ビデオ ビューアーがイメージ シーケンスまたはビデオを再生するレートを変更でき、実際の再生レートが表示されます。"再生レート"ビデオ ビューアーが 1 秒間に処理するフレーム数です。

Frame Rate dialog box with the source rate at 20 frames/sec and a field to set the desired playback rate.

実際の再生レートを上げたいが、システムのハードウェアが希望のレートに対応できない場合は、[希望の再生レートを達成するためにフレームの低下を許可する] チェック ボックスをオンにします。このパラメーターはコマ落ちさせることでビデオ ビューアーが再生レートを実現できるようにします。このオプションを選択すると、[フレーム レート] ダイアログ ボックスにいくつかの追加オプションが表示されます。これらを使用して最小と最大の更新レートを指定できます。これがハードウェアで許容される場合は、更新レートを上げてより滑らかな再生を実現します。ただし、更新レートに狭い範囲を指定すると、計算されるフレーム再生スケジュールが不規則な再生の原因となる可能性があり、警告が表示されます。

カラーマップの指定

カラーマップを指定して強度値に適用するには、[ツール] メニューから [カラーマップ] を選択するか、キーボード ショートカット C を使用します。ビデオ ビューアーにカラーマップを変更するダイアログ ボックスが表示されます。

Colormap tool with the default colormap of gray(256) selected.

[カラーマップ] パラメーターを使用して、特定のカラーマップを指定します。

ピクセル値がデータ型の全範囲を使用しないことがわかっている場合は、[表示されるピクセル値の範囲を指定します] チェック ボックスをオンにして、データの範囲を入力できます。ダイアログ ボックスには、ピクセル値のデータ型に基づいた範囲が自動的に表示されます。

イメージ シーケンスに関する情報の取得

イメージ データに関する基本情報を表示するには、ツール バーの [ビデオ情報] ボタン をクリックするか、[ツール] メニューから [ビデオ情報] を選択します。ビデオ ビューアーにより、各フレームのサイズ、フレーム レート、フレームの総数といったイメージ シーケンスに関する基本情報を示すダイアログ ボックスが表示されます。

Video Information dialog box showing that the video is grayscale with frame height of 256 pixels, frame width of 256 pixels, data type of uint8, and other information.

ビデオ ビューアー アプリの構成

[構成] ダイアログ ボックスでは、プレーヤーの外観と動作を変更できます。[構成] ダイアログ ボックスを開くには [ファイル][構成][編集] を選択します。既存の構成セットを読み込むには [ファイル][構成][読み込み] を選択します。

[構成] ダイアログ ボックスには、次の 4 つのタブがあります。[コア]、[ソース]、[ビジュアル] および [ツール]。各タブでは、カテゴリを選択し、[プロパティ] をクリックして構成の設定値を表示することができます。

Configuration dialog box showing the Core tab with two settings: General UI and Source UI.

次の表は、すべてのペインの各カテゴリで使用できるオプションの一覧です。

ペインオプションのカテゴリオプションの説明
コア一般的な UI

[絶対パスを表示] チェック ボックス — タイトル バーにビデオ データ ソースへの絶対パスを表示する場合はオンにします。既定の設定では、ビデオ ビューアーのタイトル バーに省略された名前が表示されます。

コアソース UI

[キーボード コマンドはソース再生モードを優先します] チェック ボックス — キーボード ショートカット キーに再生モードの選択を認識させる場合にオンにします。このチェック ボックスをオフにすると、キーボード ショートカット キーは、再生モードが [正方向に再生] に設定され、[繰り返し]off に設定されているものとして動作します。

[最近利用したソースのリスト] パラメーター — [ファイル] メニューに示されるソースの数を指定します。

ソースSimulink

[Simulink モデルが開いていない場合は読み込む] チェック ボックス — Simulink がインストールされていなければなりません。

[次を選択する場合はスコープを接続] — 信号線のみまたは信号線とブロックです。Simulink がインストールされていなければなりません。

ソースファイル

[開くファイルの既定のパス] パラメーター — [ファイル]、[開く] をクリックしたときに [ファイルに接続] ダイアログ ボックスに表示されるディレクトリを指定します。

ソースワークスペース

この選択に関連付けられているオプションはありません。

ビジュアルビデオ

この選択に関連付けられているオプションはありません。

ツールイメージ ツール

[エクスポートごとに新たな [イメージ ツール] ウィンドウを開く] チェック ボックス — エクスポートされるフレームごとに新しいイメージ ビューアーを開きます。

ツールピクセル領域

この選択に関連付けられているオプションはありません。

ツールイメージ ナビゲーション ツール

この選択に関連付けられているオプションはありません。

ツール計測セット

この選択に関連付けられているオプションはありません。

ビデオ ビューアー アプリの構成設定の保存

後で使用するために構成設定を保存するには [ファイル][構成セット][名前を付けて保存] を選択します。

メモ

既定の設定では、ビデオ ビューアーはファイル implay.cfg の構成設定を使用します。このファイルに構成設定を保存する場合は、最初にファイルのバックアップ コピーを作成します。