Main Content

最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

モデル エクスプローラー

Simulink モデル、Stateflow チャートおよびワークスペース変数の要素の表示、変更および追加

説明

モデル エクスプローラーを使用して、Simulink モデル、Stateflow® チャートおよびワークスペース変数の要素を表示、変更および追加する

モデル エクスプローラーを使うと、モデルやチャート内を移動することなく、特定の要素 (ブロック、信号、プロパティなど) に注目できます。

モデル エクスプローラーを使用して、以下を検索します。

  • ワークスペースおよびデータ ディクショナリの変数

  • モデル内における変数の使用

  • ブロック タイプのインスタンス

  • ブロック パラメーターとパラメーターの値

検索結果を使用して、複数の要素に対して変更を一度に適用できます。

モデルのデータ (ブロック パラメーター、信号、状態) を検索と並べ替えが可能なテーブルで操作するには、モデル データ エディターの使用を検討してください。パラメーターの値、信号の名前、状態の初期値などのデータ属性を指定できます。モデル データ エディターを使用したデータ プロパティの設定を参照してください。

データ ディクショナリでエントリを作成、変更、表示するには、モデル エクスプローラーを使用します。モデル エクスプローラーを使用したワークスペース変数の編集と管理およびディクショナリ データの変更表示と変更取り消しを参照してください。

ビューのカスタマイズ

標準のビューではニーズが満たされない場合は、ビューを変更するか、新しいビューを作成できます。

現在のビューが表すオブジェクト プロパティ表はカスタマイズできます。オブジェクト プロパティ表を変更すると、現在のビュー定義も変更されます。

モデル エクスプローラーはオブジェクト プロパティ表に対する次の変更を列ビュー定義の一部として保存します。

  • プロパティによるグループ化

  • 列内の並べ替え

  • プロパティ列の順序の変更

  • プロパティ列の追加

  • プロパティ列の非表示や削除

1 つのビューから別のビューに変更すると、前のビューに対して行ったカスタマイズがモデル エクスプローラーによって保存されます。

たとえば、Block Data Types ビューを使用していて、[LockScale] プロパティ列を削除したとします。次に Data Objects ビューに切り替え、その後で Block Data Types ビューを再び使用すると、Block Data Types ビューには削除した [LockScale] 列は含まれません。

Simulink セッションの終わりに、モデル エクスプローラーはセッション中に行われたビューのカスタマイズを保存します。Simulink でモデル エクスプローラーを再び開くと、前のセッションでビューに定義した内容を反映した、カスタマイズされたビューが使用されます。

フォント サイズの制御

フォント サイズはモデル エクスプローラー ペインで変更できます。

  • フォントのサイズを大きくするには、Ctrl + プラス記号 (+) を押します。

    または、モデル エクスプローラーの [表示] メニューから、[フォント サイズを大きくする] を選択します。

  • フォントのサイズを小さくするには、Ctrl + マイナス記号 (-) を押します。

    または、モデル エクスプローラーの [表示] メニューから、[フォント サイズを小さくする] を選択します。

メモ:

変更は、モデル エクスプローラーおよび Simulink の各セッションの Simulink ダイアログ ボックスで継続的に有効になります。

新しいビューの作成

以下のいずれかの方法で、新しい名前で新しいビューを作成できます。

  • 既存のビューをコピーし、名前を変更し、カスタマイズします。

  • 完全に新しいビューを作成します。

新しいビューを作成した後は、カスタマイズできます。

操作手順
既存のビューのコピーと名前変更

既存のビューをコピーし、名前を変更し、オプションでそのビューをカスタマイズすることで、新しいビューを作成できます。[ビュー マネージャー] ダイアログ ボックスで次の操作を行います。

  1. 新しいビューの開始点として使用するビューを選択します。

  2. [コピー] ボタンをクリックします。

    新しい行が [ビュー マネージャー] のビュー表の下部に表示されます。新しい行には、コピーしたビューの名前に続き、小かっこ内に番号が表示されます。たとえば、Stateflow ビューをコピーした場合、コピーしたビューの初期の名前は Stateflow (1) になります。

完全に新しいビューの作成

完全に新しいビューを作成するには、[ビュー マネージャー] ダイアログ ボックスで、[新規作成] ボタンをクリックします。新しい行が [ビュー マネージャー] ダイアログ ボックスのビュー リストの下部に表示されます。

新しいビューの名前と説明の指定

作成したビューには名前と説明を指定できます。

  1. ビュー表の左側の列にある [新規作成] をダブルクリックし、テキストをビューの名前に置き換えます。

  2. 表内の [説明] をダブルクリックし、テキストをビューの説明に置き換えます。

  3. [OK] をクリックします。

出荷時の設定へのビューのリセット

特定の標準のビュー (モデル エクスプローラーに用意されているビュー) が現在のビューである場合は、そのビューの元の定義をリセット (または復元) できます。これを行うには、列ビューの詳細セクションで [オプション] ボタンをクリックし、[出荷時の設定にこのビューをリセット] を選択します。

一度にすべての標準ビューを出荷時の設定にリセットするには、[オプション] ボタンをクリックして、[出荷時の設定にすべてのビューをリセット] を選択します。

メモ

すべてのビューをリセットすると、これまでに作成したカスタム ビューがモデル エクスプローラーによってすべて削除されます。ビューを出荷時の設定にリセットする前に、将来使用するビューはエクスポートしておいてください。

モデルの階層構造のコンテンツの一部または全体の表示

既定の設定では、モデル エクスプローラーは [モデルの階層構造] ペインで選択されたシステムのオブジェクトを表示します。子 (下位) システムのデータは表示しません。モデル エクスプローラーが現在選択されているシステムの階層全体のオブジェクトを表示するよう、既定の設定をオーバーライドすることもできます。現在のシステムのみの表示と、現在のシステムのシステム階層全体の表示との間で切り替えるには、以下の手法のいずれかを使用します。

  • [表示][現在のシステム以下を表示] を選択します。

  • [コンテンツ] ペインの上部にある [現在のシステム以下を表示] ボタン Show Current System and Below をクリックします。

[現在のシステム以下を表示] オプションを選択すると、以下のようになります。

  • [モデルの階層構造] ペインでは、現在のシステムとその子 (下位) システムが淡い青色で強調表示されます。

  • [コンテンツ] フィールドのパスの後にテキスト (and below) が表示されます。

  • [コンテンツ] ペインの上部と [表示] メニューにある [現在のシステム以下を表示] ボタンの外観が変化します。

  • [現在のシステム以下を表示] ボタンの上にカーソルを合わせると、表示オブジェクトのスコープがステータス バーに表示されます。

現在のシステム以下のモデルが非常に大きいと、読み込みに時間がかかる場合があります。[現在のシステム以下を表示] ボタンをクリックするか、ツリー階層の別のノードをクリックすると、いつでも読み込み処理を停止できます。

現在のシステム以下を表示する場合は、表示システムの内容をより明確に反映するよう表示を変更することをお勧めします。

[現在のシステム以下を表示] オプションの設定は、Simulink セッション間で変更されずに保存されます。

リンクされたライブラリ サブシステムおよびマスク サブシステムの表示

既定の設定では、モデル エクスプローラーはリンクされたライブラリ サブシステムまたはマスク サブシステムのコンテンツを [モデルの階層構造] ペインに表示しません。リンクされたライブラリ サブシステムのコンテンツを表示するには、次の方法のいずれかを使用します。

  • [モデルの階層構造] ペインの上部で、[ライブラリ リンクの表示/非表示] ボタン Show/Hide Library Links をクリックするか、[マスク サブシステムの表示/非表示] ボタン Show/Hide Masked Subsystems をクリックします。

  • [表示] メニューから [ライブラリ リンクの表示] または [マスク サブシステムの表示] を選択します。

ライブラリがリンクされたサブシステムおよびマスク サブシステムは、[モデルの階層構造] ペインの構成にかかわらず、[コンテンツ] ペインに表示されます。

メモ

[モデルの階層構造] ペインに表示されていないリンクされたライブラリやマスク サブシステム内の要素は検索されません。

ライブラリにリンクされ、かつマスクされているサブシステムでは、次の表に説明されているように、リンクされたライブラリ サブシステムとマスク サブシステムのオプションの設定方法によって、[モデルの階層構造] ペインにどのサブシステムが表示されるかが左右されます。

設定[モデルの階層構造] ペインに表示されるサブシステム

ライブラリ リンクの表示

マスク サブシステムの非表示

ライブラリにリンクされている、マスクされていないサブシステムのみ

ライブラリ リンクの非表示

マスク サブシステムの表示

ライブラリにリンクされていないマスク サブシステムのみ

ライブラリ リンクの表示

マスク サブシステムの表示

すべてのライブラリにリンクされたサブシステムまたはマスク サブシステム

ブロック線図への移動

エディター ウィンドウでグラフィカル オブジェクト (モデル、サブシステム、チャートなど) を開くには、[モデルの階層構造] ペインでオブジェクトを右クリックし、[開く] を選択します。

モデル、チャートまたはワークスペースへのオブジェクトの追加

モデル エクスプローラーを使用すると、多くの種類のオブジェクトをモデル、チャート、またはワークスペースに追加できます。追加できるオブジェクトのタイプは、[モデルの階層構造] ペインで選択するノードによって異なります。オブジェクトを追加するには、ツール バー ボタンまたは [追加] メニューを使用します。[追加] メニューには、追加できるオブジェクトのタイプがリストされます。

モデルまたはチャートの特定の要素への注目

モデルやチャートで作業しているとき、その一部の要素のみがモデル エクスプローラーに表示されるように制限できます。それにはいくつかの方法があります。次の表は、モデル エクスプローラーに表示されるコンテンツを制御する方法と、そのコンテンツがどのように表示されるかをまとめたものです。

手法使用時

モデルの階層構造のコンテンツの一部または全体の表示

階層モデルの表示範囲の制御

行フィルター オプションの使用

特定の種類のモデル オブジェクト (たとえば信号) を表示または非表示

検索

現在表示されていない可能性のあるオブジェクトを検索

コンテンツのフィルター表示

検索文字列に基づいて [コンテンツ] ペイン内の特定オブジェクトに焦点を絞る

関心のあるデータのセットが表示されたら、次の手法で表示されるコンテンツを整理できます。

手法使用時

並べ替え

データのプロパティに基づいて昇順または降順にデータを整理

プロパティ列でグループ化

プロパティの値に基づいてデータを論理的にグループ化

列ビューの使用

[モデルの階層構造] ペイン内のノードの種類別に適用できるプロパティ列の名前付きサブセットを表示

プロパティ表の列の追加、削除、組み直し

プロパティ列をカスタマイズ

モデル エクスプローラーを使用した検索

モデル エクスプローラーは、高度な手法を使用してモデルを調査および変更するのに役立ちます。モデル エクスプローラーを使用して、以下を検索します。

  • ワークスペースおよびデータ ディクショナリの変数

  • モデル内における変数の使用

  • ブロック タイプのインスタンス

  • ブロック パラメーターとパラメーターの値

検索条件を組み合わせて、反復的に結果を絞り込むことができます。モデル エクスプローラーでのモデル要素の検索を、モデルの階層構造内で選択したノードから開始します。モデル全体、特定のシステム内、または 1 つのシステムと階層内でそのシステムの下にあるすべてのシステム内を検索できます。

検索結果を使用して、複数の要素に対して変更を一度に適用できます。

アルゴリズム ブロックのパラメーター (Gain ブロックの [ゲイン] パラメーターなど) を変更する場合は、モデル データ エディターの使用を検討してください。モデル データ エディターを使用したデータ プロパティの設定を参照してください。

モデル エクスプローラー を開く

  • Simulink エディターの [モデル化] タブから、[モデル エクスプローラー] をクリックします。

  • Simulink エディターで開かれているモデル内で、ブロックを右クリックし、コンテキスト メニューから [エクスプローラー] を選択します。

  • 開いている Stateflow チャート内の描画領域内を右クリックし、コンテキスト メニューから [エクスプローラー] を選択します。

すべて展開する

オブジェクト プロパティを表示および編集するには、次のワークフローを使用します。

  1. 現在のシステムのみを表示するか、システムの階層構造全体を表示するかを指定するために、[モデルの階層構造] ペインでモデルを選択します。

  2. [コンテンツ] ペインに表示されるモデル情報を制御します。

    • [表示][列ビュー] オプションを使用して、表示するプロパティ列を制御します。

    • [表示][行フィルター] オプションを使用して、表示するオブジェクトの種類を制御します。

    • 列見出しを直接操作します。

  3. 検索バーを使用して、特定の値をもつモデルの要素を識別します。

  4. モデルの要素の値を [コンテンツ] ペインまたは [ダイアログ] ペインで編集します。ワークスペース変数を編集するには、変数エディターが使用できます。

  5. オブジェクトのプロパティ ダイアログ ボックスを [モデルの階層構造] ペインで開くには、オブジェクトを右クリックし、[プロパティ] を選択します。または、オブジェクトをクリックし、[編集] メニューから [プロパティ] を選択します。

    [コンテンツ] ペインの変更可能プロパティ (ブロック名など) は、表示されている値を編集することで変更できます。値を編集するには、値を含む行を選択してから値をクリックします。値は編集コントロール (テキスト値の場合は編集フィールド、値の範囲の場合はリストなど) によって置き換えられます。配列または構造体のワークスペース変数には、変数エディターが使用できます。編集コントロールを使用して、選択されているプロパティの値を変更します。

    [コンテンツ] ペインの複数のオブジェクトに同じプロパティ値を割り当てるには、オブジェクトを選択し、選択したいずれかのオブジェクトのプロパティを新しい値に変更します。編集コントロールがその値を <edit> で置き換え、一括編集モードであることを示します。モデル エクスプローラーでは、選択した他のオブジェクトにもこの新しいプロパティ値を割り当てます。

    プロパティ値は [ダイアログ] ペインを使用して変更することもできます。

ビューを [列ビュー] リストから削除するには、以下の手順に従います。

  1. [ビュー マネージャー] ダイアログ ボックスで、リストから削除する 1 つ以上のビューを選択します。

  2. [削除] ボタンをクリックするか、Delete キーを使用します。

  3. [OK] をクリックします。

    [ビュー マネージャー] ダイアログ ボックスを使用してビューを削除すると、そのビューはモデル エクスプローラー インターフェイスから完全に削除されます。ビューが後で再び必要になる可能性がある場合は、削除前にビューをエクスポートすることを検討してください。

[列ビュー] リスト内のビューの位置を変更するには、[ビュー マネージャー] ダイアログ ボックスで、以下の手順に従います。

  1. ビューの表内で上または下に 1 行移動する 1 つ以上のビューを選択します。

  2. ビューの表の右側にある上向きまたは下向き矢印ボタンをクリックします。ビューが表内の希望の場所に表示されるまで、この手順を繰り返します。

  3. [OK] をクリックします。

後で自分自身または他のユーザーがインポートできるようにビューをエクスポートするには、[ビュー マネージャー] ダイアログ ボックスで、以下の手順に従います。

  1. [ビュー マネージャー] ダイアログ ボックスで、エクスポートする 1 つ以上のビューを選択します。

  2. [エクスポート] ボタンをクリックします。[ビューのエクスポート] ダイアログ ボックスが開きます。選択したビューの横にはチェック マークが表示されています。

  3. [OK] をクリックします。[ファイル名へエクスポート] ダイアログ ボックスが開きます。

  4. ビューのエクスポート先のフォルダーに移動します。既定の設定では、モデル エクスプローラーはビューを MATLAB® の現在のフォルダーにエクスポートします。

  5. エクスポートしたビューのファイル名を指定します。ファイル形式は .mat です。

  6. [OK] をクリックします。

ビュー ファイルを別の場所からインポートしてモデル エクスプローラーで使用できるようにするには、次の手順を実行します。

  1. [ビュー マネージャー] ダイアログ ボックスで、[インポート] ボタンをクリックします。[インポートする .mat ファイルの選択] ダイアログ ボックスが開きます。

  2. ビューのインポート元のフォルダーに移動します。

  3. インポートするビューを含む MAT ファイルを選択し、[開く] をクリックします。確認ダイアログ ボックスが開きます。[OK] をクリックしてビューをインポートします。

    インポートしたビューが [列ビュー] ビュー リストの下部に表示されます。名前の競合が発生した場合は、モデル エクスプローラーによりビューの名前が自動的に変更されます。

Model ブロックを含むモデルを表示するには、Model ブロックの [モデルの階層構造] ペインのノードを展開します。

たとえば、sldemo_mdlref_depgraph モデルには、他のモデルを参照する Model ブロックが含まれています。sldemo_mdlref_depgraph モデルを開き、そのモデルを [モデルの階層構造] ペインで展開すると、モデルに heat2cost をはじめとする複数の Model ブロックが含まれているのがわかります。

Model ブロックが参照しているモデルを表示するには、次の操作を実行します。

  1. 参照モデル ノードを [モデルの階層構造] ペインで右クリックします。

  2. [モデルを開く] を選択します。

    • 参照モデルが表示されます。

    • [モデルの階層構造] ペインに、Model ブロック ノードを展開できることが示されます (読み取り専用)。

    • [コンテンツ] ペインに、その Model ブロック ノードに対応するオブジェクトが表示されます (読み取りのみ)。

    • [モデルの階層構造] ペインに、その参照モデルが別の展開可能ノードとして表示されます。

  3. たとえば、heat2cost Model ブロック ノードを右クリックして [モデルを開く] を選択すると、[コンテンツ] ペインに heat2cost Model ブロックに対応するオブジェクトが表示されます。heat2cost ノードは展開できます。

    Block objects

    参照モデルのコンテンツは表示できますが、Model ブロック内にあるモデル オブジェクトは編集できません。

    参照モデルを編集するには、[モデルの階層構造] ペインで参照モデル ノードを展開してから、参照モデル内のオブジェクトのプロパティにアクセスします。たとえば、sldemo_mdlref_heat2cost ノードを展開します。

    Expanded node

    参照モデルの詳細は、モデル参照を参照してください。

この例では、ワークスペース間でワークスペース オブジェクトを切り取り、コピーし、貼り付ける方法を示します。

  1. [コンテンツ] ペインで、切り取るかコピーするワークスペース オブジェクトを右クリックします。

  2. [切り取り] または [コピー] を選択します。

    • [コンテンツ] ペインで [編集][切り取り] を選択するか、[切り取り] ボタンをクリックしてワークスペース オブジェクトを切り取ることもできます。

    • [編集][コピー] を選択するか、[コピー] ボタンをクリックしてワークスペース オブジェクトをコピーすることもできます。

  3. 切り取ったりコピーしたりしたワークスペース オブジェクトを貼り付けるには、[モデルの階層構造] ペインで、オブジェクトの貼り付け先のワークスペースを右クリックし、[貼り付け] を選択します。

    • [編集][貼り付け] を選択するか、[貼り付け] ボタンをクリックしてオブジェクトを貼り付けることもできます。

    • コピーと貼り付け (またはドラッグ アンド ドロップ) を行うときに、名前の競合の解決を制御することができます。ダイアログ ボックスで、名前が既存の項目と競合している各項目に対して行う動作を選択します。

      • Skip — 競合する項目が同じ値をもっている場合の既定の動作。

      • Replace — 競合する項目が異なる値をもっている場合の既定の動作。

      • Keep both — 両方のコピーを保持。コピーされた項目に指定される名前は、MATLAB ワークスペースで使用される命名規則に従っています。

      コピー元とコピー先が同じである場合は、MATLAB ワークスペースで使用される命名規則に従って名前の競合を解決します。

    オブジェクトを選択してドラッグ アンド ドロップ操作を実行することで、切り取り、コピー、貼り付けを行うこともできます。

この例では、[整数丸めモード] パラメーターをもつモデル要素を検索します。その後、n-D Lookup table ブロックのみを含めるように結果を絞り込みます。検索結果を使用して、これらの値の設定方法の詳細を確認したり、検索によって見つかったモデル要素に対して一括変更を加えることができます。

  1. モデル sldemo_fuelsys を開きます。

  2. モデル エクスプローラーを開きます。[モデル化] タブで [モデル エクスプローラー] をクリックします。

    既定では、モデル エクスプローラーは現在のシステム以下を検索します。モデルの階層構造ツリーと [内容を表示] ボタン Show contents button を組み合わせて使用することで、検索範囲を指定できます。たとえば、ノードを選択し、検索を [現在のシステムの内容のみ] に設定することで、検索の範囲をそのレベルのみに維持できます。現在のシステムとそのシステム内のすべてのサブシステムを検索するには、検索を [現在のシステム以下] に設定します。

  3. この例では、検索範囲の設定を [現在のシステム以下] のままにしてモデルの最上位レベルから検索を開始します。検索条件を指定します。検索バーで、以下のように設定します。

    • [検索][プロパティ名] に設定

    • [プロパティ]Rounding に設定

      Rounding[整数丸めモード] パラメーターのプログラム上の名前です。これらの名前のリストについては、ブロック固有のパラメーターを参照してください。

  4. [検索] をクリックします。[検索結果] ボックスに 43 個の結果が表示されます。パスへのリンクをクリックすることで、項目に移動することができます。

  5. 検索を絞り込みます。検索バーで [検索オプション] をクリックして [絞り込み検索] を選択します。

    Refine Search

    検索ボタンのラベルが [絞り込み] に変わります。このラベルが表示されている場合は、追加の検索条件は以前の結果セットに対して作用します。

  6. [検索][ブロック タイプ] に設定し、[タイプ]Lookup_n-D に設定します。[絞り込み] をクリックします。

    検索によって 5 個の項目が返されます。

  7. この値をさらに操作するには、[詳細を表示] をクリックします。

  8. さらなる調査対象または作用対象として関心のあるプロパティは Rounding です。まず、検索結果でそのプロパティの列を追加します。リストから Rounding を選択し ([プロパティの検索] ボックスに入力することで迅速に検索可能)、[ビューの列としてプロパティを表示] ボタンをクリックします。

    Display columns

    Rounding の列が検索結果に表示されます。列内に表示されるパラメーターまたはプロパティについては、複数の項目の値を表示、並べ替え、変更することができます。たとえば、検索によって見つけたすべての n-D Lookup Table ブロックの Rounding 値を変更するには、リスト内のすべての項目を選択します。[Rounding] 列でいずれかのセルをクリックし、リストから新しい値 (たとえば Floor) を選択します。

    ヒント

    使用した検索オプションの概要を表示するには、[検索詳細を表示] ボタン Show Search Details をクリックして [検出されたオブジェクト数] ボックスを展開します。

    モデル エクスプローラーを使用して、データ ディクショナリでエントリを作成、変更、表示することができます。モデル エクスプローラーを使用したワークスペース変数の編集と管理およびディクショナリ データの変更表示と変更取り消しを参照してください。

関連する例

パラメーター

検索バーのコントロール

[表示]、[ツール バー]、[検索バー] オプションを使用して検索バーを開きます。検索バーには以下のようなコントロールが含まれています。検索タイプと検索オプション

[検索タイプ] コントロールを使用して、検索に含めるオブジェクトまたはプロパティのタイプを指定します。

検索タイプのオプション説明
名前指定された文字列をオブジェクトの名前に含んでいるすべてのオブジェクトのモデルまたはチャートを検索します。
プロパティ名指定されたプロパティをもつオブジェクトを検索します。検索ドメイン内のオブジェクトに対して設定可能なプロパティのリストからターゲット プロパティ名を指定します。
プロパティ値

指定した値に一致するプロパティ値をもつオブジェクトを検索します。プロパティの名前、一致させる値、および一致タイプ (equals、less than、greater than など) を指定します。

ブロック タイプ

指定されたブロック タイプのブロックを検索します。現在選択されているモデルに含まれているタイプのリストからターゲットのブロック タイプを選択します。

Stateflow タイプ

指定されたタイプの Stateflow オブジェクトを検索します。

変数の使用

ワークスペースに定義されている変数を使用するブロックを検索します。ベース ワークスペースまたはモデル ワークスペース (モデル名) を選択し、必要に応じて変数名を指定します。

参照された変数

モデルまたはブロックが使用する変数を検索します。[システム別] フィールドでそのモデルまたはブロックの名前を指定します。指定するモデルまたはブロックは [モデルの階層構造] ペイン内に存在しなければなりません。

使用されない変数

ワークスペースに定義されているが、モデルやブロックでは使用されていない変数を検索します。[ワークスペース内] フィールドのドロップダウン リストからワークスペースの名前を選択します。

ライブラリ リンク

現在のモデルのライブラリ リンクを検索します。

クラス

指定されたクラスの Simulink オブジェクトを検索します。

固定小数点機能

固定小数点の計算をサポートしているすべてのブロックのモデルを検索します。

モデル参照

モデルで他のモデルに対する参照を検索します。

ダイアログのプロンプト

指定したプロンプトをダイアログに含んでいるすべてのオブジェクトのモデルを検索します。

文字列

モデル内で、指定した文字列が含まれているすべてのオブジェクトを検索します。

[検索オプション] コントロールを使用して、検索範囲と検索文字列の適用方法を指定します。

検索オプション説明
文字列の完全一致

文字列の部分一致を認めません (たとえば、subsubstring と一致しません)。

大文字小文字の区別

文字列を比較する際に大文字/小文字を区別します (たとえば、Gaingain は一致しません)。

正規表現

一致させる文字列を正規表現として比較します。

検索中にプロパティ値を評価

プロパティ値による検索にのみ適用されます。このオプションが有効の場合、モデル エクスプローラーは、各プロパティの値を MATLAB 式として評価し、結果を検索値と比較します。このオプションが無効の場合 (既定値)、モデル エクスプローラーは未評価のプロパティ値を検索値と比較します。

絞り込み検索

最初の検索結果を絞り込むために追加の検索条件を与えて 2 回目の検索を行います。2 回目の検索処理では、元の検索条件と新しい検索条件の両方を満たすオブジェクトが検索されます。

既定の設定では、検索文字列の大文字と小文字は区別されず、正規表現として取り扱われ、検索文字列の部分一致が認められます。検索文字列にワイルドカード文字を使用することはできません。たとえば、名前の検索文字列として "*1" と入力した場合、名前が 2 つの文字 "*1" で始まる項目がない限り、一致する検索結果は得られません。out1 の項目が存在しても、検索結果にはその項目は含まれません。

[モデルの階層構造] ペイン

[Simulink ルート] を展開すると、MATLAB ワークスペース、Simulink モデル、および現在のセッションにある Stateflow チャートを表すノードが表示されます。

[ベース ワークスペース] は MATLAB ワークスペースを表します。MATLAB ワークスペースは、Simulink モデルと Stateflow チャートのベース ワークスペースです。このワークスペースで定義される変数は、開いているすべてのモデルとチャートに表示されます。

[モデルの階層構造] ペインでモデル ノードまたはチャート ノードを展開すると、開いているモデルやチャートで該当する、次の要素を表すノードが表示されます。

ノード説明

コンフィギュレーション

[コンフィギュレーション] ノードを選択して、モデルのコンフィギュレーション セットとコンフィギュレーション参照を [コンテンツ] ペインで表示します。コンフィギュレーション セットの追加、削除、保存、移動は、モデルのコンフィギュレーション セットの管理を参照してください。

モデル ワークスペース

モデル ワークスペース変数の操作にモデル エクスプローラーを使用する方法は、次のトピックを参照してください。

外部データ[外部データ] ノードを展開し、ベース ワークスペース (アクセスが有効な場合)、データ ディクショナリを含めたモデルの外部データ ソースを表示します。

最上位のサブシステム

サブシステムを示すノードを展開すると、その下にサブシステムがある場合は表示されます。

Model ブロック

Model ブロックを展開して参照モデルのコンテンツを表示します。

Stateflow チャート

  • Stateflow チャートを示すノードを展開すると、チャートの最上位のステートが表示されます。

  • ステートを示すノードを展開すると、そのサブステートが表示されます。

[コンテンツ] ペイン

[コンテンツ] ペインには、選択したタブに応じて、モデルとチャートに関する情報を含む 2 つの表のどちらかが表示されます。

  • [コンテンツ] タブには、[モデルの階層構造] ペインで選択したノードのオブジェクト プロパティ表が表示されます。

  • [検索結果] タブには、検索結果の表が表示されます。

必要に応じて、[コンテンツ] ペインの列ビューの詳細セクションを開くこともできます。次のグラフィックスは、列ビューの詳細セクションを開いた状態の [コンテンツ] ペインを示しています。

列ビューの詳細セクションを開くには、[コンテンツ] ペインの上部にある [詳細を表示] をクリックします。

列ビューの詳細セクションには列ビューをカスタマイズするためのインターフェイスがあります (既定の設定では非表示)。

オブジェクト プロパティ表セクションにはモデルとチャートのオブジェクト データの表が表示されます (既定の設定では表示)。

[コンテンツ] タブと [検索結果] タブのオブジェクト プロパティ表セクションでは、次のように表示されます。

  • 表の列はオブジェクトのプロパティ (NameBlockType など) に対応しています。

    オブジェクト プロパティ表には、最初の 2 つの列 (オブジェクト アイコンと Name プロパティ) が持続的に表示され、右にどれだけスクロールしてもこれらの列は表示され続けます。

  • 表の行はオブジェクト (ブロックや状態など) に対応しています。

[コンテンツ] ペインに表示されるオブジェクトとプロパティは、次の項目に依存します。

  • [コンテンツ] ペインで選択する列のビュー

  • [モデルの階層構造] ペインで選択するノード

  • [モデルの階層構造] ペインで選択するオブジェクトの種類 (たとえば、サブシステムやチャート)

  • 選択する [表示][行フィルター] のオプション

[コンテンツ] ペインの左上に表示される [コンテンツ] のリンクには、[モデルの階層構造] ペインで選択されているノードの名前が表示されます。[コンテンツ] ペインに表示されるモデル データには、 [現在のシステム以下を表示] オプションの設定が反映されます。この例では、[コンテンツ]vdp (モデル名) と表示されますが、それが現在選択されているノードです。

モデル エクスプローラーでは、ビューを使用して、[コンテンツ] ペインに表示するプロパティ列の集合を指定します。

[モデルの階層構造] ペインのノードに対して [コンテンツ] ペインに対象オブジェクトのどのプロパティの組み合わせを表示するかは、ノードの種類に応じて変更できます。たとえば、モデルやサブシステムなどの Simulink モデル ノードでは、次のようなプロパティを表示すると便利です。

  • BlockType (ブロック タイプ)

  • OutDataTypeStr (出力データ型)

  • OutMin (ブロック出力の最小値)

通常、列ビューにはノード内の全オブジェクトに対するすべてのプロパティは含まれません。表示するプロパティのサブセットを指定することで、モデルやチャートのオブジェクトのプロパティを検索および編集する作業を効率化し、[コンテンツ] ペインに表示されるデータの密度を濃くできます。

モデル エクスプローラーでは、モデル情報の次の側面をキャプチャするためにビューを使用できます。

  • [コンテンツ] ペインに表示するプロパティ

  • [コンテンツ] ペインのレイアウト (たとえば、プロパティに基づくグループ化、プロパティ列の順序、並べ替え)。

ビューは次のようにして使用できます。

  • モデル エクスプローラーに用意されている標準のビューを使用する

  • 標準のビューをカスタマイズする

  • ユーザー独自のビューを作成する

モデル エクスプローラーをはじめて開くと、[モデルの階層構造] ペインで選択したノードに標準ビューのいずれかが自動的に適用されます。モデル エクスプローラーでは、選択されているノードの種類に基づいてビューを適用します。

モデル エクスプローラーは、[モデルの階層構造] ペインの 4 つのノードのカテゴリのいずれかを割り当てます。最初は、各ノードのカテゴリに既定のビューが関連付けられます。4 つのノードのカテゴリは次のとおりです。

ノードのカテゴリ含まれる階層ノードの種類初期の関連ビュー
Simulinkモード、サブシステム、およびルート レベル モデルBlock Data Types
ワークスペースベースおよびモデル ワークスペース オブジェクトData Objects
StateflowStateflow チャートおよびステートStateflow
コンフィギュレーション[コンフィギュレーション] セクションのノードConfigurations
その他

コンフィギュレーション セットなど、最初の 3 つのカテゴリのいずれにも該当しないオブジェクト

Default

[コンテンツ] ペインの上部にある [列ビュー] フィールドには、モデル エクスプローラーが現在使用しているビューが表示されます。

[コンテンツ] ペインの [列ビュー] リストから、別のビューを選択できます。別のビューを選択した場合、モデル エクスプローラーでは現在のノードのカテゴリにそのビューを関連付けます。たとえば、[モデルの階層構造] ペインで選択されているノードが Simulink モデルで、現在のビューが Data Objects であるとします。ビューを Signals に変更した場合、別の Simulink モデル ノードを選択すると、モード エクスプローラーによって Signals ビューが使用されます。

既定の設定では、選択されたノードのカテゴリに応じて、さらにそのノードに最後に適用されたビューに基づいて、モデル エクスプローラーが自動的にビューを適用します。現在の作業にさらに適したビューを [列ビュー] リストから手動で選択することもできます。

モデル エクスプローラーにビューを自動的に適用させる既定のモードから、ビューを手動で選択して変更するモードに切り替えることができます。

手動のビュー選択モードを有効にするには、次の手順を実行します。

  1. [ビュー][列ビュー][ビュー管理] を選択します。

    [ビュー マネージャー] ダイアログ ボックスが開きます。

  2. [ビュー マネージャー] ダイアログ ボックスで、[オプション] ボタンをクリックし、[ビューを自動的に変更] をオフにします。

手動のビュー選択モードでは、[モデルの階層構造] ペインで、別のビューが関連付けられている別の種類のノードに切り替えた場合、使用するビューを推奨する黄色の情報バーが [コンテンツ] ペインに表示されます。

ビューは、[ビュー マネージャー] ダイアログ ボックスを使用して管理できます (新しいビューの作成やビューのエクスポートなど)。[ビュー マネージャー] ダイアログ ボックスを開くには、[ビュー管理] オプションを次のどちらかから選択します。

  • [表示][列ビュー] メニュー

  • 列ビューの詳細セクションで [オプション] ボタンをクリックしたときに表示されるオプション

[ビュー マネージャー] ダイアログ ボックスには、定義されているビューのリストが表示され、ビューを管理するためのツールが提供されます。

ビューの作成、削除、並べ替え、エクスポート、インポート、リセットなど、ビューはいくつかの方法で管理できます。

ヒント インターフェイスは、オブジェクト プロパティ表のすぐ上に表示されます。自動ビュー選択を使用している場合は表示されません。ヒント インターフェイスには、現在のビューを推奨されるビューに変更するためのリンクが表示されます。ヒント バーに表示されている推奨ビューを選択するには、リンクをクリックします。現在表示されているヒントを非表示にするには、ヒント バーの右側にあるメニュー ボタンから [このヒントを隠す] を選択します。

推奨されるビューは、最初はノードに関連付けられている既定のビューになります。別のビューをノードのカテゴリに関連付けると、同じようなノードを選択したときに、最近選択したビューが推奨されます。

ビューの手動指定から自動指定に切り替えるには、ヒント インターフェイスから下向き矢印を選択して [ビューを自動的に変更] メニュー項目を選択します。

ヒント インターフェイスを有効にするには、右側の [オプション][ビュー管理] を選択してから、[オプション][ビューを自動的に変更] を選択します。

[ダイアログ] ペインを使用して、[モデルの階層構造] ペインまたは [コンテンツ] ペインで選択したオブジェクトのプロパティを表示または変更します。

既定の設定では、[ダイアログ] ペインはモデル エクスプローラーの [コンテンツ] ペインの右側に表示されます。[ダイアログ] ペインの表示と非表示を切り替えるには、次の方法のどちらかを使用します。

  • [表示] メニューから、[ダイアログ ペインを表示] を選択します。

  • メイン ツール バーの [ダイアログの表示] ボタンをクリックします。

[ダイアログ] ペインを使用してプロパティ値を編集するには、次の手順を実行します。

  1. [コンテンツ] ペインで、オブジェクト (ブロックや信号など) を選択します。[ダイアログ] ペインに、選択したオブジェクトのプロパティが表示されます。

  2. [ダイアログ] ペインでプロパティ (Outport ブロックの端子番号など) を変更します。

  3. [適用] をクリックして変更を承認するか、[元に戻す] をクリックして元の値に戻します。

既定の設定では、変更が適用されていないダイアログ ボックスの外側をクリックすると、[変更の適用] ダイアログ ボックスが表示されます。[適用] をクリックして変更を承認するか、[無視] をクリックして元の設定に戻ります。

[変更の適用] ダイアログ ボックスを非表示にするには、次のようにします。

  1. ダイアログ ボックスで、[今後、尋ねることなく適用されるか無視されます (いずれか選択した方)] チェック ボックスをオンにします。

  2. 警告なしに Simulink に変更を適用させるには、[適用] をクリックします。警告なしに Simulink に変更を無視させるには、[無視] をクリックします。

[変更の適用] ダイアログ ボックスを再表示するには、[ツール] メニューから [変更が適用されていない場合にダイアログを表示] を選択します。

モデル ワークスペースで MATLAB の数値変数または Simulink.Parameter オブジェクトを選択すると、[ダイアログ] ペインに [引数] チェック ボックスが表示されます。このチェック ボックスをオンにすると、その変数またはオブジェクトがモデル引数として設定されます。再利用可能な参照モデルのインスタンスのパラメーター化を参照してください。

プログラムによる使用

すべて展開する

daexplr によってモデル エクスプローラーを開きます。

R2006a より前に導入