最新のリリースでは、このページがまだ翻訳されていません。 このページの最新版は英語でご覧になれます。

データの前処理

データの前処理方法

PID 調整器で、推定に使用する前にプラント データを前処理できます。I/O データをインポートしたら、[プラントの同定] タブで [前処理] メニューを使用して、前処理操作を選択します。

  • オフセットの削除 — 平均値、定数値または初期値をデータから削除します。

  • データのスケーリング — 定数値、信号の最大値または信号の初期値によってデータをスケーリングします。

  • データの抽出 — 推定に使用するデータのサブセットを選択します。抽出するデータをグラフィカルに選択することも、開始時間と終了時間とをテキスト ボックスに入力することもできます。

  • データのフィルター処理 — ローパス フィルター、ハイパス フィルターまたはバンドパス フィルターを使用してデータを処理します。

  • データ リサンプリング –– ゼロ次ホールドまたは線形内挿を使用してデータをリサンプリングします。

  • データの置換 –– データを定数値、領域の初期値、領域の最終値またはラインに置換します。この機能は、外れ値の置き換えに使用できます。

データに対する前処理操作は、アプリケーションで要求される数だけ実行できます。たとえば、データのフィルター処理とオフセットの削除の両方が行えます。

オフセットの削除

良好な結果を得るには、データのオフセットを削除することが重要です。[オフセットの削除] タブでは、オフセットをすべての信号から一度に削除することも、[信号からオフセットを削除] ドロップダウン リストを使用して特定の信号を選択することもできます。[削除するオフセット] ドロップダウン リストを使用して、削除する値を指定します。次のオプションがあります。

  • 定数値。ボックスに値を入力します (既定: 0)。

  • データの平均値。ゼロ平均のデータを作成するためのものです。

  • 信号の初期値。

オフセット値を変更すると、変更されたデータがプロットのプレビューに表示されます。

選択をしたら をクリックして、既存のデータを前処理したデータで更新します。

データのスケーリング

[データのスケーリング] タブでは、すべての信号をスケーリングするか、あるいはスケーリングする信号を指定するよう選択できます。[使用するスケール] ドロップダウン リストから、スケーリングの値を選択します。次のオプションがあります。

  • 定数値。ボックスに値を入力します (既定: 1)。

  • 信号の最大値。

  • 信号の初期値。

スケーリングを変更すると、変更されたデータがプロットのプレビューに表示されます。

選択をしたら をクリックして、既存のデータを前処理したデータで更新します。

データの抽出

[データの抽出] タブで、使用するデータのサブセットを選択します。データの抽出は、グラフィカルに行うか、開始時間と終了時間を指定して行うことができます。データをグラフィカルに抽出するには、垂直バーをクリックしてドラッグし、使用するデータの領域を選択します。

データのフィルター処理

ローパス フィルター、ハイパス フィルターまたはバンドパス フィルターを使用してデータをフィルター処理できます。ローパス フィルターは高周波信号をブロックします。ハイパス フィルターは低周波信号をブロックします。バンドパス フィルターはローパス フィルターとハイパス フィルターの両方の特性を組み合わせたものです。

[ローパス フィルター][ハイパス フィルター] または [バンドパス フィルター] タブでは、すべての信号をフィルター処理するか、特定の信号を指定するよう選択できます。ローパスおよびハイパスのフィルター処理では、信号に対し、正規化されたカットオフ周波数を指定できます。ここで、正規化周波数 1 は、サンプリング レートの半分に対応します。バンドパス フィルターでは、正規化された開始周波数と終了周波数を指定できます。周波数は、タブ上の関連するフィールドに値を入力して指定します。あるいは、データの周波数領域プロットで垂直バーをドラッグすることにより、フィルターの周波数をグラフィカルに指定します。

[オプション] をクリックしてフィルター次数を指定し、ゼロ位相シフト フィルターを選択します。

選択をしたら をクリックして、既存のデータを前処理したデータで更新します。

データ リサンプリング

[データ リサンプリング] タブで、[サンプリング周期でリサンプリング:] フィールドを使用してサンプリング周期を指定します。データのリサンプリングでは、次のいずれかの内挿法を使用できます。

  • ゼロ次ホールド — 欠損データ サンプルを、その直前にあるデータ値で埋めます。

  • 線形内挿 — 欠損データを、2 つのデータ点を繋ぐラインを使用して埋めます。

既定では、リサンプリング手法は [ゼロ次ホールド] に設定されます。[線形内挿] 法は、[以下の方法でリサンプリング] ドロップダウン リストから選択できます。

変更されたデータは、プロットのプレビューに表示されます。

選択をしたら をクリックして、既存のデータを前処理したデータで更新します。

データの置換

[データの置換] タブで、プロット内の領域を越えてドラッグすることにより、置換するデータを選択します。データを選択したら、[選択したデータを置換] ドロップダウン リストを使用して置換方法を選択します。選択したデータは、次のいずれかのオプションで置換できます。

  • 定数値

  • 領域の初期値

  • 領域の最終値

  • ライン

置換されたプレビュー データは色が変わり、置換用データがプロットに表示されます。更新前の任意のタイミングで、置換したデータを [プレビューのクリア] をクリックしてクリアし、再開します。

選択をしたら をクリックして、既存のデータを前処理したデータで更新します。

[データの置換] は、たとえば、外れ値を置換する場合などに有用となります。外れ値は、標準偏差の 3 倍を超えて平均を逸脱しているデータ値として定義できます。外れ値を含むデータからパラメーターを推定すると、その結果は不正確となることがあります。したがって、パラメーターを推定する前にデータの外れ値を置換する選択が望ましい場合もあります。

関連するトピック