Main Content

Simulink でのモデル化用のキーボード ショートカットとマウス操作

キーボード ショートカットとマウス操作を使用して Simulink® のシステムをモデル化できます。モデルからこのページを開くには、Shift+? を押すか、ナビゲーション バーのキーボード ショートカット をクリックします。

メモ

macOS でキーボード ショートカットを使用する場合は次のようにします。

  • Ctrl キーではなく command (⌘) キーを押します。

  • Alt キーではなく option キーを押します。

エディターでのキーボード ショートカットの表示

次のいずれかのモードでは、アクティブなモードに固有のキーボード ショートカットを表示するヒント パネルを確認できます。

モード定義モードに入る方法ヒント パネルの表示方法
選択矢印キーを使用して別のブロックを選択する。モデル内のブロックを選択します。M キーを押して、移動モード (既定) から選択モードに切り替えます。選択モードに入るとヒント パネルが表示されます。
移動矢印キーを使用して選択したブロックを移動する。

Simulink を開くと、既定で移動モードになります。

選択モードから移動モードに切り替えるには、M キーを押します。

選択モードから移動モードに切り替えるとヒント パネルが表示されます。

ヒント パネルを非表示にするには、キャンバスをクリックします。

信号のトレース

選択したブロックまたは信号線と信号の接続元または接続先のブロックの間の信号線をトレースする。信号のトレースの詳細については、信号の伝播元と伝播先の強調表示を参照してください。

モデル内の信号をクリックします。表示される省略記号をポイントします。展開される操作バーで、[ソースへの信号を強調表示] または [接続先への信号を強調表示] をクリックします。

信号のトレース モードに入るとヒント パネルが表示されます。
パンおよびズームパンしてモデル上で視点を移動する。ズームしてモデルにどの程度近接して表示するかを変更する。Simulink を開くと、既定でパンおよびズーム モードになります。

ヒント パネルが展開されるまでスペース バーを押します。ヒント パネルが最小化されている場合は、[?] ボタン が表示されるまでスペース バーを押します。

ヒント パネルを非表示にするには、キャンバスをクリックします。

ヒント パネルを最小化するには、キーボードの ? キーを押します。ヒント パネルが最小化されると、[?] ボタン のみが表示されます。

ヒント パネルを元に戻すには、キーボードの ? キーを押します。

あるモードでヒント パネルを最小化したり元に戻したりしても、他のモードのヒント パネルには影響しません。展開されているヒント パネルは MATLAB® セッション間で展開されたままになり、最小化されているヒント パネルは最小化されたままになります。

たとえば、移動モードの [キーボードの選択] ヒント パネルを表示するには、次を行います。

  1. モデル内のブロックを選択します。

  2. M キーを押します。モデル ウィンドウの右下に最小化されたヒント パネルが表示されます。

  3. ヒント パネルを元に戻すには、キーボードの ? キーを押します。

The left image shows a model in keyboard selection mode with the hints panel expanded in the lower right corner of the model window. The ? button is in the lower right corner of the expanded hints panel. The right image shows the same model in the same mode with the hints panel minimized. Only the ? button is visible in the lower right corner.

ファイル アクションとクリップボード アクションの実行

タスクショートカット
モデルを開くCtrl + O
モデルを作成Ctrl + N
モデルを印刷Ctrl + P
現在のモデルの階層構造内にある変更されたすべてのモデルを保存Ctrl + S
現在の参照モデルを保存Ctrl + Shift + S
モデルを閉じるCtrl + W
切り取りCtrl + X
貼り付けCtrl + V
元に戻すCtrl + Z
やり直しCtrl+YCtrl+Shift+Z (Simulink Online™)
検索文字列を検出Ctrl + F

ズームとパン

タスクショートカットとアクション
ブロック線図をウィンドウに合わせるスペース バー
選択範囲をウィンドウに合わせるスペース バー + F
ズームインCtrl + プラス (+)、スペース バー + プラス (+)
ズーム アウトCtrl + マイナス (-)、スペース バー + マイナス (-)
ズームを 100% にリセットCtrl + 0Alt + 1、スペース バー + 0
スクロール ホイールによるズーム

スクロール ホイール

[スクロール ホイールによるズーム制御] がクリアされているときに、Ctrl キーを押しながらスクロール ホイールを使用

モデル要素のズームインパレットから要素に [ズーム] ボタン をドラッグ。
モデル ウィンドウにおけるブロック線図の表示部分をブロック線図全体に対してミニマップで表示

モデルの部分にズームまたはパン。

モデルの一部のみを表示した状態で、ミニマップが表示されるまでスペース バーを押す。

モデルの別の部分を表示ミニマップで目的の部分をクリック。
パン

ミニマップで強調表示された部分をドラッグ。

中央ボタンを押してドラッグ。

スペース バーを押したままドラッグ。

スクロール バーが表示されているときにスクロール バーをキーボードで移動するには、スペース バー + 左矢印、右矢印、上矢印、下矢印を押す。

垂直方向に移動Ctrl + スクロール ホイール
水平方向に移動Shift + スクロール ホイール
ページごとに移動Shift + スペース バー + 左矢印、右矢印、上矢印、下矢印

モデルのナビゲート

タスクショートカットとアクション
モデルを開く

ダブルクリック。

Enter

タブを変更Ctrl + Shift + Tab
現在のサブシステム、参照モデル、または Stateflow® ステートの親に移動Esc
ブロック マスクの下の表示Ctrl + U
リンク付きブロックで、親ブロックのライブラリに移動Ctrl + L
モデル エクスプローラーを開くCtrl + H

モデル要素の選択と移動

選択した要素の外枠は青い実線で示されます。最後に選択した要素は、青い外枠と角にかっこが付いた状態で示されます。キーボードを使用して選択するときのカーソルを表すには、要素は破線の青いボックスで囲まれます。

The Product block is selected, the Gain block was selected most recently, and the cursor is on the Sum block.

既定では、モデルは移動モードです。移動モードでは、選択した要素を移動するためのショートカットにアクセスできます。要素を選択するためのショートカットにアクセスするには、M キーを押して選択モードに入ります。移動モードに戻るには、M キーをもう一度押します。

タスクモードショートカットとアクション
移動モードと選択モードの切り替え移動または選択

M

すべてのブロック、線、注釈の選択移動または選択Ctrl + A
選択をクリア移動または選択Ctrl + Alt + A
1 つ以上のモデル要素を選択移動または選択選択するモデル要素の周囲に選択ボックスを描画します。選択ボックスをキャンバスの空のスポットで起動します。
信号ラベルなどの任意のモデル要素を移動移動または選択要素をドラッグします。
選択した要素を移動

ポインター操作の場合は移動または選択

キーボード操作の場合は選択モード

選択した要素を 1 つドラッグします。

選択ボックスをドラッグします。

キーボードで要素を選択した後、選択モードで左矢印、右矢印、上矢印、下矢印を押します。

1 つの方向で最も近い類似した要素に選択を変更選択

左矢印、右矢印、上矢印、下矢印

類似度に関係なく、1 つの方向で最も近い要素にカーソルを移動選択

Ctrl + Shift + 左矢印、右矢印、上矢印、下矢印

キャンバスの左上の要素に選択を変更選択

Ctrl + Home

macOS では、home キーを押します。

キャンバスの右下の要素に選択を変更選択

Ctrl + End

macOS では、end キーを押します。

カーソルに対して最も左側の要素に選択を変更選択

Home

macOS では、control+左矢印を押します。

カーソルに対して最も右側の要素に選択を変更選択

End

macOS では、control+右矢印を押します。

隣接する要素を追加で選択選択

Shift + 左矢印、右矢印、上矢印、下矢印

Shift キーを押したまま、追加の要素を囲む選択ボックスをドラッグします。

隣接しない要素を追加で選択選択

Shift キーを押しながらクリック。

Ctrl + 左矢印、右矢印、上矢印、下矢印で現在の要素を変更します。Ctrl + スペース バーで現在の要素を選択に追加します。

macOS で現在の要素を選択に追加するには、command+shift + スペース バーまたは shift + スペース バーを押します。

モデル要素の追加と編集

タスクショートカットとアクション
プロパティ インスペクターを開くまたは非表示

Ctrl + Shift + I

macOS では、command+option+O を押します。 (R2023b 以降)

R2023b より前では、macOS では、command+shift+I を押します。

選択したブロックの主なパラメーターの設定Alt + Enter
クイック挿入メニューでモデルの現在の場所にブロックを追加

Simulink エディターのキャンバスをダブルクリックし、ブロック名の入力を開始してから、メニューからブロックを選択します。

Ctrl + ピリオド (.) を 2 回押してブロック名の入力を開始し、下矢印キーを押してリストからブロックを選択し、Enter キーを押してブロックを挿入します。

AZERTY キーボードでは、Ctrl + ピリオド (.) ではなく Ctrl + Shift + ピリオド (.) を使用します。

信号線に接続するブロックを選択

ポインターを信号線の接続されていない端部上に移動します。ポインターは、信号線の端部上に置くと円になります。信号線の端部をダブルクリックします。表示されるクイック挿入メニューを使用して、ブロックを追加します。ダブルクリックした信号線の端部に新しいブロックが接続されます。

クイック挿入メニューの使用方法の詳細については、Add Blocks to Models Using Quick Insert Menuを参照してください。

ライブラリ ブラウザーを開くCtrl + Shift + L
クイック挿入メニューでモデルの現在の場所に注釈を追加

Simulink エディターのキャンバスをダブルクリックして注釈の内容を入力し、注釈オプションを選択します。

Ctrl + ピリオド (.) を 2 回押して注釈の内容を入力し、下矢印キーを押して注釈オプションを選択し、Enter キーを押して注釈を挿入します。

AZERTY キーボードでは、Ctrl + ピリオド (.) ではなく Ctrl + Shift + ピリオド (.) を使用します。

選択したモデル要素をコピー

マウスの右ボタンで要素をドラッグします。

Ctrl キーを押しながらドラッグ。

Simulink エディター ウィンドウ間で選択したモデル要素をコピーウィンドウ間で要素をドラッグします。
選択したモデル要素を削除Delete または Backspace

モデル要素の接続

タスクショートカットとアクション
信号線を使用してブロックを結線

端子をクリックします。接続先の互換性のある端子の近くに表示される青いシェブロン記号 port hint symbol をクリックします。

最初のブロックを選択してから、Ctrl キーを押しながら 2 番目のブロックをクリック。

端子から端子にドラッグ。

端子を 1 つクリックして、Shift キーを押しながら次の端子に接続。Shift キーを押して、複数の連続した接続を行う。

信号線の分岐

端子を 1 つクリックし、分岐先の近くへカーソルを移動して、プレビューを確認してからクリック。

線を選択し、接続先の要素に向けてカーソルを移動し、端子の近くに表示される青いシェブロン記号 port hint symbol をクリックします。

Ctrl キーを押しながら線をドラッグ。

マウスの右ボタンを押しながらドラッグ。

複数の入力をもつブロックに端子を追加

互換ブロックまたは信号線から端子にドラッグ。

端子を追加するブロックの端からドラッグ。

端子の端をクリックし、ドラッグ。

端子の端をクリックし、メニューの信号タイプ (信号、バス、またはコネクタ) にカーソルを合わせ、ドラッグ。

選択したブロックの切り離し

Shift キーを押しながらブロックをドラッグ。

キーボードでブロックを選択した後、M を押してから Shift + 左矢印、右矢印、上矢印、下矢印を押します。

選択したブロックのコメント スルーCtrl + Shift + Y
選択したブロックのコメントアウトまたはコメント解除Ctrl + Shift + X

モデル要素名の指定

タスクショートカットとアクション
選択したモデル要素の名前変更

ラベルをクリックまたはダブルクリック。

要素を選択して F2 を押します。

macOS では、F2 キーではなく command+return を押します。

信号線の名前の設定信号をダブルクリックしてその名前を入力。
名前の付いた信号線の分岐に名前を表示分岐をダブルクリック。
信号線のすべての分岐の名前の設定信号を右クリックして [プロパティ] を選択し、[信号プロパティ] ダイアログ ボックスを使用。
信号のラベルおよび名前の削除ラベルで文字を削除するか [信号プロパティ] ダイアログ ボックスで名前を削除。
信号ラベルのみの削除 ラベルを右クリックして [ラベルの削除] を選択。
信号ラベルのコピーCtrl キーを押しながら信号ラベルをドラッグ。
Subsystem ブロックで端子ラベルを編集

端子ラベルにカーソルを合わせて対話型キュー (端子を囲む青色のボックス) をクリックします。

端子を選択します。端子ラベル キューをクリックし、F2 を押します。

信号端子のラベルの編集時にブロック名と信号名を切り替えるには、Ctrl + 1,2 を押します。

サブシステム ブロックで端子ラベルを連続して編集するには、次のようにします。

  • ブロックの端子を選択し、ラベルを編集して Enter キーを押します。このアクションにより、キーボードによる端子の選択が有効になります。

  • 上矢印キーまたは下矢印キーを使用して隣接する端子を選択し、F2 キーを押してすぐに編集できます。

ブロック線図の書式設定

タスクショートカットとアクション
モデルの自動調整Ctrl + Shift + A
幅と高さの比率を維持しながらブロックのサイズを変更Shift キーを押しながらハンドルをドラッグ
ブロックのサイズ変更 (中心から)Ctrl キーを押しながらハンドルをドラッグ
ブロック周囲のラインの描画描画中に Shift キーを押しながらドラッグ
ブロックの時計回り回転Ctrl + R
ブロックの反時計回り回転Ctrl + Shift + R
ブロックの反転Ctrl+I
選択によるサブシステムの作成Ctrl + G
空の選択からサブシステムまたは領域を作成

矢印キーまたはマウスを使用して変更できる、強調表示されたオプションを作成するには、次を行う。

  • 選択ボックス内をクリックする。

  • そして、Enter キーを押します。

オプションに関連付けられた数値キーを押す。

信号ラベルのフォントの変更信号線 (ラベルではなく) を選択し、[書式設定] タブで [フォント プロパティ] ボタンの矢印をクリックしてから [モデルのフォント] をクリック。
ブロックをマスクCtrl + M
Model ブロックの更新Ctrl + K

汎用アクションの実行

タスクショートカットとアクション
クイック アクション検索メニューで汎用アクションを実行

Simulink エディターのキャンバスをダブルクリックし、[アクション] タブを選択してアクション名または説明の入力を開始し、リストからアクションを選択します。

Ctrl + ピリオド (.) を押してアクション名または説明の入力を開始し、下矢印キーを押してアクションを選択し、Enter キーを押して実行します。

AZERTY キーボードでは、Ctrl + ピリオド (.) ではなく Ctrl + Shift + ピリオド (.) を使用します。

状況依存のアクションの実行

クイック アクション検索メニューを開く前に、モデル要素を選択します。

モデルのコードのシミュレーション、更新、生成

タスクショートカット
シミュレーションを開始するCtrl+T または F5
シミュレーションを中止するCtrl + Shift + T
モデルを更新するCtrl + D
[コンフィギュレーション パラメーター] ダイアログ ボックスを開くCtrl + E
モデルの作成 (コード生成用)Ctrl + B

シミュレーションのデバッグ

R2023b 以降

この表で示されているキーボード ショートカットは、Simulink エディター、Stateflow エディター、および MATLAB Function ブロック エディターで同じです。

タスクショートカット
ステップ オーバー

F10

macOS では、shift+command+O を押します。

ステップ イン

F11

macOS では、shift+command+I を押します。

ステップ アウト

Shift+F11

macOS では、shift+command+U を押します。

関連するトピック