Cannot run Matlab Student on Linux Mint

2 ビュー (過去 30 日間)
bdcxns 2018 年 5 月 6 日
編集済み: madhan ravi 2018 年 11 月 29 日
I just purchased the student version of Matlab and installed & activated following the instructions from Matlab. However, I cannot run it either with sudo or without.
With sudo, there is the license error saying the user name is different, I figure out that it becomes 'root' so is different from the username of the license. Without sudo, I got stuck at the splashscreen and can never go to the Matlab window. I have to enter ctrl-Z to stop it running from the terminal.
I tried to install in both the home directory and the default /usr/local directory trying to avoid the issue with administrative privilege, but the result is the same (stuck at the splashscreen). I also tried the matlab-support package, still no luck.
Thanks in advance for replying.


bdcxns 2018 年 5 月 6 日
編集済み: madhan ravi 2018 年 11 月 29 日
I found the answer here:
After adding the write permission by chmod a+w -R ~/.matlab, Matlab can start normally, without superuser privilege.
  4 件のコメント
Walter Roberson
Walter Roberson 2018 年 11 月 29 日
You probably do need sudo to install.
bdcxns 2018 年 11 月 29 日
if this is necessary then install in home directory and run without sudo as the student license only allow one user
I managed to solve this issue in this way


その他の回答 (0 件)


Help Center および File ExchangeIntroduction to Installation and Licensing についてさらに検索

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by