Does MathWorks provide any tools for automatically generating flight code for the Pixhawk platform?

13 ビュー (過去 30 日間)
I am using the Pixhawk autopilot system designed by the PX4 open-hardware project by 3D Robotics. Is there an existing Simulink library block-set for generating embedded C-code from Simulink for this platform?
  1 件のコメント
MathWorks Aerospace Products Team
MathWorks Aerospace Products Team 2016 年 2 月 26 日
編集済み: MathWorks Aerospace Products Team 2016 年 3 月 1 日
A new version of the Pixhawk Pilot Support Package (Version 1.3) has been released for MATLAB R2015b.
This release incorporates the following changes:
1) Added high-resolution timer (HRT) for posting the base-rate semaphore in the Nuttxinitialize.c scheduling code
2) Forked Firmware tied to Pixhawk PSP upgraded to Release v1.0.0 https://github.com/PX4/Firmware/releases/tag/v1.0.0
3) uORB Topic blocks for publishing and subscribing data
4) Ability to model asynchronous tasks that are driven by uORB topic events
5) ADC block support
6) Serial Rx/Tx Block support
7) Ability to read flight parameters in the generated code using storage classes
See: https://pixhawk.org/firmware/parameters
7) Various bug fixes
Included are also examples/tutorials that go over some of these new features.
NOTE: The R2015a and R2014b release of the Pixhawk PSP contain the exact same set of features and are considered the same version (Version 1.2) and represent the first public release. Please consult the documentation to learn more about the features contained within Release 1.2.

サインインしてコメントする。

採用された回答

MathWorks Aerospace Products Team
MathWorks Aerospace Products Team 2015 年 7 月 8 日
MathWorks has developed a Pixhawk Pilot Support Package (PSP) which provides a suite of Simulink blocks to target and interface with the Pixhawk FMU. To download the support package go to this page:
Please note that only MATLAB R2014b is supported at this moment.

その他の回答 (6 件)

Abhishek GS
Abhishek GS 2019 年 3 月 29 日
Hi All,
The official support package - 'Embedded Coder support Package for PX4 Autopilots' is now live from R2018b onwards.

Ahmad Drak
Ahmad Drak 2016 年 7 月 14 日
is there a release for ubuntu? running matlab 2016a?
  2 件のコメント
Ahmad Drak
Ahmad Drak 2016 年 7 月 17 日
2016a is not supported. Only 2015b

サインインしてコメントする。


Balaji Balasubramaniam
Balaji Balasubramaniam 2017 年 6 月 14 日
I am getting the following error: "Failed to load library 'AR_Drone_Positioning' referenced by 'Green_Ball_Tracking_Mounted/Flight Controller'". Can you please help?

Stephen Warwick
Stephen Warwick 2018 年 3 月 26 日
Are there plans to upgrade PSP support for MATLAB 2017b?
  4 件のコメント
Walter Roberson
Walter Roberson 2018 年 8 月 27 日
"This support package is available for 64-bit Microsoft® Windows® and Linux. This version of the support package is compatible with MATLAB R2017a and R2017b. It also works in MATLAB R2018a with limitations to External Mode functionality."

サインインしてコメントする。


jone1984
jone1984 2018 年 10 月 5 日
My OS is win10, Matlab is 2017b
these were what i have done and met:
download bash,install it.
download PSP, install it in matlab,
download Python, install it.
In the PSP UI, validate path, no problem. push download firmware button, after a whole night ,finished, on problem.
If i push the 'save setting and exit' button first ,error will tell no firmware, so I download firmware first.
install other tools by running 'windows_bash_nuttx.sh', error met as below:
do not know how to fix it.
then push build button ,met these message:
can not go on, how can i fix these?
  1 件のコメント
Matija Krznar
Matija Krznar 2019 年 2 月 3 日
They have created this script with windows editor and because of that linux have problems with space and newline.
Install a tool dos2unix and run it on script.
install:
sudo apt-get update
sudo apt-get install dos2unix
then use it on script:
dos2unix windows_bash_nuttx.sh
it worked for me.

サインインしてコメントする。


Stephen Warwick
Stephen Warwick 2018 年 11 月 29 日
Is support for R2018b planned in the near future? Will this block set be regularly updated for new versions. Just curious whether I should migrate or not to the newer version of Matlab/Simulink. Thank you
  1 件のコメント
Mahmud Khan
Mahmud Khan 2019 年 2 月 7 日
I can't even make it work with R2017a (yet).
I followed the instructions provided in the download page. It results in this error during the installation and its not like there's any support material/group to help anyone through all that.
Did you get to try it out?

サインインしてコメントする。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by