Simulink Blank Diagnostic Viewer

88 ビュー (過去 30 日間)
Thomas 2014 年 11 月 9 日
回答済み: Antonio Lira Verduzco 2023 年 9 月 22 日 0:32
Hi, I'm using Simulink (verions 2014a) for an assignment, who already purpose me a Simulink script (in version 2011a). After some modifications, I'm trying to launch it, but there are some errors. When I wanted to check the errors via the diagnostic viewer, I have a blank window li ke that :
How can I solve this bug ?
Thanks in advance. Thomas
  1 件のコメント
Thomas 2014 年 11 月 9 日
I forgot to said that I'm working on a Mac... Thanks. Thomas


回答 (18 件)

James Marriott
James Marriott 2020 年 7 月 28 日
Dont think Mathworks will ever fix this issue and its annoying as hell!

Kerry Schutz
Kerry Schutz 2014 年 12 月 18 日
Hi Thomas,
I am hitting a similar problem in R2014b on Windows7. I am researching the issue now. When I find an answer I will post back to this forum. Hopefully the fix will be the same for Mac and Windows.
  2 件のコメント
Bryan Wasileski
Bryan Wasileski 2015 年 5 月 1 日
I have 15a and it's doing the same thing. The bug still exists. I restarted MATLAB and it did not fix it.


WILLIAM LEMEILLEUR 2015 年 1 月 29 日
Hello guys,
I'm like you thomas:
Have you found a fix for this issue? Do you know if it's possible to go back as it was done in old matlab, with the debug messages into the command window instead of the "Diagnostic viewer" if this component does not work correctly ?
Thanks by advance,

Thomas 2015 年 1 月 31 日
I didn't find any way to solve it, it was solved by himself ! Don't ask me how is it possible...I just remove and install again Matlab.
You can try to do this, but I cannot guaranty you a positive result, sorry !
Thanks a lot for your answers !
PS admin : need I to close this post/question, or leave it like this and wait for better answers for the next guys ?
  1 件のコメント
Paul 2015 年 1 月 31 日
Are you still using 2014a or the latest version (2014b)?


Carlo Avizzano
Carlo Avizzano 2015 年 4 月 16 日
Apparently the same thing happens on my machine after I have a DHCP renew, and in combination with this message on the command line (cometD server?)
INFO [bayeux.server.ServerSession] Emergency sweeping session 2jjj0hls7pxwgwcndqv4pdzyl - last connect 30007 ms ago
Maybe simulink uses a server logger to capture these messages?
BTW, is there any way to completely disable the Diagnostic viewer and getting back to the previous diagnostic style?

Khalid 2016 年 9 月 30 日
Hi guys!!
I was using Matlab 2015a but now I'm using Matlab 2016a and I'm facing the same problem so I would like to ask if anyone know how to solve this problem.
Looking forward for you attantion and thanks in advance.

J.W. Harris
J.W. Harris 2018 年 1 月 16 日
2016a definitely has this problem STILL and re-starting does not help. The viewer only works once in a great while for me. This command will allow one to update the model and see the output in the console: set_param(bdroot, 'SimulationCommand', 'update')

Bhavanithya Thiraviaraja
Bhavanithya Thiraviaraja 2018 年 4 月 11 日
I have 2017a. The problem still exists. It got resolved after restarting it. Mathworks probably should look into this issue.

Sascha Rimet
Sascha Rimet 2018 年 7 月 11 日
編集済み: Sascha Rimet 2018 年 7 月 11 日
I have the same problem. I am using 2017b. The diagnostic viewer is permanently blank and neither reinstalling Matlab nor restarting it solves the issue. The error appeared after the latest windows update. Without the diagnostic viewer, simulink is basically unusable...
It's honestly embarrassing that this error is now existing for 4 years without a fix
  1 件のコメント
Nithya Padmanaban
Nithya Padmanaban 2018 年 10 月 31 日
Hello Sascha, Our support records show that this issue was related to an incompatible NVIDIA graphics card driver version, and switching OpenGL to 'software' helped resolve the issue. If the incorrect behavior still exists. Please do let us know.


Nithya Padmanaban
Nithya Padmanaban 2018 年 10 月 31 日
Thank you for your feedbacks.We recommend to update your release to R2018b for an enhanced usability of diagnostic viewer. If the problem still persist, please contact us with sample model and reproduction steps at

Ziniu Lu
Ziniu Lu 2018 年 11 月 9 日
I am using R2018a. Still, the same question!
  2 件のコメント
Ziniu Lu
Ziniu Lu 2018 年 11 月 12 日
編集済み: Ziniu Lu 2018 年 11 月 12 日
I'm using MATLAB 2018a on Win8.1 System. it works again now but I don't know why.
  • 1. I restarted my Computer -> didn't work
  • 2. I added ' localhost' in the file 'hosts.txt' --> didn't work
  • 3. restarted MATLAB2018a for three times --> worked again


Jordan Smith
Jordan Smith 2019 年 9 月 28 日
Same issue with R2019a

Laith Mohammed
Laith Mohammed 2019 年 12 月 29 日
Dear Friends,
I had the same problem with matlab 2015b
The simulink shows black content of files that I have worked on before.
I did the following started the Matlab two times and the first one did not open the file while he second one did open it.
So, this is the solution that worked with me openning two matlab's windows and then closing the one that does not open.
Regards to everybody.
  1 件のコメント
hb z
hb z 2020 年 7 月 19 日
Thanks. I open two matlab, and both of the two work.


Mikayla Bridges
Mikayla Bridges 2020 年 1 月 31 日
Same issue with 2019a, but Laith's recomendation worked, open a second while the first malfunctioning one is still up and then the diagnostic will no longer be blank. You can then close the first window.

Louis THOMAS 2020 年 3 月 23 日
Same issue with R2019b. I tried to switch from Hardware to software on OpenGL but still does not work. Thanks in advance if you know how to fix this
  3 件のコメント
Ali Saj
Ali Saj 2021 年 9 月 19 日
I have R2018b and i run what Augusto said. It works !
Thank You Augusto.
  • note that you should change modelname to the name you saved your simulink


Codrut Alexandru Dan
Codrut Alexandru Dan 2021 年 9 月 2 日
Bug seems to be still there in 2019b, restarting MATLAB fixed it here.
For me, the issue appeared when I tried to open the link to the issue block by using middle mouse button (reflex for open in new tab...)
Another option is simulating model from script using 'sim' so the errors are thrown in the command line.

Aiden 2023 年 5 月 10 日
Working on 2022b, trying to open diagnostic viewer and I don't even get a blank box, it just doesn't open at all. There's no indication of it loading when I click on it?
  2 件のコメント
Antonio Lira Verduzco
Antonio Lira Verduzco 2023 年 9 月 22 日 0:31
Not working for me. R2023a.


Antonio Lira Verduzco
Antonio Lira Verduzco 2023 年 9 月 22 日 0:32
Same for me, very little information online and nothing has work out. R2023a


Help Center および File ExchangeConfigure and View Diagnostics についてさらに検索

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by