MATLAB Answers

Simscape powergui - Invalid dimension specified for input port

1 ビュー (過去 30 日間)
Hi there,
I've seen very similar questions to this with the same error however I haven't seen one that has a clear answer/reason as to why the error appears.
I'm modelling a wind turbine and for some reason get this error with the powergui block and don't really know why or where it arises from.
I've went to the specific input port of the 'gate' and it appears to be one of the diodes of my IGBT's for my converter model - but this is still quite weird to me as a lot of the other gates in the block are also from diodes of the IGBT and don't produce an error even though they are all connected in the same fashion.
It appear sas though some other people have had the same issue so i was wondering whether anyone could shed some light on the matter.
Thanks!
  1 件のコメント
Abd Al-Rahman Al-Remal
Abd Al-Rahman Al-Remal 2021 年 7 月 1 日
I've attached a photo here of the diodes and you can see that there isn't really any difference in how it is connected comapred to the other ones.

サインインしてコメントする。

採用された回答

Pemendra Kumar Pardhi
Pemendra Kumar Pardhi 2021 年 7 月 1 日
Hi
This error occurs due to, you are providing 6 input signals on gate signal of each IGBT, moreover only single gate signal is required to each IGBT.
Give a single gate signal to the IGBT, this way your error will not be occured.
  4 件のコメント
Abd Al-Rahman Al-Remal
Abd Al-Rahman Al-Remal 2021 年 7 月 1 日
Oh okay yeah I had the same though but was worried that the PWM would then be split into the base components instead but I'll give that a shot

サインインしてコメントする。

その他の回答 (0 件)

コミュニティ

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by