MATLAB Answers

Simulink Network not working same as Matlab Network

5 ビュー (過去 30 日間)
Himanshu Dubara
Himanshu Dubara 2021 年 4 月 17 日
コメント済み: Himanshu Dubara 2021 年 4 月 30 日
I have trained and tested a fitnet neural network in matlab. later I tried generating its simulink model to deploy it on raspberry pi using:
gensim(net_voltage1,-1)%net_voltage1 is the name of my network
I then copied the network block and put it in my simulink model.However the output received for the test data in simulink is not the same as that of the output received while testing the nework in matlab. How do I rectify this?

採用された回答

Maadhav Akula
Maadhav Akula 2021 年 4 月 22 日
Hi Himanshu,
Try setting up the initial conditions of the model using setsiminit, please refer this example.
  2 件のコメント
Himanshu Dubara
Himanshu Dubara 2021 年 4 月 30 日
On viewing the example it says a simple gensim will do for a feed forward network. However I tried the following
[xs,xi,ai,ts] = preparets(net_voltage1,test_volt_in.Data,{},test_volt_out.Data);
On running this it gave me an error
Error using preparets (line 194)
Number of feedback signals not equal to all feedback (0) or open feedback (0) outputs.
what do I do?

サインインしてコメントする。

その他の回答 (0 件)

製品


リリース

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by