Why is fimplicit not plotting x^2 = 0 ??

9 ビュー (過去 30 日間)
Mohit Kumar
Mohit Kumar 2020 年 10 月 1 日
編集済み: Mohit Kumar 2020 年 10 月 1 日
I have a code that takes in an implicit function from the user and then plots it. However, I ran into this odd problem where fimplicit is not plotting anything when the function is x^2. The code I entered :
fimplicit(@(x,y) x.^2,[-5 5 -5 5],'b-');
The output is just a plain white plot. No blue line at x=0. However, if I simply change my function to x.^2 - 1, everything works as expected. I'm guessing there is some trouble caused by the fact that x^2 is "tangential" to zero. (I know that this may be incorrect terminology.)
Is there any workaround for this?
EDIT: I am looking for a fix not only for the case of x.^2. The recommended solution must also be able to plot implicit functions as that is the primary requirement.
Thanks,
Mohit.

回答 (2 件)

madhan ravi
madhan ravi 2020 年 10 月 1 日
fplot()
  1 件のコメント
Mohit Kumar
Mohit Kumar 2020 年 10 月 1 日
The function entered by the user will, in general, be a function of x and y. As far as I understand, fplot works only for a single variable.
That is, the code below does not work.
fplot(@(x,y) x.^2)

サインインしてコメントする。


KSSV
KSSV 2020 年 10 月 1 日
x = linspace(-5,+5,100) ;
y = x.^2 ;
plot(x,y)
  1 件のコメント
Mohit Kumar
Mohit Kumar 2020 年 10 月 1 日
Perhaps I should have made this clearer in the question itself. The function entered by the user will, in general, be implicit. Say something like x^2*y^2+x^3*y^4+x+tan(x*y)+5=0.
That is why I cannot use plot.

サインインしてコメントする。

製品


リリース

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by