Incorrect RequirementInfo Formatting from ''Requirements Summary Table'' slreportgen component

5 ビュー (過去 30 日間)
In 19a (no update installed just the baseline release) when the property "RequirementInfo" is selected in the property columns of the report generator component "Requirement Summary Table", the resulting Requirement info in the table is poorly formatted. This occurs only when the requirement is coming from a Requirement Set file (slreqx). The online examples using excel etc are reporting "RequirementInfo" correctly.
It was expected to see just the requirement description text here. However, there is some leading and trailing html style referencing of the location of this Requirement Description text cluttering up the field in the table.
Is this fixed in a 19a update or is there a work around?
As work around I had considered:
  1. extracting the necessary requirements as an object (req=find(rs,'Type','Requirement','ID',reqIDxyz)
  2. Get the Description of the requirement reqDescriptionString = req.Description (at this step you will see a bunch of leading and trailing edge html code wrapped around the Description field).
  3. Remove the necessary html code using extractBefore/ extractAfter commands
Above gives you the requirement description text clean. But it's a long way around and now you also need to setup your own table in the report, instead of using the convenient "Report Summary Table".
  1 件のコメント
Adam Whitmill
Adam Whitmill 2020 年 5 月 6 日
Hi Artem, it worked and removed the HTML code (it took a while to install the file as I don't have write privileges in the instillation).
However, I was wondering if there is any other way to further customise what “RequirementInfo” puts in the “Requirment Summary Table”. Ideally you just want the table with 3 fields, which model object the requirement is linked to, the requirement ID and the actual requirement text.
When you use this feature on a requirement from Excel, this is exactly what you get. When the requirement was from a requirement set, the requirement text is together with a bunch of other stuff about what file the requirement was in etc etc, You get this all together in one field. It looks a bit untidy and there seems to be no way of removing it all.
My assumption is you cannot use this report generator component and the RequirmentiInfo property together with requirement sets, to generate a clean looking table. if you want to further customise it you need to make your own table programmatically and strip all the other stuff away from the requirement text using MATLAB.
Is this correct or is there an example of such a table being generated available?

サインインしてコメントする。

回答 (1 件)

Artem
Artem 2020 年 3 月 27 日
Yes, this is a bug in the Product. I have just created a formal record (g2206550) and will be nominating it for next update of released product. What happens, req.Description is a rich-text field, but we need plain text for this report purpose. There is a step to strip HTML tags, but we make a mistake and leave some parts of the <style> tag. I will attach a fixed file here. You will need to put it under toolbox/shared/reqmgt/+linktypes. Sorry about the inconvenience.
  3 件のコメント
Artem
Artem 2022 年 12 月 20 日
Ruili, this was fixed in FCS of R2020b, and also in R2020a update 1, although the fix is different from what we did in R2019b. If you are still experiencing a similar problem in R2020b, please confirm.

サインインしてコメントする。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by