Workspace data is not reflected in the model

3 ビュー (過去 30 日間)
sintu kumari
sintu kumari 2020 年 1 月 14 日
編集済み: sintu kumari 2020 年 1 月 14 日
We have used the 'From Workspace ' block in the model to pass the inputs from .mat file . Although the values of the signals from .mat file is properly reflected in the workspace , but it is not getting propogated in the model at correct time stamp.
We have not used the default setting of the 'From workspace' ,instead we have used the below shown settings.
InkedCapture_LI.jpg
However, When we are using the default settings , we observed the values of the signals from .mat file is properly reflected in the workspace , propogated in the model at correct time stamp.i.e
InkedCapture_1_LI.jpg
Also, as per our requirements we don't want to interpolate the data .
Could you please suggest the correct setting of the'From Workspace'

回答 (1 件)

Raj
Raj 2020 年 1 月 14 日
Ok to summarize, you have a time series data in your workspace which you want to import to Simulink at appropriate time stamps. Between one time stamp data to next, you want to hold the value and not interpolate.
I tried something simple like this and it seems to be working:
>> A=[0 0;1 1;2 2;3 3;4 4;5 5]
Saves 'A' in workspace as:
A =
0 0
1 1
2 2
3 3
4 4
5 5
where I assume my first column is time and second column is data.
Now a Simulink model with setting as shown will give you required output:
Capture.JPG
Capture1.JPG
Capture2.JPG
Hope this helps!!
  1 件のコメント
sintu kumari
sintu kumari 2020 年 1 月 14 日
Thanks for your responds . But this is not much helpful. Check the aatached files:

サインインしてコメントする。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by