MATLAB Answers

Getting an error GTK+ module libcanberr​a-gtk-modu​le.so cannot be loaded. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.

38 ビュー (過去 30 日間)
Anil Kemisetti
Anil Kemisetti 2019 年 10 月 2 日
回答済み: Hari Krishna Ravuri 2019 年 11 月 7 日
I am getting this error,
(MATLAB:14295): Gtk-WARNING **: 08:58:49.363: GTK+ module libcanberra-gtk-module.so cannot be loaded.
GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported.
Gtk-Message: 08:58:49.363: Failed to load module "canberra-gtk-module"
[1002/085850.986027:INFO:context.cpp(159)] Using multi-threaded message loop for Linux
I have already installed "sudo apt install libcanberra-gtk-module libcanberra-gtk3-module"

  0 件のコメント

サインインしてコメントする。

回答 (2 件)

Niklas Wulms
Niklas Wulms 2019 年 10 月 17 日
I got the same error - also I have installed the mentioned modules, and furthermore installed them additionally in 32-bit and 64-bit. Both did NOT help.

  0 件のコメント

サインインしてコメントする。


Hari Krishna Ravuri
Hari Krishna Ravuri 2019 年 11 月 7 日
I have heard that this issue is known and the concerned parties may be investigating further.

  0 件のコメント

サインインしてコメントする。

製品


リリース

R2019b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by