MATLAB Answers

Not responding on startup, macOS Mojave

363 ビュー (過去 30 日間)
William Smith
William Smith 2019 年 9 月 17 日
コメント済み: Pedro Bezerra 2021 年 6 月 24 日
I have just installed MATLAB 2019b on a Macbook Pro 2019 running macOS Mojave 10.14.6.
Just after installation, Matlab ran fine. However, if I now try to open it I see the splash screen then it freezes on the Matlab window showing no content and I have to force quit. If I run from the command line with -nodesktop it works and I can even load the desktop from there and it works ok. But if I try to load directly it hangs. I doubt it is a conflict as I have installed barely anything else on this macbook yet.
  28 件のコメント
Sebastian Sas Brunser
Sebastian Sas Brunser 2020 年 12 月 2 日
Thanks Simardeep Hari . This solved my problem.

サインインしてコメントする。

回答 (22 件)

Jon Gotow
Jon Gotow 2019 年 10 月 29 日
編集済み: Jon Gotow 2021 年 3 月 21 日
I'm the developer of Default Folder X. With the help of Philip Slaymaker I've tracked down the issue with Matlab. Matlab doesn't launch correctly if other apps use the Accessibility API (a part of macOS) to query it for information while it's launching.
A number of apps use the Accessibility API to communicate with other applications. These include Default Folder X, Magnet, Spectacle, and most other utilities that help you arrange / resize windows. If you run into this problem, you can narrow down the possible culprits by going to System Preferences > Security & Privacy > Privacy > Accessibility. This list shows all the applications that you've given permission to use the Accessibility API - one of them is triggering the bug in Matlab and causing it to hang. You'll need to use a process of elimination to determine which one, but it'll usually be an app that gets and sets information about other applications' windows.
Note that contacting the developer of any of these applications won't really help much, as it's not their fault. The fundamental issue is that Matlab contains a bug that causes it to hang when other apps request information via the Accessibility API. That bug needs to be fixed to resolve this problem. Phil Slaymaker submitted the bug to MathWorks - hopefully they'll fix it soon.
In the meantime, if you're a Default Folder X user, I have a version of DFX that may successfully work around the problem. I'd appreciate hearing from you at support (at) stclairsoft (dot) com.
- Jon
  27 件のコメント
Pedro Bezerra
Pedro Bezerra 2021 年 6 月 24 日
Thank you!
I have MatLab R2020a running in a 2011 MacBook Pro with High Sierra macos. I disabled Spectacle in System Accessibility and worked fine!

サインインしてコメントする。


CoolNickname
CoolNickname 2020 年 3 月 16 日
編集済み: CoolNickname 2020 年 3 月 24 日
I had the same problem today with R2019b. Out of nowhere - well, after installing update 5 of R2019b - it stopped working. MATLAB would just not open after clicking it. The little dot under thy icon appeared and disappeared shortly after.
But I was able to start MATLAB through the terminal via
/Applications/MATLAB_R2019b.app/bin/matlab
But the real problem solver was to give it full disk access. For that please go to Preferences > Security & Privacy > Privacy > Full Disk Access. There you should check MATLAB. Or, if it isn't listed, click on the + and look for it in the Application folder and add it to the list manually. After doing that it was good to go.
I also use the app "Magnet", but that didn't cause the problem. However, one should constrain Magnet to ignore MATLAB, otherweise MATLAB could be quite laggy.
Hope that helps.
  8 件のコメント
Miguel Cruz
Miguel Cruz 2020 年 10 月 28 日
Thank you soo much coolnickname

サインインしてコメントする。


Selene Schmittling
Selene Schmittling 2020 年 4 月 22 日
Here I am again in this Discussion thread. I was so hoping I wouldn't have to return.
I run MATLAB R2019b on macOS Catalina 10.15.4. I have not had issues with MATLAB in a while then suddenly (when I'm under a time crunch, of course) I get the whiring pinwheel of death every time I open MATLAB.
What I am posting now is a quick and dirty way to get a responsive instance of MATLAB (I can't worry about an actual fix right now).
I open an instance of Terminal. I type "/{path_to_your_matlab_application_folder}/bin -nodesktop" (replace the material in braces {} with the path to your Matlab application folder).
This starts a command line instance of MATLAB (I assume). At the ">>" prompt I type "desktop".
Then I find myself in a working instance of MATLAB able to do my work.
You can find this solution by querying "MATLAB not responding". I may have cobbled it together by reading more than one post. I wanted to share here in the hopes that it kept others from unnecessary hair loss.
Regards,
S
  11 件のコメント
Anand Kulkarni
Anand Kulkarni 2021 年 3 月 31 日
Thank you for posting this!! It works for me. 2020a with 10.14.6.

サインインしてコメントする。


Lin Qi
Lin Qi 2020 年 8 月 12 日
Here is a solution maybe. Open MATLAB, and then open another app, or let another app come into the front, anyway let the MATLAB starting in the background. Then it would successfully startup every time on my laptop. If I just open MATLAB and let it starting in the front, it would be randomly a success or failure. Can't find any pattern.
  6 件のコメント
Peter Kaczkowski
Peter Kaczkowski 2020 年 12 月 11 日
Changing focus works for me too with 2019b. Unfortunately, the code I need to run does not yet work with 2020b, so I'm SOL.

サインインしてコメントする。


Zongde Qiu
Zongde Qiu 2019 年 9 月 19 日
same issue on MacOS 10.14.6

Selene Schmittling
Selene Schmittling 2019 年 9 月 23 日
I have finally gotten MATLAB 2019b to work on my mac with os 10.14.6.
Initially, I could not even get MATLAB to run in Safe Boot Mode. However, after a clean uninstall (including deleting Mathworks folder out of "Application Support" folder, I was able to get it running.
There were four possible sources of conflict: Goolge Drive Stream, OneDrive, Spectacle and Echo Desktop auto-loader (loads when Echo pen connected to USB).
I turned all these off and opened MATLAB and it worked.
I turned off the automatic load of Echo Desktop and turned it back on. MATLAB still working
I also have a piece of software called Spectacle, which sizes windows with keystrokes. I turned that off and have since turned it back on and am still running MATLAB successfully.
I have not started up Google Drive Stream or OneDrive yet. I'm just so happy to have MATLAB working, I don't want to tempt fate. When I turn these back on, I'll post back my results.
I hope this helps someone else struggling with this issue too.
Regards and good luck,
  5 件のコメント
Selene Schmittling
Selene Schmittling 2019 年 11 月 3 日
UPDATE:
AAAAAARRRRGGGHHHH!!!! This ridiculous bug is back (of course when I need to get some work done). I have this issue on a Mac Book Pro 2016 running Catalina 10.15.1.
MATLAB® people: please, please fix this.
I have been running MATLAB fine, even with Spectacle running, then out of the blue, MATLAB hangs again. Once it hangs, there is no way to get it running without reinstalling the whole mess again shy of (hopefully) booting in safe mode.
I went in and removed all items that required accessibility to whit: Spectacle, Duet and Google File Drive Stream. I have rebooted my machine (multiple times) and MATLAB still hangs.
This is beyond infuriating. I'm going to boot into safe mode and hope I can get my work done.

サインインしてコメントする。


Jason
Jason 2019 年 12 月 1 日
I'm not sure if this is related, but when I upgraded to Catalina, I lost the ability to access many folders on my computer (Matlab R2017b). I added Matlab under System Preferences --> Security & Privacy --> Privacy --> Full Disk Access, but it didn't change anything. Upon bootup, Matlab can't find many of the files in the Matlab path. And I can't navigate to a lot of folders on the disk.
  1 件のコメント
Jason
Jason 2019 年 12 月 1 日
I think I found the reason for the issue. Catalina moves any folders in the root directory of the computer into this folder: /Users/Shared/Relocated Items.
This effected some of my folders, so I will have to update everything in my Matlab path definition file unfortunately.

サインインしてコメントする。


Feiran li
Feiran li 2020 年 2 月 14 日
Have the same problem Matlab2019b macOs Catalina 10.15.3. solved the problem by blocking Dropbox from System Preferences --> Security & Privacy --> Privacy --> Accessibility.
  3 件のコメント
George A.
George A. 2020 年 11 月 24 日
I had to remove the app Contexts. Dropbox is ok for me.
With Contexts enabled I have to delete the folder "~/Library/Application\ Support/MathWorks/MATLAB/R2019b/" before opening Matlab.

サインインしてコメントする。


Jonathan Lilly
Jonathan Lilly 2019 年 10 月 4 日
A perhaps similar issue for me. Matlab 2019b was working, but there was a strange bug which is that I was unable to select text with the mouse in Matlab, which I do all the time. After reading this thread, I traced the problem to a window-sizing software called Magnet that I had recently installed. This solved the problem. Thanks!

Philip Slaymaker
Philip Slaymaker 2019 年 10 月 26 日
I had a similar issue with Matlab 2019b (Matlab 2019a worked fine) not finishing initializing the command window and then freezing, requiring a force quit of Matlab. This happened on both Mojave 10.14.6 and High Sierra 10.13.6 on the iMac 27 2019 and 2017, respectively. I found that quitting and not running Default Folder 5.4.1 at all (or earlier versions) allowed Matlab to load and run. Rerunning Default Folder while Matlab was running caused Matlab windows to freeze.

Andriy Yabluchanskiy
Andriy Yabluchanskiy 2019 年 11 月 7 日
編集済み: Andriy Yabluchanskiy 2019 年 11 月 7 日
i found that the problem, at least on my end, is somehow connected to the network in my institution. matlab runs fine when on my home network but always freezes on splash screen when at work
macOs Catalina 10.15.1
Matlab 2019b

robin tournemenne
robin tournemenne 2020 年 1 月 23 日
I also have this problem. Among the list of possible conflicts with other softwares I see spectacle that I use basically always. Very annoying, please do something mathworks, now I need to work in the terminal witht he command matlab -nodesktop...

Selene Schmittling
Selene Schmittling 2020 年 1 月 23 日
So, for the last few months, I have basically resorted to unloading Spectacle whenever I use MATLAB and not loading it again until I've close MATLAB.
This is extremely annoying but certainly less annoying than the unending spinning pinwheel of death.
Since using this procedure, I have not encountered any freezing issues. I have not checked whether OneDrive or Google File Stream continue to be issues. I will try to remember to do that and report back.
Regards,
S

Yiqian Qian
Yiqian Qian 2020 年 2 月 24 日
For my case, it conflicts with Google Drive Backup & Sync.app. when i quit Google Drive, it can be launched succesfully.

Mickey London
Mickey London 2020 年 4 月 28 日
The feedback of disabling accessibility applications worked for me. The App the caused the issue was Magnets.
When checked out, Matlab stopped hanging.
Thanks

Sangjae
Sangjae 2020 年 6 月 29 日
編集済み: Sangjae 2020 年 6 月 29 日
I have same problem, MATLAB 2020a & MacOS Catalina
  2 件のコメント
Sangjae
Sangjae 2020 年 6 月 30 日
Thanks!, I tried removing all items checked in the accessibility,
but, unfortunately, it doesn't work in my case.
when I checked the syslog (/var/log/system), it said
com.apple.xpc.launchd[1] (com.mathworks.matlab.19992[1601]): Service exited with abnormal code: 1

サインインしてコメントする。


Stefan Baginski
Stefan Baginski 2020 年 8 月 15 日
My solution to this and the only one which allowed me to start MATLAB again was to delete the ~/Library/Application Support/MathWorks/MATLAB/R2020a
Afterwards MATLAB started again but unfortunately your settings are gone. So I recommend to make a copy of the folder just in case. But so far I was not able to figure out which file is causing the issue.
  3 件のコメント
Dave
Dave 2020 年 9 月 4 日
Yes, this was mentioned above, and it works for me. Easy but not very satisfying.

サインインしてコメントする。


Toby Driscoll
Toby Driscoll 2020 年 9 月 2 日
For me the key was adding MATLAB to System Prefs / Security & Privacy / Accessibility. I'm running DFX, Dropbox, Google Drive Stream, and Spectacle–did not have to change those.
(This is for release 2020a on Catalina.)
  2 件のコメント
Dave
Dave 2020 年 9 月 4 日
Yes, this did not work for me either.

サインインしてコメントする。


Griffin Willis
Griffin Willis 2020 年 9 月 7 日
This has been happening to me too, I've figured out a way around it by simply going into your documents and opening a matlab file from your folders to launch matlab that way.
  1 件のコメント
Jon Sporring
Jon Sporring 2020 年 10 月 13 日
I just had this problem with R2020b (9.9.01467703) on macOS Catalina (10.15.7). It was solved by starting /Applications/MATLAB_R2020b.app/bin/matlab from a terminal (with full disk access) once. Now Matlab does not hang, when I start it from Finder. Good luck.

サインインしてコメントする。


Brett Tofel
Brett Tofel 2020 年 10 月 25 日
Same on bug on 2020a for Mac Catalina as with 2020b above, and same fix, but I remember this dumb bug from like 2018? This should really get fixed!

Guo Jack
Guo Jack 2020 年 12 月 6 日
編集済み: Guo Jack 2020 年 12 月 6 日
I tried above advices but it's still not working. I found another solution from
https://www.mathworks.com/matlabcentral/answers/501420-i-installed-and-activated-matlab-on-macos-catalina-but-it-s-not-opening
This is what I did:
1) Open terminal and type (you need to change the version in the following command line)
/Applications/MATLAB_R2020a.app/bin/matlab -nodesktop
2) Type “desktop” when matlab starts
3) Go to desktop matlab preference. Under "general", change the initial working folder to another one and it workded for me.
I benefit a lot seeking solutions for matlab issues and want to thank you all in this forum.
Hope it helps for y'all.

Gregor Dumphart
Gregor Dumphart 2020 年 12 月 11 日
I was also troubled by Matlab R2020b getting stuck usually in the first minute of use on macOS Big Sur. I followed all suggestions in this topic, but to no avail.
Here's what fixed it for me: In System Preferences -> Accessibility -> Zoom, deactivate everything, especially Advanced -> Smooth Images. Immediately, my Matlab experience became a hundred times more fluent and I am stuck-free ever since.
Cheers

タグ

製品


リリース

R2019b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by