"This canvas does not support painters" error flooding command window

2 ビュー (過去 30 日間)
Carson Lay
Carson Lay 2019 年 8 月 22 日
コメント済み: Matthias Walle 2019 年 12 月 23 日
I have an issue using the appeditor. The error "This canvas does not support painters" floods my command window. I am using an app that was created by another user on a different computer, possibly with a different version of MATLAB.
  2 件のコメント
Carson Lay
Carson Lay 2019 年 10 月 22 日
The app was designed in 2018b, and I am using 2019a.

サインインしてコメントする。

回答 (1 件)

Siriniharika Katukam
Siriniharika Katukam 2019 年 10 月 24 日
I understand that you were receiving the error "canvas does not support painters" on opening your App with AppDesigner in MATLAB R2019a.
The issue is caused due a bug in MATLAB R2019a and has been fixed in MATLAB R2019b.
If the "DefaultFigureRenderer" property of "groot" was set to painters when the MLAPP file was saved, the error will occur if the MLAPP file is opened in MATLAB R2019a. Here is how to check the value of "DefaultFigureRenderer":
>> get(0, 'DefaultFigureRenderer')
  1 件のコメント
Matthias Walle
Matthias Walle 2019 年 12 月 23 日
I am having the same problem. I changed the Renderer back to opengl but the error still occurs now. App was created in R2019a and error occurs in R2019a. I cannot upgrade.

サインインしてコメントする。

カテゴリ

Find more on Develop Apps Using App Designer in Help Center and File Exchange

タグ

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by