Error when running programme on external Android

5 ビュー (過去 30 日間)
Kiat Nern Yeo
Kiat Nern Yeo 2019 年 6 月 7 日
コメント済み: Kiat Nern Yeo 2019 年 6 月 19 日
Hello all
I have encountered this error repeatedly, without being able to find a solution at all.
The test app by MATLAB Connector works perfectly fine.
The applications i create are able to run when uploaded using "deploy to hardware"
However, when the play button is pressed, the following error is obtained, as a result, i cannot read my android's sensor data in my MATLAB PC.
""
Error occurred while executing External Mode MEX-file 'ext_comm': Failed to connect to the target. Possible reasons for the failure: a) The target is not switched on. b) The target is not connected to your host machine. c) The application for the model is not running on the target. You might have clicked the Stop button. If the Run button is not dimmed, click it. Otherwise, click the Build button, which downloads and runs your application on the target. Caused by: An error occurred attempting to open an rtIOStream. More detail may be reported in the MATLAB command window
""
Any help is greatly appreciated.
Thank you !

採用された回答

Kiat Nern Yeo
Kiat Nern Yeo 2019 年 6 月 10 日
Hi Sir
Yes i have used both the simulink display block, and the android data display, and have also set the mode to external and run time to inf.
Both these signals are coming out from the same android sensor block.
Best regards
  5 件のコメント
Kiat Nern Yeo
Kiat Nern Yeo 2019 年 6 月 11 日
Ok got it. Will call them. Thank you very much !

サインインしてコメントする。

その他の回答 (2 件)

Sruthi Yenugula
Sruthi Yenugula 2019 年 6 月 7 日
Hi,
Use this link to run the external mode
Make sure your device and pc are connected to same wifi network when running external mode.
  1 件のコメント
Kiat Nern Yeo
Kiat Nern Yeo 2019 年 6 月 19 日
Yup i got it. The solution is to make sure that both devices are connected to the same private and secured network !

サインインしてコメントする。


Kiat Nern Yeo
Kiat Nern Yeo 2019 年 6 月 9 日
Hi Sir. Thank you for replying
I have went through the example and the app can indeed be deployed onto my phone, and the sensor values can be read within my phone's screen.
However, it still does not show up in simulink's scope or display blocks.
I have also performed androidhwsetup, and the test app can run.
The USB cable is also always attached, and both the phone and computer are connected to the same private network.
I also have the proper android driver installed, along with the required android studio SDK and NDK.
Is there something that i could have missed ?
Best regards sir.
  2 件のコメント
Kiat Nern Yeo
Kiat Nern Yeo 2019 年 6 月 19 日
Yup i got it. The solution is to make sure that both devices are connected to the same private and secured network !

サインインしてコメントする。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by