MATLAB Answers

0

Simulink crash - unexpected exception

Lukasz Grabowski さんによって質問されました 2019 年 4 月 20 日
最新アクティビティ George Iskander さんによって 回答されました 2019 年 6 月 1 日
Hello,
my name is Lukas.
Once I open Simulink I got the following error:
Unexpected exception (mwboost::interprocess::intermodule_singleton initialization failed) was caught.
Then, when I try to add a block, Simulink and Matlab crash, giving following error.
Internal program error while accessing database.
I attach the report.
I will be greatful for any help you can give me.
Happy Easter,

  0 件のコメント

サインイン to comment.

3 件の回答

回答者: Lukasz Grabowski 2019 年 4 月 22 日

With help from Matlab and Microsoft support we found up that the solution is simple.
Open "Disk Cleanup" in Windows 10, clear system files, the reboot Windows.
It is a work around way for solving this issue, but for now the working one (2019a version of Matlab)

  4 件のコメント

Lukasz Grabowski 2019 年 5 月 2 日
I do not know then.
MatLab support answerd me this:
>To clear the logs, you can Run Event Viewer as Admin user, clear the logs in "Windows >Logs/System" and restart the machine. You can refer to the 3rd party tutorial below to try it out:
Howerver this didnt work for me so I used "Disk Cleanup" instead to clear system logs. Remember to restart your system.
I have to do this every time I open my Windows again.
Check if your error report is the same as mine.
Erik Vogt
2019 年 5 月 17 日
Hello thank you for the feedback, this was also the „solution“ the matlab service offered, however it is only a temporary solution. Mathworks is already working to fix the problem with the next release so far i know
George Iskander 2019 年 5 月 29 日
It worked :) :) Thanks Lukasz Grabowski
I've used Disk-clean up and Event view method then I restared my PC
And simulink started normally......
But I have another problem ....
Simulink Onramp failed to launch... Any Help .......

サインイン to comment.


回答者: Italo Belli 2019 年 5 月 17 日

I have the same problem, I tried using "Disk Clean-up" and restartin my laptop but it did't work. Is there a more effective solution to this?

  2 件のコメント

Erik Vogt
2019 年 5 月 17 日
Use the event viewer solution , however after every restart the failure will occur. My solution was to install 2018b
Italo Belli 2019 年 5 月 19 日
Hi,
I installed Matlab 2018b and it works fine (so far)! Thank you very much for your answer!
PS: anyway, I hope that the reason for the problem can be found in 2019 version...

サインイン to comment.


回答者: George Iskander 2019 年 6 月 1 日

I've used Disk-clean up and Event view method then I restared my PC
And simulink started normally......

  0 件のコメント

サインイン to comment.



Translated by