MATLAB Answers

panda
0

PixhawkPSP used in matlab R2017b in linux

panda
さんによって質問されました 2018 年 10 月 25 日
最新アクティビティ Abhishek GS
さんによって 回答されました 2019 年 4 月 2 日
Hi,everyone,I have installed Pixhawk Support in matlab20217b in linux, when I click the Dowloand Firmware,it begin git clone Px4Firmware from github, but some modules couldn't not found, the modules include "NxWidgets", "misc/tools", and "nuttx".
the question as follows:
.... Username for 'https://github.com': xiongmaoshisb
Password for 'https://xiongmaoshisb@github.com':
remote: Repository not found.
fatal: repository 'https://github.com/PX4-NuttX/NxWidgets.git/' not found ..
when I download Firmware in bash on windows in windows10,it also has this problem,can sommeone help me? Thank you very much!

  1 件のコメント

panda
2018 年 11 月 2 日
Tank you T.A.C.J.M. Albers,I will accept you response.

サインイン to comment.

2 件の回答

回答者: T.A.C.J.M. Albers 2018 年 10 月 30 日
 採用された回答

Hi Panda,
My installation also resulted in an error in Matlab R2017b. The clone in the GUI resulted in the same error as yours. However, I tried manually cloning the repository as is discussed in the manual:
https://nl.mathworks.com/hardware-support/forms/pixhawk-downloads-conf.html?elqsid=1540927154536&potential_use=Education
Afterwards, you need to make sure the Simulink module is present in the Firmware folder and is included in the make file. That should solve your problem.

  2 件のコメント

Nicola Misurati 2018 年 11 月 6 日
Hello T.A.C.J.M.
You said that "Afterwards, you need to make sure the Simulink module is present in the Firmware folder and is included in the make file. "
In my Firmware folder I don't have that Simulink module. What can I do? Thanks
T.A.C.J.M. Albers 2019 年 1 月 20 日
Hi Nicola,
I'm sorry for the late response, I'm quite bussy lately. However, I'm still encounting issues with the PSP. The progress I have made so far is described here:
My contribution is mainly related to my university, so their might be some additional steps in order to make it work, and others are unnesesary. However, it describes the missing module you are talking about, so take a look and perhaps it might help you solve your issue.
Lastly, I'm still updating every now and then, so solutions might be updated. But as of sofar, take a look at it and I'm sure it might help you.
Best, Tom

サインイン to comment.


回答者: Abhishek GS
2019 年 4 月 2 日

The official support package 'Embedded Coder Support Package for PX4 Autopilots' is now available from R2018b onwards.
Here is the documentation on getting started with the official support package.
~Abhishek

  0 件のコメント

サインイン to comment.



Translated by