I can't start Matlab through Jenkins?

6 ビュー (過去 30 日間)
Partha Mitra
Partha Mitra 2018 年 9 月 23 日
コメント済み: 건희 김 2022 年 8 月 11 日
I have written few m scripts and made a windows batch file out of them. The created batch file ran as well when i try using cmd. But same batch file when i use in Jenkins, Matlab doesn't at all start? What should I do?
Eg: I am also trying as below (Simple way to check): Created a Batch File called Test.bat having below content:
C:\MATLAB\R2010b\bin\matlab.exe -r "disp('Hello World!')"
Now when I am putting this batch file (Test.bat) in Jenkins project as Execute windows batch command, I get following:
Console Output in Jenkins: Started by user admin Building in workspace C:\Program Files (x86)\Jenkins\workspace\Test [Test] $ cmd /c call C:\Windows\TEMP\jenkins7251338391131038286.bat
C:\Program Files (x86)\Jenkins\workspace\Test>C:\Partha\Try\20180917_Master\Test.bat
C:\Program Files (x86)\Jenkins\workspace\Test>C:\MATLAB\R2010b\bin\matlab.exe -r "disp('Hello World!')" Finished: SUCCESS
But Matlab is not started through this.

回答 (1 件)

Nico Müller
Nico Müller 2019 年 5 月 22 日
I have the same problem. Did you solved the problem?
  2 件のコメント
Sameer Gadekar
Sameer Gadekar 2022 年 4 月 27 日
Hello @Nico Müller @Partha Mitra ,I'm also facing similar issue. Could you please share the solution ?
건희 김
건희 김 2022 年 8 月 11 日
Did you solved the problem?

サインインしてコメントする。

カテゴリ

Help Center および File ExchangeIntroduction to Installation and Licensing についてさらに検索

製品


リリース

R2010b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by