Why do I get a "MATLABWindow application failed to launch" error when launching Live Editor, App Designer, or any other MATLAB/Simulink UIs on Ubuntu 18.04 using MATLAB R2017b or R2018a?

546 ビュー (過去 30 日間)
I have recently upgraded to Ubuntu 18.04 LTS. When I try to open App Designer, Live Editor, or any other MATLAB/Simulink UIs, I get the following error message:
ERROR: >> appdesignerError using appdesservices.internal.browser.WebWindowController/startBrowser (line 87)
Unable to start App Designer due to an internal error.
MATLABWindow application failed to launch. Unable to launch the MATLABWindow application
or I get a modal dialog (pop-up box) with the following text:
The Live Editor is unable to run in the current system configuration.
For more information, see Live Editor Requirements
The above window appears despite all the published Live Editor requirements being satisfied. What could be causing this on Ubuntu 18.04 LTS and how can it be fixed?

採用された回答

MathWorks Support Team
MathWorks Support Team 2021 年 1 月 6 日
編集済み: MathWorks Support Team 2020 年 10 月 30 日
Issue summary:
This is occurring due to a library incompatibility between Ubuntu 18.04 and MATLAB R2017b/18a. MATLAB R2017b and R2018a were built using libglib-2.0.so.0 version 4200 and version 5400 respectively. However, Ubuntu 18.04 ships with libglib-2.0.so.0 version 5600. Therefore at run-time, one of MATLAB's calls to the libglib-2.0.so.0 library fails when the expected symbol is not found in the older version of the library. 
To narrow-down the issue to exactly the one described here, please try running the following code on the affected system:\n
>> w = matlab.internal.webwindow('http://mathworks.com')
The above line of code will show the following error message on systems which are affected by this issue: \n\n
ERROR: Error using matlab.internal.webwindow (line 310)
MATLABWindow application failed to launch. Unable to launch the MATLABWindow application
\n
Workaround:
The workaround for this issue is identical to one published in a previous bug report for a MATLAB R2017b issue with Ubuntu 17.10: 
The workaround requires modifying one of the libraries in the MATLAB installation directory. Note that the first line below may need to be changed if MATLAB is not installed in the default location. Additionally, this may require administrator privileges on your system: 
# cd /usr/local/MATLAB/R2017b
# cd cefclient/sys/os/glnxa64
# mkdir exclude
# mv libglib-2.0.so* exclude/
# exit
\nOnce the libglib-2.0.so libraries are moved, please try running the following code again:
>> w = matlab.internal.webwindow('mathworks.com')
>> w.show
\nIf the workaround has been applied correctly, the above code will launch a mini-browser window that shows the mathworks.com website.
The MATLAB developers are aware of this issue and may provide a fix for this in a future MATLAB update. 
  11 件のコメント
Nilo
Nilo 2022 年 11 月 24 日
you should exclude libtiff* and libfreetype* in /bin/glnxa64

サインインしてコメントする。

その他の回答 (5 件)

Martin Gladis
Martin Gladis 2021 年 3 月 4 日
編集済み: Martin Gladis 2021 年 3 月 4 日
In my case i removed from /usr/local/MATLAB/R2020b/bin/glnxa64 file libcrypto.so.1.1 (I use fedora 33)

Utku Kaya
Utku Kaya 2021 年 4 月 18 日
I had the same problem in my MATLAB R2021a in RHEL 8. Removing file libcrypto.so.1.1 from .../MATLAB/R2021a/bin/glnxa64 solved the problem for me.
  1 件のコメント
scivision
scivision 2021 年 5 月 24 日
Thanks renaming or removing libcrypto.so.1.1 also makes it work for CentOS 8 Stream with Matlab R2021a

サインインしてコメントする。


Frank van Diggelen
Frank van Diggelen 2022 年 10 月 25 日
I have the same problem with R2022a, and the above fixes do not work for me:
1) there are no files: MATLAB/r2022A/bin/glnxa64/libglib-2.0.so*
I moved libgdk* and libgtk* to exclude/ but that didn't help
2) there is no file: MATLAB/r2022A/bin/glnxa64/libcrypto.so.1.1
  1 件のコメント
Raphaëlle Schlienger
Raphaëlle Schlienger 2022 年 10 月 27 日
I'm on Linux Debian bookworm sid
"I fixed it by running the following commands.
cd <matlab installer root directory>
cd /bin/glnxa64
ls | grep libfreetype
mkdir exclude
mv libfreetype.so.6 exclude/
mv libfreetype.so.6.16.0 exclude/
"
Worked for me too !

サインインしてコメントする。


Hafeez Jimoh
Hafeez Jimoh 2019 年 10 月 20 日
This works for me. Thank you

Pablo sanchez
Pablo sanchez 2020 年 2 月 27 日
Excellent¡¡
Thank you very much¡¡
It works perfectly¡¡

カテゴリ

Find more on Environment and Settings in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by