MATLAB Answers

0

copy from UITABLE to clipboard not working

Gregory McFadden さんによって質問されました 2017 年 4 月 24 日
最新アクティビティ Luna
さんによって コメントされました 2019 年 10 月 16 日
I have a UI table, I used to be able to copy from it to the windows clipboard, but now it no longer copies. I have absolutely no idea what has changed nor where to look for the problem. Any thoughts on where the problem might be?
thanks Greg

  0 件のコメント

サインイン to comment.

タグ

製品

3 件の回答

Answer by Gregory McFadden on 25 Apr 2017
 Accepted Answer

it actually was some kind of "as currently running" issue. Restarting matlab fixed the issue.

  0 件のコメント

サインイン to comment.


xi
Answer by xi
on 25 Apr 2017

You may want to change the uitable property of 'ColumnEditable' from true to false. When it is true, you can edit, but can't copy the whole table to clipboard (can only copy one cell at a time). When it is false, you can't edit, but can copy the talbe. I usually add a toggle button beside the uitable, so that users can switch between copy mode and edit mode. I'm not sure if this is the problem you encountered.

  1 件のコメント

Interesting, I did not know that.

サインイン to comment.


Feng
Answer by Feng
on 10 Oct 2019

i also have this problem with 2019b. has anyone found a solution?

  4 件のコメント

This is frustrating. I have tried many different ways but still can't get around this issue...
Matlab has confirmed the function is missing for uitable and hopefully this will be addressed in the next release. in the meantime, use clipboard for it but i won't copy the format of the table.
I think writing our own copy to clipboard function and calling it in cellSelectionCallback will solve. But I haven't tried yet. I will give a feedback asap.

サインイン to comment.



Translated by