Issue with print -depsc in R2015a

7 ビュー (過去 30 日間)
Maja
Maja 2017 年 1 月 10 日
回答済み: Jyotish Robin 2017 年 1 月 16 日
I work almost exclusively with eps figures and produce them with the command >> print -depsc [filename]. Today I was not able to load such a figure in LibreOffice. My old eps-files were loaded as usual. So was the same plot created by going to File > Save As > and then choosing eps file in the menu.
I looked into the eps file of this plot created in three different ways (files included in attached zip-file):
1) File > Save As > EPS figure : SaveAs.eps 2) print -depsc print: print.eps 3) print -depsc2 print: print2.eps
Option 1) worked in LibreOffice, but not 2) and 3). The only difference I could see was that SaveAs.eps had a completely different bounding box.
What has changed and how can it be fixed? Going through the menu every time I want to save a plot is not on option. I run Matlab R2015a on Ubuntu 16.04.
  1 件のコメント
Jan
Jan 2017 年 1 月 10 日
Please explain "did not work" with any details: Do you get an error message or does the displayed results differ from your expectations?

サインインしてコメントする。

回答 (1 件)

Jyotish Robin
Jyotish Robin 2017 年 1 月 16 日
I have taken a look at the EPS files you attached. It seems that the EPS files are still readable via other vector graphics viewers. This likely results from the limitations of the EPS drivers, as the EPS files can still be viewed with other PostScript viewer applications.
As a workaround, I suggest you use an alternative vector data type such as the Enhanced Metafile format (EMF). The EMF file can be generated via the following:
>>print -dmeta custModel.emf
Hope this helps!

カテゴリ

Find more on Printing and Saving in Help Center and File Exchange

製品

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by