xlsread - Undefined function 'dec2base27

5 ビュー (過去 30 日間)
Andre Labuschagne
Andre Labuschagne 2016 年 10 月 12 日
コメント済み: Walter Roberson 2017 年 2 月 2 日
Hi I am running R2013a on Windows 7 Prof. I have been successfully using xlsread in a script to read .xlsx spreadsheets (Excel 2010) - worked 100%. Last night I accidentally opened another instance of Matlab, my pc slowed down dramatically, but the script was still executing. I then closed both instances of Matlab and opened only one instance. Since then I have been getting this error: Undefined function 'dec2base27' for input arguments of type 'double'. Searches via Google show quite a few similar problems. I have tried the following (without success): (I used the function as follows: [~,~,RAW]=xlsread(FILE,SHEET,RANGE)) a] Have relevant spreadsheet open/closed will running the script. b] Removing the 'Range' argument. c] Added the 'basic' argument. d] Changing spreadsheet to Excel 97 format. e] Disabling Excel add-ins: - Send to Bluetooth" (btsendto_office.dll) - I do not have this add-in: ADTAPLib.ApproveItAddin
Please advise Thanks Andre
  3 件のコメント
Jan
Jan 2016 年 11 月 13 日
@MEBARA TANGA Serge: Please post the message as text, not as screen shot. It is much easier to ask an internet search engine for details, when I can use copy&paste, instead of typing the text by my own.

サインインしてコメントする。

回答 (3 件)

Walter Roberson
Walter Roberson 2016 年 11 月 13 日
In R2013b, dec2base27 was a function inside of xlswrite.m and xlsread.m did not use dec2base27 at all.
You should be checking for the possibility that you are using an old version of xlsread.m . In R2013b, line 105 of xlsread.m should say
% $Revision: 1.23.4.43 $ $Date: 2012/12/10 23:52:43 $

Pritesh Shah
Pritesh Shah 2016 年 10 月 12 日
Dear Andre,
Restart the laptop. It may work.. :))
  1 件のコメント
MEBARA TANGA Serge
MEBARA TANGA Serge 2016 年 11 月 13 日
Hi, I have the same problem. I have already restart the laptop but it doesnt work.
Can you help me?

サインインしてコメントする。


Jen
Jen 2017 年 1 月 31 日
Hi, I have the same problem. The error message is:
Error using xlsread (line 248)
Undefined function 'dec2base27' for input arguments of type 'double'.
Line 105 of xlsread.m says exactly:
% $Revision: 1.23.4.43 $ $Date: 2012/12/10 23:52:43 $
Thank you for your answer!
  6 件のコメント
Walter Roberson
Walter Roberson 2017 年 2 月 2 日
A 2015 copyright certainly should not have been present in R2013b. You might need to reinstall MATLAB to get the correct version.
Had you installed a Mathworks patch at some point?

サインインしてコメントする。

タグ

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by