フィルターのクリア

Why do I get an "failed to connect error" when trying to connect my Lego Mindstorms EV3 robot with Simulink?

7 ビュー (過去 30 日間)
When trying to deploy my Simulink model to my Lego Mindstorms EV3 robot I get the following error message:
ERROR: The call to realtime_make_rtw_hook, during the after_make hook generated the following error:
Failed to connect to EV3 (192.168.179.21). Please check your network settings.
The build process will terminate as a result.
Caused by:
Failed to connect to EV3 (XXX.XXX.XXX.XX). Please check your network settings.
Component: Simulink | Category: Model error
Where XXX.XXX.XXX.XX is the IP of my EV3. The behavior started only recently. Connecting to the brick in MATLAB works fine. The firmware version is V1.09H.

採用された回答

MathWorks Support Team
MathWorks Support Team 2024 年 4 月 18 日
編集済み: MathWorks Support Team 2024 年 4 月 18 日
In the firmware version V1.09H, SSH and telnet are blocked by Lego. The interface Simulink uses to connect to the brick relies on these two types of connections while the interface used in MATLAB does not.
In order to be able to connect to the brick, use an older Firmware version, for example 1.03. Please contact Lego support on how you can access older versions of firmware:
Note that the firmware versions 1.06, 1.07 and 1.08 are also known to work with the Simulink support package for LEGO MINDSTORMS EV3 without any known issues. However the support package is tested thoroughly only with 1.03 version of the firmware.
Previous firmware releases can be difficult to obtain, so a fix has been released to allow compatibility with
. Note that
 for this version.

その他の回答 (0 件)

カテゴリ

Help Center および File ExchangeLEGO MINDSTORMS EV3 Hardware についてさらに検索

タグ

タグが未入力です。

製品


リリース

リリースが未入力です。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by