MATLAB Answers

K E
0

Why "Name is nonexistent or not a directory" only when Adminstrator?

K E
さんによって質問されました 2016 年 1 月 20 日
最新アクティビティ K E
さんによって コメントされました 2016 年 1 月 22 日
In the past couple days, Matlab has developed some strange behavior: If I run it as an administrator, it can't seem to access a remote drive ("Name is nonexistent or not a directory" upon startup when it tries to load my path; can't change directories to that drive), even though I can access that drive outside of Matlab. However when I run Matlab as a non-administrator, the error doesn't happen and I can access directories on the drive. What could be going on? More details: The drive is a NAS device mapped to a drive letter on my Windows 7 machine, and I am running 2015b.

  3 件のコメント

Kirby Fears
2016 年 1 月 20 日
Network drive letter mappings are specific to the user currently logged in. Running as admin may be temporarily assigning you a different admin username that does not have your drive mapped to that letter.
You could try using the actual network path to the remote drive instead of the mapped drive letter and see if that works.
Walter Roberson
2016 年 1 月 20 日
Is it possible that the NAS is mounted by NFS (Network File System)? NFS behaves like that.
K E
2016 年 1 月 22 日
Yes, the actual network path works when I am running Matlab as admin. I will ask about NFS. The strange thing is that I previously was able to access that NAS when running Matlab as an admin.

サインイン to comment.

0 件の回答


Translated by