MATLAB Answers

GPU CUDA problems: CUDA_ERROR_UNKNOWN

61 ビュー (過去 30 日間)
Thomas Hansen
Thomas Hansen 2015 年 5 月 26 日
回答済み: Yuya Kodama 2020 年 11 月 20 日
Hi I use a GeForce GTX 980 with Ubuntu 15.04, but I have trouble using the GPU from within Matlab. When i run gpuDevice I get the following error " >> g=gpuDevice Error using gpuDevice (line 26) An unexpected error occurred during CUDA execution. The CUDA error was: CUDA_ERROR_UNKNOWN "
Can anyone help me figuring out what the problem is?
  1 件のコメント
Joss Knight
Joss Knight 2015 年 5 月 28 日
What version of MATLAB are you using?

サインインしてコメントする。

回答 (6 件)

Ashish Gudla
Ashish Gudla 2015 年 5 月 27 日
編集済み: Ashish Gudla 2015 年 5 月 27 日
It is possible that the CUDA driver might be causing the error message. Do you have the latest drivers installed? If not, install the latest drivers and verify if you still see the error message.
You can get the drivers from:
  1 件のコメント
hongshaorou
hongshaorou 2018 年 3 月 15 日
thanks,I am trying to solve.

サインインしてコメントする。


Wajahat
Wajahat 2015 年 12 月 3 日
Try starting matlab with sudo:
>> sudo /usr/local/MATLAB/R2014a/bin/matlab -desktop

Douglas
Douglas 2015 年 7 月 18 日
編集済み: Douglas 2015 年 7 月 20 日
It seems to be a permission error. I've started matlab as root and, in my case, the problem was solved.
To run as normal user, see this:
https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-331/+bug/1361207
You have to install nvidia-modprobe package.

Yue Bai
Yue Bai 2017 年 8 月 21 日
I met the same problem, solved with restart computer

SATYAM KUMAR CHOURASIYA 16MCA1038
SATYAM KUMAR CHOURASIYA 16MCA1038 2018 年 3 月 12 日
Error using parallel.gpu.CUDADevice.hBuild
An unexpected error occurred trying to retrieve CUDA device properties. The CUDA error was:
CUDA_ERROR_UNKNOWN
my gpu device having computing capacity of 2.1 ,
can u elaborate this is the reason of this issue or something else?

Yuya Kodama
Yuya Kodama 2020 年 11 月 20 日
In my environment, everything from R2020b to R2016a had the same error with no gpu available.
The GPU is Tesla K80 * 2 and the OS is Ubuntu 18,04.
When I checked, nvidia-smi was OK, but even python tensorflow could not call the GPU.
The reason was that my predecessor had left behind a blacklist.conf configuration file with a fixed driver version.
So, all drivers could not be loaded by modprove.
Therefore, I think that the dependencies were broken with the version upgrade.

タグ

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by