MATLAB コマンド ラインから Simulink モデルのバージョンを​設定するには、どうす​ればよいですか?

7 ビュー (過去 30 日間)
MathWorks Support Team
MathWorks Support Team 2024 年 2 月 6 日
編集済み: MathWorks Support Team 2024 年 2 月 29 日
MATLAB コマンド ラインからモデルの Simulink バージョンを設定したいです。
モデルのバージョンは下記コマンドで照会することができます。
get_param(bdroot,'Modelversion')
しかし、モデルのバージョンを設定したい場合、
set_param(bdroot,'Modelversion',1.2)
次のエラーが表示されます。
???==> set_param の使用中にエラーが発生しました
block_diagramパラメーター 'Modelversion' は読み取り専用です。

採用された回答

MathWorks Support Team
MathWorks Support Team 2024 年 2 月 29 日
編集済み: MathWorks Support Team 2024 年 2 月 29 日
MATLAB コマンド ラインから現在の Simulink モデルのモデル バージョンを変更するには、次のコマンドを使用します。
set_param(bdroot,'Modelversionformat','3.5')
 

その他の回答 (0 件)

カテゴリ

Help Center および File Exchangeプログラムによるモデル編集 についてさらに検索

製品

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!