Accurate measurement of inverter and motor efficiency

62 ビュー (過去 30 日間)
ALEXANDER
ALEXANDER 2023 年 1 月 17 日
コメント済み: Joel Van Sickel 2023 年 2 月 28 日
I am building a model of a 300V, 100A DC-3φ inverter connected to a permanant magnent motor and am having trouble measuring inverter and motor efficiency. To measure efficency I need to find power. I am measuring DC power at the battery, AC power at the inverter, and mechanical power at the motor - however, I am getting very different power measurements for each, where I would expect around 10% deviation.
DC power at the battery is measured with the "Power Sensor" block. AC power at the inverter is measured two ways: with the "Power Sensor (Three-Phase)" block, and with the formula Pac=3/2*((Iq*Vq)+(Id*Vd)) (which is what we use to measure AC power on the hardware). Mechanical power at the motor is measured with the "Ideal Torque Sensor" block to get torque, and the "Ideal Rotational Motion Sensor" to get speed, and power is then calculated with P=Torque*((60/(2*pi))*Speed)/9.554. All measurements should be in watts. This is the result:
Red line is measured with the formula, green line is measured with the sensor. Any idea on why I have such large differences in power measurement, and how I can make it more accurate?
  2 件のコメント
Joel Van Sickel
Joel Van Sickel 2023 年 2 月 17 日
are you able to share your model?
ALEXANDER
ALEXANDER 2023 年 2 月 27 日
@Joel Van Sickel Attached is my current model, based on the Three Phase PMSM Drive sample. I have improved accuracy somewhat, but it is still quite inaccurate (it should be that Pm < Pabc < Pdc at all times by conservation of energy, but it isn't).

サインインしてコメントする。

回答 (2 件)

Sulaymon Eshkabilov
Sulaymon Eshkabilov 2023 年 2 月 17 日
One quick note is the equations and conversions. It looks like there is a "pi" magnitude problem in your calculations of power.

Joel Van Sickel
Joel Van Sickel 2023 年 2 月 28 日
編集済み: Joel Van Sickel 2023 年 2 月 28 日
Thank you for the model. The good news is your model is simulating correctly, and your assumptions are correct. The problem is the sensor setup and the filtering. One issue is that your 3 phase power calculation is doing line voltage * phase current. It needs to be line voltage * line current. This can be configured in the sensor you have on the three phase line. Another issue is that the filter you have on the 3 phase power is a different time constant than the filter on the other 2 signals. The final issue is that the filters are defaulting to discrete time. For this system, that is enough quantization error to further make the 3phase measurements wrong. If you change their time step to 0, you should get a continuous time filter implementation. If you do these things, you will be comparing apples to apples and not have quantization effects from discrete filters. This will cause the DC power signal to be highest and the mechanical power to be lowest (I also set external torque to 0 just to make sure I was comparing apples to apples, but you should be able to put external torque back in the way you have the system set up.)
  2 件のコメント
ALEXANDER
ALEXANDER 2023 年 2 月 28 日
@Joel Van Sickel Thank you for answering, those results look much better. Could you link the updated model? I am having trouble configuring line current.
Joel Van Sickel
Joel Van Sickel 2023 年 2 月 28 日
Sure thing, here it is!

サインインしてコメントする。

カテゴリ

Help Center および File ExchangeElectromechanical についてさらに検索

製品

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by