Segmentation algorithm not giving correct output

2 ビュー (過去 30 日間)
Shoaib Ali
Shoaib Ali 2022 年 8 月 4 日
コメント済み: Shoaib Ali 2022 年 9 月 12 日

Hi ,
I am evaluating segmentation models with my own data. Only FCN produces the right segmented output for test images, but other segmentation models (such as U-Net and SegNet) produced really odd results. The segmented pixels are dispersed throughout the whole image instead of the targeted region. Even if I evaluate my trained model using the training data.
What may be the reason behind that?
This is segmented output by SegNet.

This is segmented output by FCN.

  1 件のコメント
sudobash
sudobash 2022 年 8 月 19 日
Your images are not visible.

サインインしてコメントする。

回答 (1 件)

Birju Patel
Birju Patel 2022 年 9 月 8 日
Generally, FCN, U-Net, and SegNet are different architectures that require their own set of training options to produce optimal results. You cannot assume they will all converge to the same results.
For instance, U-Net does not use a pre-trained backbone so it can take longer to train compared to FCN, which uses a VGG-16 image net pretrained backbone.
  1 件のコメント
Shoaib Ali
Shoaib Ali 2022 年 9 月 12 日
Thank you for your answer.
You mean I have to train each network with diffferent hyperparameters to figure out the best values of parameters for each model?

サインインしてコメントする。

カテゴリ

Find more on Deep Learning Toolbox in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by