フィルターのクリア

Getting an error when running a simulation 3d scene configuration block with Simulation 3d vehicle model block

38 ビュー (過去 30 日間)
Below is the error I am facing:
Caused by: Could not establish communication with 3D simulation engine. Restart the simulation. If problem persists, contact MathWorks.
Can you please assist, do you have any suggestions to the issue. I am using a company laptop so deleting the latest windows updates isn't possible. Thank you

回答 (1 件)

Chandrika
Chandrika 2024 年 2 月 5 日
Hello Fadi,
Please make sure you are following the steps as mentioned here in the following documentation:
Besides, verify once that you are reparenting the blueprint as described in the "Reparent Actor Blueprint" section of "https://www.mathworks.com/help/driving/ug/customize-scenes-using-simulink-and-unreal-editor.html" document.
Further, once upon clicking on “Run” in the Simulink model, make sure you are starting the simulation by clicking on “Play” in the Unreal Editor. This is because the source of the scenes is the project opened in the Unreal Editor.
Also, when you click "Run" in Simulink, verify that the Diagnostic Viewer window in Simulink displays the following message:
"In the Simulation 3D Scene Configuration block, you set the scene source to 'Unreal Editor'. In Unreal Editor, select 'Play' to view the scene."
This message confirms that Simulink has instantiated vehicles and other objects in the Unreal Engine environment.
Hope this helps!

製品


リリース

R2022a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by