Matlab crashed on start on Fedora 36

462 ビュー (過去 30 日間)
Hyma Harish Vallabhapurapu
Hyma Harish Vallabhapurapu 2022 年 4 月 19 日
コメント済み: Chandram 2022 年 9 月 25 日 7:34
As title suggests, matlab crashes when launched form the terminal on Fedora 36. There are lots of Java errors. the version of Matlab I am using is 2021b. See attached image for error. Running ./bin/glnxa64/MATLABWindow gives the error symbol lookup error: /lib64/libcairo.so.2: undefined symbol: FT_Get_Color_Glyph_Layer
For reference, matlab worked fine on Fedora 35. I had upgraded just two days earlier.
  1 件のコメント
Riccardo Scorretti
Riccardo Scorretti 2022 年 4 月 21 日
Up to my (limited) experience, this could be due to an incompatibility between the libraries shipped with MATLAB and the ones installed in the system. Usually this kind of very nasty problem can be solved either by removing the version of the library shipped with MATLAB, or by downgrading the cluprit library.
Assuming that the library which is at the origin of the problem is libcairo.so.2, which is not shipped with MATLAB, you can try the following procedure:
  1. download the previous version of the library from https://download-ib01.fedoraproject.org/pub/fedora/linux/releases/35/Everything/aarch64/os/Packages/c/cairo-1.17.4-4.fc35.aarch64.rpm. It should be a file named cairo-1.17.4-4.fc35.aarch64
  2. Extract the file (don't install, just extract it) and copy the file libcairo.so.2.11704.0 somewhere (personally I would copy it into /usr/lib64)
Now, I would like to run MATLAB by using: LD_PRELOAD=/usr/lib64/libcairo.so.2.11704.0 matlab. Unfortunately I get the error:
ERROR: ld.so: object 'libcairo.so.2.11704.0_copy' from LD_PRELOAD cannot be preloaded (cannot open shared object file): ignored.
I think that if you manage to solve this problem and preload the version of the library shipped with F35, your problem could be solved. I hope it helps.

サインインしてコメントする。

回答 (4 件)

Anil GURSES
Anil GURSES 2022 年 5 月 1 日
I solved the problem by downgrading libcairo and dependent packages. You can use the command below,
sudo dnf install cairo-1.17.4 --releasever=35
If you still encounter an error, try to link /lib64/libcairo.so to /lib64/libcairo.so.2.
sudo ln -s /lib64/libcairo.so /lib64/libcairo.so.2
I hope this helps.
  3 件のコメント
Julio Larco
Julio Larco 2022 年 5 月 14 日
編集済み: Julio Larco 2022 年 5 月 14 日
Only remove files " rm libfreetype.so.6*" of the installer. I don't remember where I saw that, but this works for me.

サインインしてコメントする。


Trevor Vannoy
Trevor Vannoy 2022 年 6 月 28 日
There's no need to downgrade libcairo to the Fedora 35 version. According to the Arch Wiki The issue stems from the version of libfreetype that ships with MATLAB.
I fixed the issue by setting aside MATLAB's libfreetype.so.6.16.0 library, then symlinking to my system's libfreetype.s0.6:
cd /usr/local/MATLAB/R2022a/bin/glnxa64
sudo mv libfreetype.so.6.16.0{,.bak}
sudo ln -sf /lib64/libfreetype.so.6 libfreetype.so.6

Viktor Erdelyi
Viktor Erdelyi 2022 年 5 月 16 日
I'm using 2022a, but I managed to fix the issues by moving/removing the following files
  • mv sys/opengl sys/opengl_BAK
  • rm sys/os/glnxa64/libstdc++*
  • rm bin/glnxa64/libfreetype*
  1 件のコメント
Chandram
Chandram 2022 年 9 月 25 日 7:34
This absolutely works on R2022b

サインインしてコメントする。


Cristian Le
Cristian Le 2022 年 6 月 21 日
Is this issue still prevelant in R2022b? Pinning cairo to an old releasever is not an ideal solution for the users.
  1 件のコメント
Trevor Vannoy
Trevor Vannoy 2022 年 6 月 28 日
You don't need to downgrade cairo. See my answser: https://www.mathworks.com/matlabcentral/answers/1699735-matlab-crashed-on-start-on-fedora-36#answer_995890

サインインしてコメントする。

製品


リリース

R2021b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by