my firing angle on this triac does not work correctly ?

6 ビュー (過去 30 日間)
noble amin
noble amin 2022 年 1 月 7 日
回答済み: Joel Van Sickel 2022 年 1 月 11 日
Hi everyone, I have implemented a triac circuit with a resistive load, when I run the simulation I have 3 curve (figure 2), the problem is that the curves are wrong compared to the theory (figure 3), so surely my firing angle alpha = 36 ( figure 4) has a problem under the mask.
Guys if one of you knows how to implement a correct firing angle , explain to me plz. thanks
figure 1
figure 2
figure 3
figure 4

回答 (3 件)

Dr Narayanaswamy P R Iyer
Dr Narayanaswamy P R Iyer 2022 年 1 月 7 日
For switching thyristors, you may refer to the following text book:
NARAYANASWAMY P R IYER: "Power Electronic Converters Interactive Modelling Using Simulink", CRC Press / Taylor and Francis, 2018, Chapter 2.

R SRIRANJANI RAMAKRISHNAN
R SRIRANJANI RAMAKRISHNAN 2022 年 1 月 8 日
Thyristor 1 is 36 degree , then thyristor 2 is 180+36 degree with phase delay of 0.01sec.

Joel Van Sickel
Joel Van Sickel 2022 年 1 月 11 日
My first guess would be that you need to double the rate of your firing. It looks like you are triggering the first thyristor correctly for the positive portion of the sine wave, but need to trigger the other thyristor for the negative side. This is what R Sriranjani Ramakrishnan is suggesting. You can either have double the rate, or add a second pule generator running at 36+180.

コミュニティ

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by