Problems in reading XLSX file

9 ビュー (過去 30 日間)
pietro
pietro 2014 年 10 月 31 日
Hi all,
I have some problems in reading xlsx files. I use the readtable command because I can get a structure where the fields have the same name of the header of the excel file, but I get the same problem with xlsread. Yesterday everything worked fine but not today. When I type:
[~ ~ raw]=xlsread('Filename.xlsx')
matlab halts, niether CTRL+C works, I have to kill the excel process and then it's fine. Here the error I get.
Error using xlsread (line 247)
Error: The remote procedure call failed.
Error in importdata>readFromExcelFile (line 707)
[n,s,raw] = xlsread(FileName,descr{i});
Error in importdata (line 165)
out = readFromExcelFile(FileName, descr, out, bFlatten);
I have discovered the problems doesn't appear if I specify the cell range to read, but as I said, yesterday it worked fine without. What may I do to solve the problem?
Thank you

回答 (0 件)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by