Stateflow shows a dimension error for an output port?

3 ビュー (過去 30 日間)
Ayham Aljawabrah
Ayham Aljawabrah 2021 年 11 月 26 日
編集済み: Ayham Aljawabrah 2021 年 12 月 21 日
I am using Statefloe, specifically, Simulink based state and experiencing a problem. My Model have 5 states and uses one simulink function to check the transition conditions based on different integrators states and another function to set the state of the associated integrators in different states at the transition.
My chart contains only '8 output', as seen in the red box, right of the 2ed picture. However, the following error keeps appearing for 'Output Port 10' which does not exist in my model:
Error in port widths or dimensions. 'Output Port 10' of 'dynamic_model_stateflow/Chart' is a one dimensional vector with a maximum of 1 elements.
Component:Simulink | Category:Model error
Error occurred in 'dynamic_model_stateflow/Chart'.
Component:Simulink | Category:Model error
I thought that these extra two ports (9 and 10) are related to the two Simulink functions, so, I tried to remove the functions and make it dummy model (runs on simple transition conditions and without setting the integrator states), and it worked but I need the model to include these functions. Port 10 is not visible to meand cannot do anything to change its properties.
How may I solve the problem?

回答 (0 件)

カテゴリ

Help Center および File ExchangeSimulink Functions についてさらに検索

製品


リリース

R2020b

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by