MATLAB Answers

EPS export problems in R2014b

10 ビュー (過去 30 日間)
Remco
Remco 2014 年 10 月 21 日
コメント済み: Qisq 2018 年 3 月 12 日
I have recently upgraded to R2014b (Linux version), and now exporting figures to eps seems to have a strange bug. If I try the following from the command line, I get the expected outcome. plot(1:3,2:4);print(gcf,'-depsc', 'testFromCommandLine.eps');
However, if I run the exact same script from the editor window, I get an eps file with a graph that occupies the top left corner of the canvas.
The only code in the script is: close all; plot(1:3,2:4); print(gcf,'-depsc', 'testFromScript.eps')
The screenshots of the two generated eps files are embedded.
This happens in all these three cases: pressing the RUN button in the editor, selecting the code and running the selection and executing the script (just typing the script's name without .m) from the command line.
  2 件のコメント
William Thompson
William Thompson 2014 年 10 月 29 日
UPDATE: The following code will *almost* work (see comments below):
epsfig = hgexport('factorystyle');
epsfig.Format = 'eps';
x = randn(10,1);
y = randn(10,1);
figure
set(gca,'FontSize',30)
set(gcf,'Units','normalized')
plot(x,y,'o')
title('Title','FontSize',30);
xlabel('X Label','FontSize',30)
ylabel('Y Label','FontSize',30)
set(gca,'box','on')
set(gcf,'OuterPosition',[0.1 0.1 0.7 0.7])
saveas(gcf,strcat('testfig','.fig'))
set(gcf,'PaperPositionMode','auto')
hgexport(gcf,'filename',epsfig,'Format','eps')
close(gcf)
It appears that hgexport is a lower-level function used by the File > Save As command (hence explaining the observations of Remco). The file produced with the above code snippet renders OK on Mac (Mavericks). BUT: when the file is opened, it gives a warning about font conversion.
There are also some cross-platform issues. If you use latex symbols, e.g.,
title('\Delta Title','FontSize',30)
this will not render. Changing to
title('$\Delta$ Graphics','FontSize',30,'interpreter','latex');
will render fine on the Mac, but gives bizarre results (missing axis tick labels) on Windows (XP).
Basically, Mathworks needs to take a hard look at this. EPS graphics are near-universal for scientific publication, and if 2014b cannot do it properly, that is a major issue.

サインインしてコメントする。

採用された回答

Bruno Pop-Stefanov
Bruno Pop-Stefanov 2014 年 10 月 22 日
Can you check the 'PaperPositionMode' property of the figure before printing it in each case? Try setting it to 'auto' before printing:
>> set(gcf, 'PaperPositionMode','auto')
Do you see the same behavior when printing to something else than .eps, for example .png?
>> print -dpng test.png
  5 件のコメント
Leonardo
Leonardo 2014 年 11 月 22 日
I am having the same problem, too. It is infuriating, and making it impossible to proceed with writing a paper for a journal that only accepts vector figures.
Not to mention, the file sizes are outrageously huge in 2014 compared to 2012.

サインインしてコメントする。

その他の回答 (7 件)

Jonathan
Jonathan 2014 年 10 月 24 日
Hi, I just upgraded to 2014b on OS X and neither of these fixes stops the .eps from being bounded by a full page when saved. I also tried changing groot as suggested, and even giving exact page sizes to match my figure window size but using either command line or script saving via saveas or print always returns the full page bounding box. Any other tips/things to try?
Using the dialog saveas works fine, why Matlab haven't implemented that as the default behaviour of saveas I have no idea.
  1 件のコメント
Leonardo
Leonardo 2014 年 11 月 22 日
Same here. I'm having the same problem and it is infuriating. Code which worked in 2012a now produces garbage pictures in 2014b. I've wasted hours and hours trying to get the old behavior back, to no avail. Also, the EPS files are now 10 times larger in file size than previous. Put it back the way it was!

サインインしてコメントする。


CHJY
CHJY 2015 年 7 月 20 日
Try this:
  1. set(gcf,'paperpositionmode','auto')
  2. print(gcf,'-depsc2','-loose','test.eps');
The '-loose' option affects how matlab defines the bounding box in the eps file.
  3 件のコメント
Qisq
Qisq 2018 年 3 月 12 日
Worked for me! Thank you Sir. Turns out MATLAB outputs tight bounding box that is inconsistent across different figures, so when I use epstopdf on them they are cropped to different dimensions!

サインインしてコメントする。


Gideon simpson
Gideon simpson 2014 年 11 月 3 日
I have the additional problem on OS X 10.9 that when I save figure eps figures (with latex labels) and open them in Preview.app, I get:
PostScript Conversion Warning:
Converting the PostScript file "test.eps" produced the following warnings: · CMR10 not found, using Courier. · CMMI10 not found, using Courier.
  1 件のコメント
Dawson Baker
Dawson Baker 2015 年 11 月 8 日
I have the same problem, and have not been able to figure it out.

サインインしてコメントする。


Viktor Vorobev
Viktor Vorobev 2015 年 2 月 15 日
I also have another problem. After exporting to EPS I used to edit the figure with CorelDRAW and everything was OK. But after exporting to EPS in 2014b (Win, x64), my CorelDRAW (X5, Win, x32) hangs while trying to import this EPS file.
With 2013b (Win, x64) everything works great.

PaVi90
PaVi90 2015 年 2 月 27 日
Same problem here. Is it possible that I have to downgrade to the blurry R2014a because of this? Unfortunately I desperately need exports in EPS in an automatic manner... :(

Daniel
Daniel 2015 年 6 月 25 日
編集済み: Daniel 2015 年 6 月 25 日
This problem persists in Matlab 2015a. Code which previously generated a correctly sized eps no longer does so. Instead, I get a letter-sized eps containing a fragment of my figure, with the box spilling over the edge. Hence, the visualization software I wrote is essentially broken for generating publication-quality vector graphics. A fix is desperately sought.

Shannon
Shannon 2017 年 11 月 23 日
Still having the same issues with 2016.
  1 件のコメント
Jan
Jan 2017 年 11 月 23 日
@Shannon: I find several problem descriptions and suggestions for solutions. Please explain, what exactly "the same issue" is, preferably with a small code example.

サインインしてコメントする。

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by