Simscape is aligning tyre wrong.

3 ビュー (過去 30 日間)
Volkan Eyidemir
Volkan Eyidemir 2021 年 11 月 19 日
コメント済み: Volkan Eyidemir 2021 年 11 月 25 日
I am designing a suspension system. However, when ı want to connect tie rod to the upright, it is connecting it from the other side by rotating the tyre 180 degree such that inside of the tyre is facing out. What can I do to make the program that it connecting tie rod to the upright in a correct tyre orientation.

採用された回答

Steve Miller
Steve Miller 2021 年 11 月 25 日
The initial position of the joints can be influenced using joint targets.
Those are set within the joint. Here is a screenshot of the Revolute Joint with the desired angle set to 180 deg.
You can check your assembly by opening the Simscape Variable Viewer.
Here is a screenshot showing that not all joints achieved their desired initial positions from model sm_double_wishbone_suspension
To learn more about this topic, read this documentation page: How Multibody Assembly Works.
If you are modeling suspensions, you also should take a look at the Simscape Vehicle Templates. This is a free set of templates for modeling vehicle dynamics and vehicle powertrains in Simscape. You can see many animations on this page:
--Steve
  1 件のコメント
Volkan Eyidemir
Volkan Eyidemir 2021 年 11 月 25 日
Thanks a lot. This helped me to solve my problem.

サインインしてコメントする。

その他の回答 (0 件)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by