この質問は閉じられています。 編集または回答するには再度開いてください。

When will MATLAB be updated for OS X Yosemite?

1 回表示 (過去 30 日間)
Parth Patel
Parth Patel 2014 年 10 月 16 日
When OS X Yosemite launches in the upcoming days (perhaps even today), will it be safe to update to OS X Yosemite from Mavericks? I ran the Yosemite Beta and MATLAB wasn't working so I had to downgrade back to Mavericks and MATLAB worked perfectly. I am aware of the workarounds for Yosemite, but will those work for the official release of Yosemite?
  8 件のコメント
Leo 2014 年 10 月 22 日
What Austin said below worked for me(2012a student) --reinstall XQuartz
-Re-installing XQuartz. I'm tempted to say this is the main reason why older versions of MATLAB are running into the issue as, after trying to open MATLAB in terminal, my computer indicated that the X11 files were missing after the update to Yosemite."
Mohammad reza nilchiyan
Mohammad reza nilchiyan 2014 年 10 月 27 日
Hi there, I installed new version of Os X Yosemite, but my Matlab 2012a doesn't work .could you please let me know how can I turn this version of Os X to my previous version? thanks

回答 (7 件)

Bhanu 2014 年 10 月 17 日
I was having the problem with MATLAB R2010a (already installed on my system) crashing when attempting to launch on 10.10 public release as well, but I just got it working without any need for Mathworks' patch or any strange modifications to system files! Maybe this will work with other versions too. Here's how:
1. Install latest release of X11/XQuartz (2.7.7). For some reason my X11 hadn't autoupdated.
2. Install legacy Java version 6 from Apple
3. Create symlink to /opt/X11 folder in /usr/
Instructions: open terminal, execute command exactly as follows (type password when asked): sudo ln -s /opt/X11/ /usr/X11
Now launch MATLAB and it should work. I noticed when launching MATLAB from /Applications/ -maci in terminal that it gave an error about not loading /usr/X11/lib/libXext.6.dylib; we can see that it is looking for a folder /usr/X11, but this is not present. Hence we create the symlink and everything works!
  10 件のコメント
Spase 2014 年 10 月 21 日
and also now I can't open the Mail, and reading from other forums it seems like it is related to this fix... :/
Javier 2014 年 10 月 21 日
Hi Spase, I didn't realize of java exception when running help. However, see the Tom comment below. By copying the provided patch in the /Applications/MATLAB_R2010b/java folder I can now run the help like a charm :).
Regarding the Mail error. Did you modify the ProductVersion or ProductUserVisibleVersion keys in the /System/Library/CoreServices/SystemVersion.plist file? I have read several solutions that involve modifying those keys. If so, try to revert the changes. Mines look like this:
Good luck again!

Ken Atwell
Ken Atwell 2014 年 10 月 17 日
MATLAB supports Yosemite as-of R2014b. Older release may also work, but this is not something MathWorks has rigorously tested. There were troubles in several the beta builds of Yosemite, but the final release of Yosemite has been reported to work well with MATLAB.
  10 件のコメント
Image Analyst
Image Analyst 2014 年 10 月 21 日
Yavuz: most likely there will be none. Historically, only the "a" versions, released annually in March, have had student versions.
Ken Atwell
Ken Atwell 2014 年 10 月 21 日
With that MathWorks patch at, you should be able to use MATLAB releases as far back at R2012a on Yosemite. Be sure to download the patch that matches your release of MATLAB.

Marco 2014 年 10 月 20 日
Is this really a MATLAB issue, or more a Yosemite issue which then should better be adressed directly to Apple? I heard that other software packages (i.e. professional music software) also have severe trouble with it (not running anymore).
  1 件のコメント
Ken Atwell
Ken Atwell 2014 年 10 月 21 日
Marco, yes and no. There are two issues at play:
  • Initial releases of Yosemite blacklisted some releases of MATLAB. This was corrected in an update released as Yosemite went gold. We hope most users get this update within hours of installing Yosemite (so this problem should age out in the days/weeks to some). See for details.
  • Once you are past the blacklisting, all MATLAB release except R4014b will need a patch or MATLAB may abort suddenly, on start-up in many situations. This problem is detailed at

Tom 2014 年 10 月 20 日
Here is a patch I made from Mathwork's official patch. It works on versions prior to R2013b (unlike the official patch) without modifying the SystemVersion.plist. I've confirmed R2013a and R2012b but I assume others will work as well.
To install:
  1. Extract
  2. Right click on in your Applications directory and click "Show Package Contents"
  3. Place the extracted folder (named "patch") into the folder (alongside the existing jar and jarext folders)
You may still need to run Matlab by double clicking To avoid this you can temporarily change your SystemVersion.plist (as described in other posts here), launch Matlab, change the SystemVersion.plist back, and now Matlab will work by double clicking the .app.
  1 件のコメント
Javier 2014 年 10 月 21 日
Thank you Tom. I was able to run matlab with other solutions, however, the matlab help was throwing me a java exception. With your solution I can run the help without any problem.

Hongbo Miao
Hongbo Miao 2014 年 10 月 17 日
  2 件のコメント
William 2014 年 10 月 17 日
Mine is 2012a and the patch doesn't work. Any suggestion ?
Bob 2014 年 10 月 18 日
i got the same problem with 2012a!

Balaji 2014 年 10 月 20 日
MathWorks has released patches/workarounds for the two main issues
1) "You can't use this version of the application" error.
If you have the latest 10.39 or later update from Apple,this issue should not occur. But in the case that it does,you can use either of the two workarounds mentioned in the above link.
2)Java crash upon MATLAB.
This patch addresses the Java issue.
Accept/comment on this answer if it works so that other users can benefit from it.
  2 件のコメント
Philip 2014 年 10 月 20 日
Java patch doesn't fix R2013a_Student...maybe others, I don't know.
Ken Atwell
Ken Atwell 2014 年 10 月 20 日
Correct, the patch for the Java crash works with R2014a and R2013b only.

Austin 2014 年 10 月 20 日
I was running the student version of R2012a before updating to Yosemite and was greeted with the "You can't run this application on this version of OSX" after the update. Fortunately, after trying a few things I was able to get MATLAB up and running again. This is what I did that I believed fixed my copy:
-Re-installing XQuartz. I'm tempted to say this is the main reason why older versions of MATLAB are running into the issue as, after trying to open MATLAB in terminal, my computer indicated that the X11 files were missing after the update to Yosemite.
-Installing the most recent version of Java on my computer. I'm not 100% sure this is mandatory for the fix, but I did update Java after the update and a lot of people are noting that this was necessary for a fix.
I can't say I've tested this fix enough to know for certain that this solution will work in all instances, but my version is working fine now after doing the above. Best of luck!

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by