Simulink - TI Piccolo F2803x eQEP block not working properly

7 ビュー (過去 30 日間)
Samira Tungare
Samira Tungare 2021 年 11 月 15 日
回答済み: Chidvi Modala 2021 年 11 月 18 日
I am trying to configure the eQEP block for my system and am running into issues with getting it set up properly. Therefore, when we run the motor I am using we see that the position waveform seems to be shifting. When looking at some help documents I noticed that under Model Configuration Parameters -> Hardware Board Settings -> Target Hardware Resources there should be an eQEP tab which would allow me to check/configure the pin assignments. I have tried using both Matlab2019 and Matlab2021a and do not have this option available in the Model Configuration Parameters (see image). Does anyone know how to solve this issue?

回答 (1 件)

Chidvi Modala
Chidvi Modala 2021 年 11 月 18 日
Hi Samira,
The “Target hardware resources” groups shown differ by hardware board and only appear when there are multiple options to choose from for that group. For the TI Piccolo F2803x, it is expected that the eQEP parameter would not appear since there are not multiple options for the eQEP pin assignments.
In the Texas Instruments documentation for the TI Piccolo F2803x, it states that EQEP1A is assigned to GPIO20, EQEP1B is assigned to GPIO21, EQEP1S is assigned to GPIO22, and EQEP1I is assigned to GPIO 23. Since each eQEP pin can only be assigned to one corresponding GPIO pin for this hardware board, there is no eQEP parameter since there are no options for alternative pin assignments. If there are multiple options for eQEP pin assignments like for the TI Piccolo F2805x board, then eQEP will show up under groups and there will be a dropdown menu for each eQEP pin than can be assigned to multiple GPIO pins (see image below).

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by