Installer hang when installing Matlab R2021b as root on Ubuntu 20.04

1,619 ビュー (過去 30 日間)
My operating system is Ubuntu 20.04 LTS. I must install Matalb as root, and always have done. This is historic as all specialist programs are installed in /opt.
I have now downloaded MATLAB R2021b and the Installer hang when installing Matlab R2021b as root on Ubuntu 20.04, the command sudo ./install just hangs with a blinking cursor, no Matlab install GUI is displayed.
As first attempted solution I have created a MATLAB/R2021b folder in /opt, that did not help.
I have also tried to install R2021b normally with defaults but although now I progress nicely to the Matlab GUI, but the default location /usr/local/MATLAB/R2021b cannot created/located and then I have to aboard.
I have always had to install MATLAB as root.
Any advice on getting the MATLAB install GUI to display on Ubuntu R2021b will be appreciated.
Thank you
  8 件のコメント
SEO Service
SEO Service 2021 年 10 月 21 日
It seems to be working for me now!

サインインしてコメントする。

採用された回答

El'ad Gips
El'ad Gips 2021 年 9 月 30 日
this tip:
(run the command : xhost +SI:localuser:root)
and after
sudo ./install
worked for me (matlab 21b and ubuntu 20.04)
  11 件のコメント
Olivier Alexander S Wartique
Olivier Alexander S Wartique 2021 年 12 月 2 日 7:44
Worked for me on Ubuntu 20.04 - Matlab R2021b

サインインしてコメントする。

その他の回答 (1 件)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by