フィルターのクリア

I can't write a Raspbian image to certain SD cards using the Raspberry Pi support package

7 ビュー (過去 30 日間)
John
John 2014 年 3 月 26 日
コメント済み: BOUREZIG sidahmed 2022 年 6 月 14 日
I've been trying to use the Raspberry Pi support package to set up Simulink models on my Raspberry Pi, but the SD cards that came with the kit I have don't seem to work. These are 8 GB SD cards that already come with installation software that is meant to be run just using the Pi itself, but I wanted to over-write them with the image from the support package so that I could be sure they will work with MATLAB.
I'm wondering if maybe I should have ran raspi-conf first to expand the card size, because the setup instructions I read seemed to indicate they don't come fully expanded. They start out with a small size that is supposed to be expanded in raspi-conf, and when I tried to write the new image onto them using the support package, not only did I get a vague error message about how the SD card could not be written to, but viewing the card itself in explorer now says it is only 56 megabytes in size with some little files in it that weren't on it before. The linux software seems to be gone too, because the raspberry pi can't boot with the card anymore.
I've tried using the SD card formatting tool that the raspberry pi website operators recommend, but it doesn't seem to have any effect on the result. Even if I re-size them, they just get shrunk back to 56 MB when MATLAB fails to write the Raspbian image. I can use brand new SD cards fine with no errors from MATLAB, but i'd really like to know why the cards that came with the Pi don't seem to work for me.

回答 (5 件)

Murat Belge
Murat Belge 2015 年 3 月 24 日
Start MATLAB using "Run as administrator". Right click on the MATLAB icon and choose "Run as administrator" in the popup menu. Then on the MATLAB command line:
>> targetupdater
This will drop you the second portion of the install. Follow the instructions.
  7 件のコメント
BOUREZIG sidahmed
BOUREZIG sidahmed 2022 年 6 月 14 日
Worked for me thank you

サインインしてコメントする。


Murat Belge
Murat Belge 2014 年 3 月 27 日
The SD card for Raspberry Pi has two partitions: one is a FAT partition of small size and the other is a Linux EXT partition. Your Windows computer cannot read the EXT partition and shows only the FAT partition. This is what you are seeing when you look at the SD card on your Windows computer. If you were to use a Linux computer, you would be able to see both partitions.
What exactly is the error message reported by the Support Package Installer when writing to the SD card?
  2 件のコメント
Md. Ashfaque
Md. Ashfaque 2015 年 3 月 24 日
Hi I have a similar problem. Every time I try to click refresh in order for SupportPackageInstaller to install the Raspbian image on the sd card...there is a message that shows enumerating sd card devices and then i get an error that says sdwriter.exe has stopped. Nothing else can be done. Is there a workaround for this issue?
Shogan Aversa-Druesne
Shogan Aversa-Druesne 2015 年 5 月 14 日
You need to copy the mcf110u.dll into the same directory as the sdwriter.exe. The DLL is found in MATLAB/bin/win64

サインインしてコメントする。


Greg Buffinton
Greg Buffinton 2016 年 1 月 29 日
編集済み: Greg Buffinton 2016 年 1 月 29 日
I had to set "Run as Admin" in 2 locations. Right click on the matlab icon on the desktop and go to properties. 1> click "Advanced", tick "Run as administrator", click ok 2> click "Compatibility" tab, tick "Run this program as administrator", click ok.
After that I ran matlab, typed in targetupdater and this time the support package installer found my drives.
Hope this helps!
Edit: This was for Win8.1

tcn0002
tcn0002 2015 年 5 月 14 日
has anyone figured out the solution to this?

vishal pattni
vishal pattni 2017 年 6 月 16 日
IS it possible to write R.Pi support package and Simulink support package for R.pi in a single SD card?

カテゴリ

Help Center および File ExchangeMATLAB Support Package for Raspberry Pi Hardware についてさらに検索

製品

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by