MATLAB Compiler

MATLAB Runtime

MATLAB をインストールせずにコンパイル済みの MATLAB アプリケーションやコンポーネントを実行

MATLAB Runtime はスタンドアロンの共有ライブラリ セットで、コンパイル済みの MATLAB アプリケーションやコンポーネントを実行できます。MATLABMATLAB Compiler、MATLAB Runtime を組み合わせて使用すると、多数のアプリケーションやソフトウェア コンポーネントを安全かつ迅速に作成、配布できます。

MATLAB Runtime は次の手順でダウンロードしてインストールします:

  1. 以下の表を参照して、ご使用のアプリケーションやコンポーネントに対応するバージョンとプラットフォームをクリックしてください。MATLAB Runtime のバージョンは MATLAB のバージョンに対応しています。

    注:この情報は、アプリケーションやコンポーネントに付属の readme.txt ファイルに収録されています。

  2. アプリケーションまたはコンポーネントを実行するコンピューターに MATLAB Runtime のインストーラー ファイルを保存します。

  3. インストーラーをダブルクリックして、インストール ウィザードの指示に従います。

詳細については、MATLAB Runtime インストーラーのドキュメントをご覧ください。

Release (MATLAB Runtime Version#) Windows Linux Mac
R2018b (9.5)
64-bit
64-bit
Intel 64-bit
R2018a (9.4)
64-bit
64-bit
Intel 64-bit
R2017b (9.3) 64-bit 64-bit Intel 64-bit

MATLAB Runtime の R2016a ~ R2017a バージョンでは、インストール後に更新を適用してください。

MATLAB Runtime の R2016a、R2016b、R2017a の各リリースでは、重要なセキュリティ パッチが提供されています。これらの MATLAB Runtime リリースのいずれかをインストールした場合、下記のうち適切な更新のリンクをクリックして最新の更新を適用してください。この操作は、MATLAB App Designer を使用して作成された MATLAB アプリ (.mlapp ファイル) を配布先で使用する場合にのみ必要です。詳細については、バグ レポートをご覧ください。

R2017a (9.2)
64-bit   |   Update 64-bit   |   Update Intel 64-bit   |   Update
R2016b (9.1)
64-bit   |   Update 64-bit   |   Update Intel 64-bit   |   Update
R2016a (9.0.1) 1, 2 64-bit   |   Update 64-bit   |   Update Intel 64-bit   |   Update
R2015b (9.0) 1, 2, 3 32-bit / 64-bit 64-bit Intel 64-bit
R2015aSP1 (8.5.1) 1 32-bit / 64-bit 64-bit Intel 64-bit
R2015a (8.5) 1 32-bit / 64-bit 64-bit Intel 64-bit
R2014b (8.4) 1 32-bit / 64-bit 64-bit Intel 64-bit
R2014a (8.3) 1 32-bit / 64-bit 64-bit Intel 64-bit
R2013b (8.2) 32-bit / 64-bit 64-bit Intel 64-bit
R2013a (8.1) 32-bit / 64-bit 64-bit Intel 64-bit
R2012b (8.0) 32-bit / 64-bit 64-bit Intel 64-bit
R2012a (7.17) 32-bit / 64-bit 32-bit / 64-bit Intel 64-bit
R2011b またはそれ以前 4

MATLAB を開いて mcrinstaller コマンドを実行し、MATLAB Runtime の場所を指定してコンパイル済みのコンポーネントを再配布します。

注意事項

  1. 1. R2014a ~ 2016a では、macOS Sierra 10.12 をサポートしていません。これらのバージョンの MATLAB Runtime をサポート対象外のバージョンの macOS で実行する場合、修正パッチをインストールして互換性の問題を解決する必要があります。非互換性による影響があるかどうかを判断するには、詳細をご覧ください。MathWorks では、macOS Sierra 10.12 で R2014a より前のバージョンの MATLAB Runtime を実行しないことを強くお勧めします。
  2. R2016a バージョン用の MATLAB Runtime 9.0.1 は、R2016a バージョンの MATLAB 9.0 で動作することを想定しています。
  3. R2015b バージョン用の MATLAB Runtime 9.0 は、R2015b バージョンの MATLAB 8.6 で動作することを想定しています。
  4. オンライン バージョンの MATLAB Runtime は、R2012a 以降のリリースでのみ使用できます。古いリリースの MATLAB Runtime は、MATLAB Compiler に同梱されています。MATLAB をお持ちでない場合は、配布パッケージを作成した MATLAB Compiler ユーザーに MATLAB Runtime をご依頼ください。