MATLAB Answers

Problems with a down arrow displaying in a plot

85 ビュー (過去 30 日間)
10B
10B 2017 年 4 月 25 日
コメント済み: KL 2017 年 4 月 25 日
Hello Community,
I have recently re-run a bit of code to display a plot, and there is an error that has occurred without my changing the code. In the plot text, there was a 'down arrow' showing, but now, the syntax '\downarrow' appears in its place. Ive looked on Mathworks and I think there is a problem associated with a service pack (though I may be wrong on this!).
I have also tried to set LateX interpreter to 'on', code below:
% Turn on LateX Interpreter
set(0,'Interpreter','latex');
then run the following text command:
% Create text
text('Parent',subplot2,'String',{'\downarrow 1(D)'},...
'Position',[35.2026613558799 5703.42205323194 0]);
but I still get the following error:
Warning: Error updating Text.
Character vector must have valid interpreter syntax:
\downarrow 1(D)
Could any kindly soul advise on how I can workaround this please?
Regards,
10B.

採用された回答

KL
KL 2017 年 4 月 25 日
Like this?
text(35.02,5703.42,'$\downarrow 1(D)$','Interpreter','latex')
  2 件のコメント
KL
KL 2017 年 4 月 25 日
From what I understand, it's just part of the syntax so Matlab knows what's between dollar symbols should be converted into latex specs.

サインインしてコメントする。

その他の回答 (0 件)

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by