Arduino simulink problems seems to be a theme

1 ビュー (過去 30 日間)
Robert
Robert 2017 年 1 月 15 日
So I'm trying to explore simulink and arduino a bit
Just followed a basic example
Cant get it to work
I continue to get a common error that i have found many posts on but non of the listed solutions have fixed my issues
2016B version
Arduino Uno
I can't even post the error to the forum because its so big
/Users/RboklemanMAC/Documents/MATLAB/SupportPackages/R2016b/toolbox/target/supportpackages/arduinotarget/registry/../scheduler/src/arduinoAVRScheduler.cpp: In function 'void configureArduinoAVRTimer()':
/Users/RboklemanMAC/Documents/MATLAB/SupportPackages/R2016b/toolbox/target/supportpackages/arduinotarget/registry/../scheduler/src/arduinoAVRScheduler.cpp:66:3: error: 'SETUP_PRESCALER' was not declared in this scope
SETUP_PRESCALER;
^
gmake: *** [arduinoAVRScheduler.o] Error 1
### Build procedure for model: 'Arduino_test' aborted due to an error.
Error(s) encountered while building "Arduino_test":
### Failed to generate all binary outputs.
I have found many posts about this error message but none of the fixes have worked for me
does anyone have any ideas?
Thanks

回答 (2 件)

Chinmayi Lanka
Chinmayi Lanka 2017 年 1 月 20 日
I would recommend that you go through the following documentation and try to execute the example models mentioned in the document: http://www.mathworks.com/help/supportpkg/arduino/examples/getting-started-with-arduino-hardware.html
If you are able to run the example models but not your model, please share the build log (you can attach it as a text file).

amina ibrahim
amina ibrahim 2019 年 2 月 6 日
the same problem with me
  1 件のコメント
Madhu Govindarajan
Madhu Govindarajan 2019 年 2 月 7 日
Have you tried uninstalling and reinstalling MATLAB support package for Arduino and Simulink support package for Arduino when you have administrator access?

サインインしてコメントする。

カテゴリ

Find more on Simulink Support Package for Arduino Hardware in Help Center and File Exchange

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by