Unable to change default radio button in button group

5 ビュー (過去 30 日間)
David K
David K 2021 年 9 月 27 日
コメント済み: Cris LaPierre 2021 年 9 月 27 日
I am building an app in appdesigner which contains a Radio Button Group. I recently decided to add a new radio button option to the button group and want to set it as the new default value on startup. I did this by copying and pasting an existing button. In the Component Browser the new radio button is listed as a child of the button group in the same list as the old buttons.
The problem I'm encountering is that when I try to select the Value checkbox for the new radio button, it automatically changes it to one of the others. Why would this be happening, and how can I fix it? As far as I can see, all of the properties visible in the Inspector tabs are the same for the old and new buttons.

採用された回答

Cris LaPierre
Cris LaPierre 2021 年 9 月 27 日
編集済み: Cris LaPierre 2021 年 9 月 27 日
I discovered that your workflow works for a brand new radio button group. However, once I close the app and reopen it, if I try to add another button, I see the behavior you report. I tested in R2019b, R2020b, and R2021b. This looks like a bug to me. Please report it here.
In the meantime, the workaround might be to recreate your radio button group with all the buttons.
  2 件のコメント
Cris LaPierre
Cris LaPierre 2021 年 9 月 27 日
Good idea.

サインインしてコメントする。

その他の回答 (0 件)

カテゴリ

Find more on Desktop in Help Center and File Exchange

製品


リリース

R2019a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by