Can't use attachDatabase

2 ビュー (過去 30 日間)
Korbinian Kohl
Korbinian Kohl 2020 年 10 月 7 日
コメント済み: Jason Matthews 2020 年 10 月 21 日
Hello,
i am working on a script which will get Data from a CAN device (Vector CANCaseXL).
So far i got everything to run, but now i face the problem, that i can't attach the CanDB with the attachDatabase function.
Unrecognized function or variable 'attachDatabase'.
Error in WorkflowCAN (line 24)
attachDatabase(msg,canDB)
Looks like the attachDatabase function can't be found by Matlab, which surprises me, because all other functions of the vehicle network toolbox work like a charm.
I already tried rehash and reinstalling the Toolbox, also i have this problem on two different Computers. One with R2020a and the other with R2019b.
Anything else I could Try?
Or do I have it to do it on my own with assigning the Message_ID form the DBC File with the recieved Messages?
Kind regards,
Korbinian
EDIT: I tried a third PC (R2019a) an the Issue is still the same
EDIT2: One more PC and still the same Problems, but the canMessageTimetable Function does the Job i want. I will let this question open, if someone else faces that problem (and maybe some Matlab Staff sees it to investigate further)
  1 件のコメント
Jason Matthews
Jason Matthews 2020 年 10 月 21 日
Using 2018b, and I see the same error. Additionally I do not see this function in the vnt toolbox.

サインインしてコメントする。

回答 (0 件)

製品


リリース

R2020a

Community Treasure Hunt

Find the treasures in MATLAB Central and discover how the community can help you!

Start Hunting!

Translated by